Jump to content

Photo

If SE fails to start BEFORE getting to the main menu and you use a laptop(with Nvidia), try this:


  • Please log in to reply
2 replies to this topic

#1
EveningTide

EveningTide

    Enthusiast

  • Account closed
  • PipPip
  • 132 posts

If you have a gaming laptop, it's likely you have two graphic processors. One for display and another that is used as a rendering engine.

 

If you have a Nvidia processor, then you need to go into the Nvidia control panel, go to "Manage 3D settings" and then head to "Program Settings".

 

It'll take a bit to load.

 

You should see a drop down and buttons next to it. From the scroll down, look for Skyrim SE executable, then click "Add".

 

Now go to the section below that says:

 

2. Select preferred graphics processor for this program:

 

Here you need to select your Nvidia processor because it'll be your integrated gpu by default.

 

Repeat the above for the Skyrim Special Edition Launcher executable as well. This will enable it to redetect your GPU.

This is what causes SE to max your CPU out and crash as the integrated processor is trying to load a program way too powerful for it.

 

 



#2
EveningTide

EveningTide

    Enthusiast

  • Account closed
  • PipPip
  • 132 posts

I also run Windows 10, so I can say this is not an OS issue.



#3
SMB92

SMB92

    Resident poster

  • Premium Member
  • 4,325 posts
Thanx for posting this. Also to be on the safe side, be sure to select "prefer maximum power" if it offers you this.




Page loaded in: 0.947 seconds