Jump to content

Photo

SSE NIF Optimizer


  • Please log in to reply
1810 replies to this topic

#991
ousnius

ousnius

    Resident poster

  • Premium Member
  • 9,978 posts
In response to post #54247678. #54249898, #54251498 are all replies on the same post.


Spoiler

If you select the old BSInvMarker and new BSInvMarker blocks in NifSkope, you will see that they're unchanged.

#992
Brandon007

Brandon007

    Retired Commonwealth Spartan Author

  • Premium Member
  • 3,472 posts
In response to post #54247678. #54249898, #54251498, #54251603 are all replies on the same post.


Spoiler

Then the converter has changed something else in the nifs that make them look differently.

#993
ousnius

ousnius

    Resident poster

  • Premium Member
  • 9,978 posts
In response to post #54247678. #54249898, #54251498, #54251603, #54252283 are all replies on the same post.


Spoiler

It seems like the mod doesn't have separate ground object/inventory meshes. You have to edit the plugin to point to new separate meshes for inventory/ground, then you need to copy the other NIFs there and turn off their skinning completely.

You can turn off skinning by loading the mesh into Outfit Studio, double-clicking each shape in the list to the right and unchecking the "Skinned" checkbox.

Currently, it's not possible to do this in NifSkope.

The issue happens because the ground object is skinned and the NIF Optimizer recalculates the bounds for these. There's no way around this from my side, you have to fix the mod itself.

Edited by ousnius, 09 October 2017 - 01:46 PM.


#994
Brandon007

Brandon007

    Retired Commonwealth Spartan Author

  • Premium Member
  • 3,472 posts
In response to post #54247678. #54249898, #54251498, #54251603, #54252283, #54254208 are all replies on the same post.


Spoiler

I cant load the nifs in outfit studio unfortuantely, the models look like they have exploded, and currently are unworkable.

#995
Mebantiza

Mebantiza

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 3,836 posts
In response to post #54246723. #54249848, #54250963, #54251508 are all replies on the same post.


Spoiler

I know the first three are, those are the from the attempt I made, the first three were not already optimized, they are from 2014, but do not seem to have the problem you mention.

Looking at the rest, it was just that one nif alone that gave NO fits-all the other optimized fine.

Thank you for looking at it, Ive never seen NO hang before so I thought I would report it. If something like it should happen again(doubtful), I know what to look for now.

Thank you.

Edited by Mebantiza, 09 October 2017 - 05:48 PM.


#996
dunc001

dunc001

    Faithful poster

  • Premium Member
  • 1,519 posts
In response to post #54237533. #54238443, #54246298 are all replies on the same post.


Spoiler

Thank you for the sympathy vote! My own fault for not reading stuff! Anyway, a day and a half later I'm now back to square one and ready to optimize the whole lot again. I have used Spluff to output all the winning meshes from my MO profile so I can work on them there and leave the mods original in case I do something daft again!

So from that I've separated out (by copying) meshes/actors and am currently going through and removing anything that is not Headparts. I'll then optimize the main output folder with the default optimization, and the thinned out actors folder with the head parts only optimization. I'll then load them in MO in that order and all should be good for the entire load order.

Spluff is an awesome tool for this sort of stuff as it saves you from having to manually work through hundreds of individual mods.

Edit - OK, I've just noticed in a couple of posts here you include hair, beards, etc as headparts. Does that mean I have also incorrectly processed everything in for example Apachi and KS Hairdos, Art of the Beard, etc? Is it literally everything head related? Are there any exceptions? Sorry for all the questions but I don't really want to go through all this again if I get it wrong! And what will happen in game of I miss correcting something I did wrong first time round?

Edit again - Actually Apachi and KS are the SE versions. Does that mean that when I ran the full optimization NifOpt would have skipped them and not done any damage?

Edited by dunc001, 10 October 2017 - 06:50 PM.


#997
2H34M

2H34M

    Enthusiast

  • Members
  • PipPip
  • 177 posts
Hi, big thx for this realy helpful tool. :)

Is it possible to add a new option for auto renaming the "0 NiNode" to "Scene Root" or maybe add own name via textfield?

#998
ousnius

ousnius

    Resident poster

  • Premium Member
  • 9,978 posts
In response to post #54364808.


Spoiler

The question is why?

#999
mpjbay

mpjbay

    Faithful poster

  • Premium Member
  • 1,317 posts
Thank you for making this tool. <3

#1000
2H34M

2H34M

    Enthusiast

  • Members
  • PipPip
  • 177 posts
In response to post #54364808. #54367293 is also a reply to the same post.


Spoiler

Ich antworte mal in deutsch. Ist einfacher dann zu erklären. (du kannst doch deutsch, wenn ich dein Profil so anschaue oder?) :)
Aktuell arbeite ich an einem Armor Replacer für meinen Custom Body.
Dabei konvertiere ich aber nicht einfach nur den Body sondern versuche neue Outfits zu entwerfen mit den vorliegenden Shapes.
Ich mixe also unterschiedliche Meshes und forme sie zu etwas Neuem.
Problem ist dabei immer das viele Mods, vorallem ältere, ihre 0 NiNode nicht Scene Root nennen.
Beim Copy & Paste in Nifskope muss ich das halt immer erst umbenennen damit kein Error aufkommt.
Ist dann bei gefühlt 100 Meshes irgendwann einfach nur nervig.
Daher die Frage. Es würde einfach ein paar Arbeitsschritte einfacher machen. ;)




IPB skins by Skinbox
Page loaded in: 0.850 seconds