Jump to content

Photo

Creation Kit Allow Multiple Masters Not Working

creation kit allow multiple masters data ini help

  • Please log in to reply
7 replies to this topic

#1
SickMods1111

SickMods1111

    Journeyman

  • Members
  • Pip
  • 20 posts

As the title says, I can't get the Creation Kit to load multiple master files.

I've added the "bAllow" line to the Custom Creation Kit INI I created. I also tried putting it under General in the other two Creation Kit INI's.

 

I also changed the "SresourceArchives" line to match my DLC list.

 

No matter what I do, I get the Multiple Masters load error. PLEASE help me fix this so I can get back to creating FREE mods. There's got to be something stupid I'm missing. Unless Bethesda just updated the kit and ruined it or something since Creation Club just came out. This day has been a Bethesda disaster.



#2
beebscalicor

beebscalicor

    Enthusiast

  • Premium Member
  • 116 posts

Hey @sickmods111 - I had the same issue but I DID solve it, and it does work now. The issue was three-fold for me.

  1.  A lot of the suggested lines I found online for enabling multiple master file loading were typed wrong, or they were slightly off, or they were just flat out incorrect. I eventually found the "right" line that needs to be added. (the second line in my example below)
     
  2. There was actually a conflicting line in my CreationKit.ini and CreationKitCustom.ini files. The line was buried in the middle of the settings in the [GENERAL] section, so I hadn't seen it. It was the same line I added but it was set to zero, and it was "under" my new line. It was overriding my line and turning master loads back off again whenever the kit loaded. So... 
     
  3. ... I made a backup of both ini files and chose to delete the conflicting line from both of them. Technically you should be able to delete the conflicting line from the CreationKitCustom.ini only and it should work (in fact that is the recommendation). But I chose to do a backup and delete the line from both files (your choice). In any case, It finally worked.
     

Here are the lines I added 

[GENERAL]

bLoadMultipleMasterFiles=1
bAllowMultipleMasterLoads=1
aAllowMultipleEditors=1

- Yes I know the first two are similar.  But, the second line is the one you absolutely must have in there.  That's the magic line that everyone needs to have, and nothing can be below it that contradicts it or turns it off.  As for the first line... well, when I finally got it working I had both lines in there, I got sick of messing with it, so I just decided to keep both lines. It doesn't hurt anything to have both lines in there in this case, especially since the valid line is below the invalid/less-valid line. But it's up to you. Just know that the second line is the one you have to add for sure - it's mandatory. 

The third line is a good idea to add anyway, because it enables you to have another copy of the Creation Kit open (for browsing vanilla files for example). I got that setting idea from Kinggath, the mod author of Sim Settlements in his Builders Toolkit.

Having another copy of the CK to browse files in, instead of browsing vanilla files while you are making a mod, is a good idea- because it's too easy to accidentally edit a vanilla file you might have open for research purposes. The edit could get saved with your mod and cause issues.  This is a good setting to put in there even if haven't used it. This setting doesn't hurt anything being in there, and it just gives you another option. But this third line is totally optional.

Anyway, good luck and I hope this helps you solve your multiple master file loading issue.  Let me know how it goes. 



#3
Handicraft

Handicraft

    Old hand

  • Premium Member
  • 530 posts

Thank you !!!

This is very helpfull, ihad the same problem.



#4
beebscalicor

beebscalicor

    Enthusiast

  • Premium Member
  • 116 posts

Thank you !!!

This is very helpfull, ihad the same problem.

 

Awesome - I'm glad you found this helpful! 



#5
Flowerguy360

Flowerguy360

    Old hand

  • Premium Member
  • 916 posts

 

Hey @sickmods111 - I had the same issue but I DID solve it, and it does work now. The issue was three-fold for me.

  1.  A lot of the suggested lines I found online for enabling multiple master file loading were typed wrong, or they were slightly off, or they were just flat out incorrect. I eventually found the "right" line that needs to be added. (the second line in my example below)
     
  2. There was actually a conflicting line in my CreationKit.ini and CreationKitCustom.ini files. The line was buried in the middle of the settings in the [GENERAL] section, so I hadn't seen it. It was the same line I added but it was set to zero, and it was "under" my new line. It was overriding my line and turning master loads back off again whenever the kit loaded. So... 
     
  3. ... I made a backup of both ini files and chose to delete the conflicting line from both of them. Technically you should be able to delete the conflicting line from the CreationKitCustom.ini only and it should work (in fact that is the recommendation). But I chose to do a backup and delete the line from both files (your choice). In any case, It finally worked.
     

Here are the lines I added 

[GENERAL]

bLoadMultipleMasterFiles=1
bAllowMultipleMasterLoads=1
aAllowMultipleEditors=1

- Yes I know the first two are similar.  But, the second line is the one you absolutely must have in there.  That's the magic line that everyone needs to have, and nothing can be below it that contradicts it or turns it off.  As for the first line... well, when I finally got it working I had both lines in there, I got sick of messing with it, so I just decided to keep both lines. It doesn't hurt anything to have both lines in there in this case, especially since the valid line is below the invalid/less-valid line. But it's up to you. Just know that the second line is the one you have to add for sure - it's mandatory. 

The third line is a good idea to add anyway, because it enables you to have another copy of the Creation Kit open (for browsing vanilla files for example). I got that setting idea from Kinggath, the mod author of Sim Settlements in his Builders Toolkit.

Having another copy of the CK to browse files in, instead of browsing vanilla files while you are making a mod, is a good idea- because it's too easy to accidentally edit a vanilla file you might have open for research purposes. The edit could get saved with your mod and cause issues.  This is a good setting to put in there even if haven't used it. This setting doesn't hurt anything being in there, and it just gives you another option. But this third line is totally optional.

Anyway, good luck and I hope this helps you solve your multiple master file loading issue.  Let me know how it goes. 

 

 

Just checking to cover the bases: 

 

Is that third line intended to start with an "a", or is that a typo and should be "b"?

I only ask because I have an existing line in my ini that is "bAllowMultipleEditors=0" and I do not want to tell it to do two different things.

 

Thanks for this, btw.  :)



#6
fruitierracer42

fruitierracer42

    Regular

  • Members
  • PipPip
  • 57 posts

None of this worked for me... I have no idea what I'm doing wrong, but I literally copied and pasted everything, even changed the sResourceArchive2 list to include all the DLC, but nothing is working. I've noticed that it WILL allow me to open the Fallout4 master file along with ONE additional master, but that's it. It's not letting me do all 6 at the same time. This is getting super frustrating, as I don't understand why this isn't a default action for the creation kit... Any help would be greatly appreciated!



#7
grrlie

grrlie

    Enthusiast

  • Members
  • PipPip
  • 145 posts

One of the things that you might consider is:

 

1) launching the Bethesda.net launcher

2) selecting Fallout 4 Creation Kit (CK)

3) select  "game options" in the upper right hand corner

3.1)  select "scan and repair" - make sure that you've backed up your ini files.

 

Now that your Creation Kit files have been validated, open the CK, unzip the base.zip, overwrite the files there.

 

Close the CK

 

Now edit both the CreationKit.ini  and CreationKitPrefs.ini files to have these lines in this order:

 

[General]
bLoadMultipleMasterFiles=1
bAllowMultipleMasterLoads=1
bAllowMultipleEditors=1
 
Do NOT use baAllowMultipleEditors=1 or aAllowMultipleEditors=1  even though the list of commands has the baAllowMultipleEditors=1 in it ..... IT DOES NOT WORK.
 
Hopefully this will do the job for you.  (I hate when Bethedsa changes the ini files).
 
 

 



#8
SixthHouseCultist

SixthHouseCultist

    Newbie

  • Members
  • Pip
  • 12 posts

 

Hey @sickmods111 - I had the same issue but I DID solve it, and it does work now. The issue was three-fold for me.

  1.  A lot of the suggested lines I found online for enabling multiple master file loading were typed wrong, or they were slightly off, or they were just flat out incorrect. I eventually found the "right" line that needs to be added. (the second line in my example below)
     
  2. There was actually a conflicting line in my CreationKit.ini and CreationKitCustom.ini files. The line was buried in the middle of the settings in the [GENERAL] section, so I hadn't seen it. It was the same line I added but it was set to zero, and it was "under" my new line. It was overriding my line and turning master loads back off again whenever the kit loaded. So... 
     
  3. ... I made a backup of both ini files and chose to delete the conflicting line from both of them. Technically you should be able to delete the conflicting line from the CreationKitCustom.ini only and it should work (in fact that is the recommendation). But I chose to do a backup and delete the line from both files (your choice). In any case, It finally worked.
     

Here are the lines I added 

[GENERAL]

bLoadMultipleMasterFiles=1
bAllowMultipleMasterLoads=1
aAllowMultipleEditors=1

- Yes I know the first two are similar.  But, the second line is the one you absolutely must have in there.  That's the magic line that everyone needs to have, and nothing can be below it that contradicts it or turns it off.  As for the first line... well, when I finally got it working I had both lines in there, I got sick of messing with it, so I just decided to keep both lines. It doesn't hurt anything to have both lines in there in this case, especially since the valid line is below the invalid/less-valid line. But it's up to you. Just know that the second line is the one you have to add for sure - it's mandatory. 

The third line is a good idea to add anyway, because it enables you to have another copy of the Creation Kit open (for browsing vanilla files for example). I got that setting idea from Kinggath, the mod author of Sim Settlements in his Builders Toolkit.

Having another copy of the CK to browse files in, instead of browsing vanilla files while you are making a mod, is a good idea- because it's too easy to accidentally edit a vanilla file you might have open for research purposes. The edit could get saved with your mod and cause issues.  This is a good setting to put in there even if haven't used it. This setting doesn't hurt anything being in there, and it just gives you another option. But this third line is totally optional.

Anyway, good luck and I hope this helps you solve your multiple master file loading issue.  Let me know how it goes. 

 

 

You my friend are a LEGEND

 

every other forum online someone had spelled it wrong. Followed your approach here and I can confirm i had it spelled wrong

 

bAllowMultipleMasterLoads=1

 

 ^ is the correct line that needs to be entered.

 

if anyone else gets stuck, i hope to god they find your post.


Edited by SixthHouseCultist, 06 May 2020 - 02:50 AM.






Also tagged with one or more of these keywords: creation kit, allow multiple masters, data, ini, help

Page loaded in: 1.081 seconds