Jump to content

Photo

BOSS_API_ERROR_INVALID_ARGS: Plugins may not be sorted before Update.e


  • Please log in to reply
53 replies to this topic

#31
preslavb

preslavb

    Stranger

  • Supporter
  • Pip
  • 8 posts
Guys i think i understood how to fix the problem for the master files. For me, unchecking all of the esm-s and esp-s flagged as masters and then installing the mod that has the "plugins cannot be before masters" or something and then checking all the esm-s back on worked for me.

#32
emonoo7

emonoo7

    Stranger

  • Members
  • Pip
  • 2 posts

If your NMM is crashing because you are getting the following error in your tracelog:

"BOSS_API_ERROR_INVALID_ARGS: Plugins may not be sorted before Update.esm."

It's because you don't have an Update.esm in your Skyrim directory.

The number 1 reason for you not having Update.esm in your Skyrim directory is because you pirated Skyrim, and the pirates didn't deem it necessary to share it with you.

We are NOT going to be spending time hot fixing this bug to help pirates mod their game more easily.

If you did not pirate your version of Skyrim and bought it legitimately then your Skyrim install is bugged, or you deleted Update.esm thinking you didn't need it, and I strongly recommend you reinstall it.



#33
Skanagar

Skanagar

    Regular

  • Members
  • PipPip
  • 74 posts
I had this problem with (a legal copy of) Fallout 3 when trying to install the FWE 6.03 hotfix. Gopher mentioned in some of his videos that the "alternate travel.esp" is flagged as .esm and he changed it to .esp using FO3edit. However in my downloaded version of FWE it was already flagged as .esp and this caused the BOSS_API_ERROR_INVALID_ARGS problem for me. So i changed it back to .esm and the installation of the patch (and also Marts Mutant Mod) went fine. I dont't know if it's better to leave it as .esm or not, but since it also produced conflicts with the installation of MMM, it's probably better to leave it.

#34
dammskog

dammskog

    Journeyman

  • Members
  • Pip
  • 30 posts

is there any easy fix for this crap problem/bug???

 

tried skanagars soluton and it does not help.

 

had managed to install the hotfix earlier but had to uninstall the fwe mod and install it again to activate followers enchanced and now i get this stupid error

 

 

 

 

what I did now and seems to have solved the problem is that I unchecked all plugins exited NMM, manually installed the hotfix in the data folder, started NMM and then installed the hotfix


Edited by dammskog, 22 August 2013 - 10:09 AM.


#35
ntnssc

ntnssc

    Enthusiast

  • Members
  • PipPip
  • 103 posts

If your NMM is crashing because you are getting the following error in your tracelog:

"BOSS_API_ERROR_INVALID_ARGS: Plugins may not be sorted before Update.esm."

It's because you don't have an Update.esm in your Skyrim directory.

The number 1 reason for you not having Update.esm in your Skyrim directory is because you pirated Skyrim, and the pirates didn't deem it necessary to share it with you.

We are NOT going to be spending time hot fixing this bug to help pirates mod their game more easily.

If you did not pirate your version of Skyrim and bought it legitimately then your Skyrim install is bugged, or you deleted Update.esm thinking you didn't need it, and I strongly recommend you reinstall it.

 

Actually I ran into this problem because due to previous experience I don't trust NMM anywhere near my Skyrim instalation. So I tried to use NMM for extracting FOMOD packages to save time. So much for that. Arrr.... I hear MO is good this time of year.



#36
Magicman187

Magicman187

    Stranger

  • Members
  • Pip
  • 2 posts

to fix this, u need to close NMM, then run FO3Edit ( gopher has a video on it ) load your plugins, when its done click the + next to alternate travel esp to expand it, click file header, then on right hand side where it says Record flags next to that should be blank, right click there and edit, click yes to the warning and then tick ESM, close FO3edit and click OK, then reopen NMM and install the hotfix



#37
Paintedwolf

Paintedwolf

    Stranger

  • Members
  • Pip
  • 8 posts

Hey all, First time poster bla bladdy bla

 

I have fixed my " BOSS_API_ERROR_INVALID_ARGS: Plugins may not be sorted before...."

Issue finding out which mods were causing the problems, In my case it was "Jaysus Swords" that was causeing the error. 

       When I ran Wrye Bash-Smash, it told me that these could have problems, as they were not masters, but they were ESMs, or that was my understanding. I replaced the standard (Offending) Jaysus with 

Sharlikrans Compatibility Patches (http://skyrim.nexusm...m/mods/26230//?)

      After this I was able to install the latest Unofficial patches, as well as setup Immersive animations.

 

Also, I had ignored it for sometime, but Wrye bash was warning me about a few of my mods for some time, and I just ignored it. Anyway, Run Wrye bash, find the one who isn't a true master, and replace it or load it into TS5 and save it as a master, as Sharlikrans has done. Fixed my issues anyway. Good luck and happy modding. 


Edited by Paintedwolf, 06 November 2013 - 07:25 PM.


#38
Paintedwolf

Paintedwolf

    Stranger

  • Members
  • Pip
  • 8 posts

P.S.  I love the people who throw out "Thats a wierd error! you obviously are a pirate BAN BAN BAN." Because every game launched ever has been 100% rock solid bug free.... unrelated has anyone ever played Fallout New Vegas, or Morrowind?



#39
DaNewb13

DaNewb13

    Stranger

  • Members
  • Pip
  • 1 posts

to fix this, u need to close NMM, then run FO3Edit ( gopher has a video on it ) load your plugins, when its done click the + next to alternate travel esp to expand it, click file header, then on right hand side where it says Record flags next to that should be blank, right click there and edit, click yes to the warning and then tick ESM, close FO3edit and click OK, then reopen NMM and install the hotfix

This worked for me, thank you very much!  I can confirm this fixes the problem for the error while attempting to activate the FWE hotfix for Fallout 3.



#40
crystaltiger

crystaltiger

    Stranger

  • Members
  • Pip
  • 3 posts

P.S.  I love the people who throw out "Thats a wierd error! you obviously are a pirate BAN BAN BAN." Because every game launched ever has been 100% rock solid bug free.... unrelated has anyone ever played Fallout New Vegas, or Morrowind?

I've played a lot of New Vegas; it's great. I personally much prefer it over Fallout 3 because it's just so much more fun. And ironsights, ironsights help a lot.

 

Regardless, I've been getting this for nearly all of the Unofficial Patch mods (for some reason only the one for the HD collection works). My copy is definitely legal and Update.esm is there, so I'm going to try reinstalling and then do what preslavb did if the issue persists. Hopefully that will fix it, since Skyrim and NMM are up to date and I just got Dragonborn.


Edited by crystaltiger, 28 November 2013 - 02:44 AM.





Page loaded in: 0.747 seconds