Jump to content

Photo

Not Logged In - Unable to perform token authentication on Win7 (SOLVED)

not logged in token authentication win7 unhandled exception system.servicemodel.channels login error

  • Please log in to reply
No replies to this topic

#1
tend2it

tend2it

    Enthusiast

  • Members
  • PipPip
  • 111 posts

If you are having issues on Win7 logging into NMM via the login dialog box and related to "Unable to perform token authentication," I found that the .NET install may have become corrupted.

 

NMM worked fine up to this point (and also synched with Nexus webpage download interaction) and then the mysteriously error appeared.  Reinstall of NMM didn't help.  Login errored out and hung sending credentials. 

 

The details of the error trace pointed to missing internal .NET assembly refs.

 

Repairing .NET fixed my problem. 

 

.NET repair steps can be found here (as well as notes on other Windows vers) :

https://www.daktroni...mework 4-0.aspx

 

Hope this helps anyone having this issue.

 

==============

BACKGROUND:

 

Had an issue with NMM not allowing me to login via the manager login dialog box.  Logging into the nexus website worked fine so username/password is fine.  NMM showed status (bottom left) of Not Logged In.  Clicking on the login icon next to Not Logged In popped up the dialog box with the following message in red: 

 

Unable to perform token authentication, retry using your credentials

Insert login credentials dialog box

After entering login credentials into the dialog box. the following info was displayed.

 

------------------------------------------------------------

Nexus Mod Manager (0.63.14) - Fallout4

Unhandled exception has occurred in your application.  If you click Continue, the application will ignore this error and attempt to continue.  If you click Quit, the application will close immediately.

Clicking on the Details button:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'System.ServiceModel.Channels, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
File name: 'System.ServiceModel.Channels, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

 

followed by loaded assemblies details ... not displayed here

------------------------------------------------------------

 

Hitting Continue ... The login process would hang on sending credentials and never complete ... forcing all downloads to be done manually.


Edited by tend2it, 31 October 2017 - 12:15 AM.






Also tagged with one or more of these keywords: not logged in, token authentication, win7, unhandled exception, system.servicemodel.channels, login, error

Page loaded in: 1.071 seconds