Jump to content

Photo

Navmesh Problems, please help!

navmesh creation kit

  • Please log in to reply
1 reply to this topic

#1
redprincess79

redprincess79

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 2,160 posts

So, I am working on a Hearthfire house mod. Actually, I've been working on it for what seems like ages. I edited the landscape in CK, trying to get it to do exactly what I wanted it to. After awhile it was perfect. Then I took a look at the navmesh and realized that since I manipulated the vertices, the navmesh is now all wonky. Some of it sits under the ground, and some of it sits above. I tried getting it to smooth out on the ground, by using the F key like you do with objects. That didn't go so well. All the vertices became green but nothing happened. And how do I get the vertices that are under the ground above it? And obviously I can't delete it because that would cause serious errors. And trying to regenerate it didn't work either.

 

I tried googling for this information but nobody seems to have any answers. Does anyone have any answers? I've only navmeshed interiors so this is a complete first for me. How can I fix broken navmesh?  Help! If someone could take a look at it for me or help me with ANY of it I would really appreciate it.



#2
yian

yian

    Skyrim Mod User

  • Members
  • PipPipPipPip
  • 1,164 posts

You have to move them to the right place, one by one.







Also tagged with one or more of these keywords: navmesh, creation kit

Page loaded in: 1.063 seconds