Jump to content

Photo

Skyrim constant crashing


  • Please log in to reply
10 replies to this topic

#1
William Lionheart

William Lionheart

    Fan

  • Members
  • PipPipPip
  • 315 posts
I once had an issue with Skyrim crashing for some unknown reason , when i accidentally disabled all my mods i planned to start all from a new save game but it crashed at the conversation between ralof and the thief. My computer had to be reformatted so i hoped the problem would have been solved after reinstalling it but it didn't. I've installed and re-installed Skyrim many times with my mods active , without the mods , with stuff in my Skyrim folder even without when there was nothing left. Skyrim still keeps crashing i had a save of when you're char was made it often crashed when alduin arrived , a time later it crashed again at different locations yet i still don't know what's causing this . I even tried by taking out my save games so it can't rely on it anymore but still it crashes. I have absolutely no idea how to fix it and i really want to play skyrim again. I also wonder if you edit the Skyrim ini's normal and default if you un-install the game do they still stay there when you changed a line for example the one in the My games/Skyrim folder?

#2
Kazekage1

Kazekage1

    Faithful poster

  • Premium Member
  • 1,049 posts
Make sure that your sound in Windows is set to 24bit 41000hz.

Secondly, make sure you are not using ffdshow (codec). If you are then go into the program and make sure tesv.exe is on the exceptions list.

Have you tried deleting all saves, ini's everything in the Skyrim folder, absolutely everything and then running the game without mods?

#3
Rabbit 51

Rabbit 51

    If there are no cats in Heaven then I don't want to go.

  • Premium Member
  • 4,010 posts
Never change your default ini. If you screw up your working ini (the one in the documents folder) Skyrim will rebuild it using the default ini's settings.


Rabbit

#4
William Lionheart

William Lionheart

    Fan

  • Members
  • PipPipPip
  • 315 posts
@kazekage1 I did remove every thing but i never really deleted that other ini file so i might do that and see IF that works .


@Rabbit 51 well i rather not change anything but i downloaded the HD Texture DLC before i read it was rather bad and since i wanted to keep using mods like Hvergelmirs Shield Retexture i changed the line to what was provided in the description page

#5
WaltC

WaltC

    Regular

  • Members
  • PipPip
  • 72 posts
Good advice for anyone having seemingly inexplicable CTD's or crashes otherwise--assuming you are running Win 7--right-click on "Computer," then open the Advanced system settings/Advanced tab and then hit the "settings" button under Performance, and hit the Data Execution Prevention tab. Next, select the "Turn on DEP for all programs and services except those I select" radio button, hit the "add" button, and then locate the Skyrim executable and select it. This will cause the word "Skyrim" to show up in the DEP box with a checkbox beside it. Make sure the checkbox is checked, then hit "OK" to close out the tab and save your preference.

IIRC, this does *not* require you to reboot, as a change to your swapfile locations and/or sizes might.

I suddenly started having inexplicable, but repeatable CTD incidents at the same place in the game, where I was just summarily thrown out to Windows and the game terminated. Invoking this setting apparently fixed it as those CTD's are now a thing of the past. Apparently, in some places either a mod I've installed or the Skyrim game itself is attempting to read-write to ram illegally under the DEP rules, and the game is immediately terminated by Win7 (I am running Win7x64.) This is a security precaution. Making Skyrim an exception to the rule simply means that Windows won't shut the game down abruptly if and when it breaks a DEP rule.

This also works for other games--especially older ones. For instance, before adding "Rune.exe" to the DEP exceptions list the game simply would not run at all, no matter what I did. Made an exception to the DEP rule and Rune runs perfectly under Win7x64. You would think that the other setting for hardware DEP would work here--"Turn on DEP for all essential Windows programs and services only" because it sounds like DEP is turned off for everything except some Windows programs and services. This seems not to be the case, however, and so I'd guess that "essential Windows programs" includes whatever executables are run during a session...;) Specifying each program individually to be excluded from DEP seems like the only way to do it.

Worked for me--give it a shot if you are having these CTD's. Good luck!

#6
William Lionheart

William Lionheart

    Fan

  • Members
  • PipPipPip
  • 315 posts
Thanks for all the help , it seemed the trick with the ini worked guess when i replaced it back with the old one something went wrong but now that i checked if i removed everything it works fine

#7
JJEBHR

JJEBHR

    Journeyman

  • Members
  • Pip
  • 43 posts
WaltC,
Thank you for this. I'm running on Win XP still but the getting to DEP is essentially the same. I've been having the same problem near Dushnikh Yal.

#8
Anunnak

Anunnak

    Enthusiast

  • Members
  • PipPip
  • 231 posts
Yeah I have constant crashes when climbing the steps to Mzulft, each and every time I go there I crash... I can fast travel without a problem. It's the area I check to see if someone posted a CTD solution... I did use the method that WaltC posted, noticed TESV took a while to execute, so I also added the SBW( Skyrim border less window).exe as well and it launched without delay.

Needless to say I still crashed near Mzulft, but thanks for the possible solution to other games WaltC.

#9
wallybeav2011

wallybeav2011

    Newbie

  • Members
  • Pip
  • 12 posts

thx so much WaltC...great fix that I had no idea about. BTW great name...great....name



#10
Bindiman

Bindiman

    Enthusiast

  • Supporter
  • PipPip
  • 164 posts

Anyone know how to add the skse_loader.exe to the DEP settings ? Or will it work with just the TESV.exe added ?






Page loaded in: 0.710 seconds