Jump to content

Photo

NMM 0.63.14 NullReferenceException: Object reference not set

trace log

  • Please log in to reply
5 replies to this topic

#1
Tower01

Tower01

    Enthusiast

  • Members
  • PipPip
  • 142 posts

I know NMM is E.O.L.  Posting here on the off chance that someone has encountered this issue with beta 0.63.14. and can offer a fix.

 

Nmm working beautifully, then

Repaired my Win 7 OS by upgrading from disc (last resort to resolve a firewall problem)

Skyrim SE and most programs work fine.  However, NMM has stopped launching.

 

Gave permisssion to allow NMM through firewall.  Result: no change

Completely uninstalled and reinstalled, Result: No change

 

Continue to get same Trace Log error, specifically:

 

Tracing an Unhandled Exception:
Exception: 
Message: 
Object reference not set to an instance of an object.
Full Trace: 
System.NullReferenceException: Object reference not set to an instance of an object.
   at Nexus.Client.Program.EnableTracing(IEnvironmentInfo p_eifEnvironmentInfo, Boolean p_booForceTrace)
   at Nexus.Client.Program.Main(String[] p_strArgs)
 
Thanks for any help you can provide.


#2
RedCoat19

RedCoat19

    Stranger

  • Members
  • Pip
  • 3 posts

I have the exact same problem



#3
Tower01

Tower01

    Enthusiast

  • Members
  • PipPip
  • 142 posts

@RedCoat19, What changes did you make to your system to cause it?



#4
RedCoat19

RedCoat19

    Stranger

  • Members
  • Pip
  • 3 posts

@Tower01  It was working fine until I repaired windows 7 by disk, similar to you.



#5
Tower01

Tower01

    Enthusiast

  • Members
  • PipPip
  • 142 posts

I believe this error is related to the .Net Framework.  

When repaired from disc, the environment and hence the framework reverts to original status.  Using windows update the first time after repair, it brought the .Net Framework to a certain revision level. (v4.7 , but with no version data in the registry) .  Only subsequent updates brought the registry up to date with respect to the .Net version information.  

 

This issue also effected Mod Organizer 2, but the result was simply a warning message.  It was MO2 that tweeked me to revisiting MS update for the .Net update.  And it worked, both applications now run correctly.  Unfortunately NMM reset the mod information, and although loading them correctly, it treated all mods as "unmanaged" i.e. it lost track of the library paths and mod info.

 

I hope this helps you to also regain use of NMM.


Edited by Tower01, 10 January 2018 - 01:48 PM.


#6
RedCoat19

RedCoat19

    Stranger

  • Members
  • Pip
  • 3 posts

@Tower01 Yea it works for me now, thanks m8







Also tagged with one or more of these keywords: trace log

Page loaded in: 0.757 seconds