Jump to content

Photo

Settlement icon not showing stats or in trade routes

settlement settler player settlement workshop workbench

  • Please log in to reply
6 replies to this topic

#1
TaxiVader

TaxiVader

    Enthusiast

  • Premium Member
  • 188 posts

Hi all.

 

I have made a functioning settlement (https://www.nexusmod...out4/mods/29441) but there are a few issues with it.

 

1. The settlement icon does not show the settlement stats in the regular pipboy map view, 

2. The icon does not appear in the trade routes map view, and

3. I can send settlers from the settlement to other locations, but not the reverse because the name of my new settlement isn't in the list of destinations from any other settlement.

 

I have also tried a whole new game, same thing happens. So it's not due to the game already being in progress.

 

I'm brand new to the FO4 creation kit so I don't have any idea what to do. My guess is that all of these are linked or are in fact the same thing, and that I've not inserted the settlement into a list / script of some sort.

 

Can anyone suggest how I might try to fix these issues?

 

TV


Edited by TaxiVader, 28 January 2018 - 12:12 AM.


#2
TaxiVader

TaxiVader

    Enthusiast

  • Premium Member
  • 188 posts

never mind, fixed it by linked reffing the workbench to the map marker and back.

 

Just out of interest, that's not in marymint's youtube tute (Mods1984) and also doesn't get a mention in Neeher's Part 2 tute since the map marker for atom cats is already in place when he starts making the settlement (I think...)


Edited by TaxiVader, 29 January 2018 - 09:05 PM.


#3
pra

pra

    Faithful poster

  • Premium Member
  • 2,467 posts

never mind, fixed it by linked reffing the workbench to the map marker and back.

 

Just out of interest, that's not in marymint's youtube tute (Mods1984) and also doesn't get a mention in Neeher's Part 2 tute since the map marker for atom cats is already in place when he starts making the settlement (I think...)

Could you explain further? You need to link the workbench to the marker, and the marker to the workbench? Using which keywords?



#4
TaxiVader

TaxiVader

    Enthusiast

  • Premium Member
  • 188 posts

Actually I have been through both tutes about 5 times each and I only got the map icon to work once; I think it was a fluke. I've tried combining parts of the two tutorials but all I get is 0 happiness and no map icon data. The Wiki also has no info about making settlements. This is all very frustrating.



#5
pra

pra

    Faithful poster

  • Premium Member
  • 2,467 posts

Damn :/

 

I'm trying to make the abandoned "settlemods" work for me. Well, it works mostly, but Easy City Downs has no icon and you can't send settlers there, for example. On the other hand, one of the interior player home it adds can have settlers sent to it.



#6
BlahBlahDEEBlahBlah

BlahBlahDEEBlahBlah

    Faithful poster

  • Premium Member
  • 2,102 posts
They donât be mention it because you shouldnât have to do it that way.

Iâm not sure what issue is, but for sure, linking the mapmarker to the workbench is not a normal step.

Try comparing to Open Stands, a VERY basic settlement I did as a teaching tool/proof of concept.

#7
BlahBlahDEEBlahBlah

BlahBlahDEEBlahBlah

    Faithful poster

  • Premium Member
  • 2,102 posts
Also, yeah, Pra, I very much remember the trouble they had with Easy City Downs. There is a LOT of stuff going on at that location in vanilla...both they and I were very much not surprised by it having issues. Iâd wish you good luck on it, though. :)





Also tagged with one or more of these keywords: settlement, settler, player settlement, workshop, workbench

Page loaded in: 1.129 seconds