Jump to content

Photo

Convert "FFXIV hkx animation" to Blender/Unity/Maya?


1 reply to this topic

#1
Cellenseres

Cellenseres

    Stranger

  • Members
  • Pip
  • 2 posts
Hey Guys,
 
I really need help with hkx animations which I've extracted from Final Fantasy XIV.
They work on Havk Content Tools without problems, but converting this animations seems to be very tricky... and I was unable to get it to work yet.
 
My Setup:
- HavokContentTools_2014-1-1_20150216_32Bit_Anarchy
- Blender 2.79
- Maya 2015 & Maya 2017
 
Here's a video where I tested a animation in Havok Content Tools:
 
I've loaded both, the skeleton and the animation, and saved them both in a separate file again.
Reason: I've "converted" the Files I had from FFXIV to Havok hkx 2014.1.1
Both files were still working in Havok Content Tools when I loaded them both (like you can see it in the video above).
 
I've tried to convert both files to an fbx file by using havok2fbx with the command:
havok2fbx.exe -hk_skeleton skel.hkx -hk_anim anim.hkx -fbx test_animation.fbx
 
After converting the fbx with Noesis and/or Autodesk FBX Converter, I tried to load it in Autodesk Maya and Blender.
Both gave me the same result: a buggy animation.
Here's another video that shows the buggy animation:
 
I've linked the Model as FBX and the skeleton + animation as hkx.
I hope you'll be able to help me out with that.
 
Thank you in advance!
 


Additional Information:
I've tried this Tutorial 
but with HavokContentTools_2014-1-1_20150216_32Bit_Anarchy instead of HavokContentTools_2014-1-0_20140830_64Bit_PcXs which shouldn't make any difference.
HavokContentTools_2014-1-0_20140830_64Bit_PcXs refuses to load on my PC anyways and I don't know why.


#2
razar51

razar51

    Newbie

  • Members
  • Pip
  • 11 posts

I looked into it since I also wanted to utilize ffxiv animations.

The reason you are getting the 'buggy' animation seems to be that the animation tracks are getting applied to the wrong bones in the skeleton.

The havok2fbx tool was not taking into account that ffxiv animations utilize hkaAnimationBinding to specify which bones the animation tracks apply to. It was assuming a 1-to-1 mapping of Track-Bone when ffxiv havok files seem to have more bones in the skeleton than tracks in the animation, so no 1-to-1 mapping.

I released a modified version of the tool here that should address that problem:
https://github.com/razar51/havok2fbx/releases

First time using GitHub to make a release so let me know if I screwed it up somehow.





Reply to this topic



  


Page loaded in: 0.928 seconds