Jump to content


Amazing Follower Tweaks (AFT) Causing Game Freezing

freezing aft amazing follower tweaks derkeethus followers bug crash? vital please help outfit management

  • Please log in to reply
8 replies to this topic




  • Members
  • Pip
  • 38 posts

First off, I want to say that I am not incredibly skilled at modding games; more often than not, I turn to the easiest/most automated method I can to mod a game, purely because one time I tried manually installing mods and basically ruined an entire computer. Granted, now I know a bit more about how files and compatibilities work, I still feel leery about diving too deep into files and folders to manually fix issues. Just a disclaimer.


Now the issue. As of today (April 3, 2018) it seems that, whenever one of my followers attempts to change outfits to their standard (outside) outfit, the game freezes. My hypothesis: there is an issue with this specific follower OR there is an issue with my load order or version of my game causing the freeze.


For specifics, the follower in question is Derkeethus. I had just found him yesterday, and he seemed to be problem-free until today. I noticed the issue after sleeping in my bed in Breezehome, then going outside, where, for a few seconds, the game flowed normally. However, upon my followers switching from home to standard outfits, the game froze. I figured "maybe its just because my computer ran into an error," or "maybe it was because I wasn't plugged in (charging) and it was too much for the computer to handle." What's strange about this is that yesterday everything worked just fine. So, I tried a few other methods of rooting out the problem: I noticed on another occasion leaving Breezehome that only Lydia (my only other active AFT follower) came out first, and her outfit switched almost immediately with the usual split-second lag. However, a moment later Derkeethus came out, and when the game attempted to change his outfit, it froze just before his home outfit was removed. I tried leaving it to process for a few minutes, nothing. Ambient sounds and music seem to continue, but otherwise the game is entirely frozen: Windows key won't work, Ctrl+Alt+Del won't allow the task manager to appear (even after selecting it) and Alt+F4 won't force the program to close, I have to manually restart my computer each time through Ctrl+Alt+Del. 


If any of this information helps:

-Derkeethus' standard outfit is partially composed of armor parts from a mod that added several (hundred) new armor sets to the game, though this was not an issue yesterday. 

-Yesterday, I also installed a mod that reshapes each race's body to be more "lore friendly," though again I hadn't noticed problems after installing it. If it was only body shapes, I don't understand why it would cause the game to freeze during outfit change. 

-My Skyrim did have an update before launching today, I think it was only the VR update, or possibly an update for VR mode bugfixes; it was relatively small, less than 10 MB. This may be the source of the issue, I know sometimes seemingly unrelated updates can change important details.

-I also installed LOOT for the first time after the first few crashes, thinking maybe my load order just needed some tweaking. After sorting my load order with LOOT's automatic sorting, the error still continued, however it seemed like the conversation menu options were in the correct order, a few had changed position. I doubt this was the cause, but it shouldn't be ruled out. 


After sorting with LOOT, this is my load order (copied directly from LOOT):


  0  0     Skyrim.esm
  1  1     Update.esm
  2  2     Dawnguard.esm
  3  3     HearthFires.esm
  4  4     Dragonborn.esm
  5  5     unofficial skyrim special edition patch.esp
  6  6     campfire.esm
  7  7     Falskaar.esm
  8  8     Cutting Room Floor.esp
  9  9     static mesh improvement mod se.esp
 10  a     yot - your own thoughts.esp
 11  b     ineed.esp
 12  c     ineed - extended.esp
 13  d     RLO - Exteriors.esp
 14  e     RLO - Interiors.esp
 15  f     Reverb and Ambiance Overhaul - Skyrim.esp
 16 10     phenderix magic world.esp
 17 11     SoS - The Wilds.esp
 18 12     lamposts of skyrim.esp
 19 13     ordinator - perks of skyrim.esp
 20 14     SkyTEST-RealisticAnimals&Predators.esp
 21 15     Hothtrooper44_ArmorCompilation.esp
 22 16     point the way.esp
 23 17     inigo.esp
 24 18     immersive patrols ii.esp
 25 19     incubex delwraith's cooking and alchemy mod.esp
 26 1a     frostfall.esp
 27 1b     yot - frostfall module.esp
 28 1c     yot - campfire.esp
 29 1d     arrowtweaksfix.esp
 30 1e     icepenguinworldmap.esp
 31 1f     rich merchants of skyrim.esp
 32 20     violens se.esp
 33 21     diversedragonscollectionse.esp
 34 22     fast_beast_perks.esp
 35 23     cheesemod.esp
 36 24     better horses.esp
 37 25     realistic_impacts.esp
 38 26     amazingfollowertweaks.esp
 39 27     get_no_dead_followers_sepc_sp0ckrates.esp
 40 28     SkyHUD.esp
 41 29     Gri_BeastFeet.esp
 42 2a     TrainingLimit.esp
 43 2b     gitgud greaves.esp
 44 2c     gitgud greaves (dragonborn).esp
 45 2d     gitgud greaves (dawnguard).esp
 46 2e     RLO - Effects.esp
 47 2f     RLO - Illuminated Spells.esp
 48 30     RLO - CRF Patch.esp
 49 31     Skyrim Flora Overhaul.esp
 50 32     Verdant - A Skyrim Grass Plugin SSE Version.esp
 51 33     Footprints.esp
 52 34     Immersive Sounds - Compendium.esp
 53 35     unlimitedamuletsandrings.esp
 54 36     moonlight tales special edition.esp
 55 37     TrueStormsSE.esp
 56 38     wetandcold.esp
 57 39     Race Scale Remover.esp
 58 3a     better leveling.esp
 59 3b     50 more perk points.esp
 60 3c     LrsamwaysExpandedSkyrimWeaponry.esp
 61 3d     Hothtrooper44_Armor_Ecksstra.esp
 62 3e     ForgottenCity.esp
 63 3f     beltfastenedquivers.esp
 64 40     SimpleOutfitManager.esp
 65 41     FNIS.esp
 66 42     XPMSSE.esp
 67 43     Racial Body Morphs.esp
 68 44     open cities skyrim.esp
 69 45     immersive citizens - ai overhaul.esp
 70 46     alternate start - live another life.esp
 71 47     relationship dialogue overhaul.esp
 72 48     realisticwatertwo.esp
 73 49     RealisticWaterTwo+-+Verdant+Patch.esp
 74 4a     RLO - IC Patch.esp
 75 4b     RAO - Alternate Start Patch.esp

I personally feel like a few of these are in an awkward order, though nothing seems to be causing issues from my perspective, and nothing pops up as an error from LOOT.


If you need any other information, I would be glad to provide it, this is just everything I could think of that would cause the issue. Like I said, I made no changes to the game between yesterday and today, it simply seems to have stopped working correctly. My next few troubleshooting methods will consist of attempting to dismiss Derkeethus, resetting him under AFT or removing him from AFT management, or simply loading an earlier save before the problem occurred. If anyone can provide some feedback, it would be most appreciated.




Well, now the problem has gotten worse: I've run into this error before but I can't remember how to fix it. I tried dismissing Derkeethus, loading an older save, and removing him from AFT management, but it acts like he's permanently a follower now, even though he does not follow me. He draws/sheathes weapons as if he were a follower, and has an option "I think it's time we part ways," but when he says he's leaving the game doesn't say "My follower has left my service," and he remains as my "follower," though as stated he doesn't actually follow me. AFT commands and options are no longer shown either. 

Edited by LucidGamer137, 03 April 2018 - 06:24 PM.



    Faithful poster

  • Premium Member
  • 1,560 posts

I don't think the problem is AFT but Derkeethus standard outfit the mesh of the outfit could be corrupted could you try getting it from his inventory an try equipping it to see if the game crashes (it may crash as soon as you open the inventory).




  • Members
  • Pip
  • 38 posts



If you mean that I should remove the outfit from his inventory, I've tried a few similar actions...


I noticed that AFT does this odd thing where they give followers a backpack inventory, seemingly for objects used for other outfits or fenced from other items, and a trade inventory for "I need to trade some things with you." I removed his default outfit, the miner's clothes, and gave him the clothing items I want him to wear. For some reason, it's acting strange and giving his default outfit parts back to him though. For example, I gave him a different set of boots, and when I removed his default outfit parts, he somehow kept the default boots, I checked every inventory option I could and they were nowhere to be found. Also, with Lydia, she seemed to automatically sort her outfits; just an unused set of armor in her inventory was automatically equipped as one outfit, while Derkeethus seems to be unable to handle more than one outfit.


I did remove his standard outfit once, then tried going outside, but he had disappeared entirely. I know he goes to Darkwater Crossing when dismissed; I found him there in his home outfit. Acting like he was actively following me (with options to dismiss and all) but no AFT options were shown, and if I dismissed him he would say goodbye but remain in the follower list. I ran into a similar error before, but I have no idea how I fixed it the first time, something about using a console command to hard-remove him from the list...



    Old hand

  • Premium Member
  • 980 posts

Try moving AFT to the bottom of your load order and use TESEdit to find conflicts.




  • Members
  • Pip
  • 38 posts

Try moving AFT to the bottom of your load order and use TESEdit to find conflicts.


I'll be sure to try that. The only thing I'm wary about is that the LOOT program places it really high up, then again I suppose it may not know exactly where to place every mod. Thanks.




  • Members
  • Pip
  • 38 posts

Thanks to both of you guys for the help, looks like shifting the load order a bit fixed the problem, thanks!




  • Premium Member
  • 297 posts

Don’t mean to resurrect this thread, but I’m experiencing this too. But only with Aela the huntress... 




  • Members
  • PipPipPip
  • 318 posts

Don’t mean to resurrect this thread, but I’m experiencing this too. But only with Aela the huntress... 

Seconded. Moving AFT to the bottom of my load order did nothing.




  • Premium Member
  • 2 posts

Had this issue with only Aela the huntress.  Changing the order of AFT to the bottom did nothing.  I then went into her inventory and removed all her items.  I was then able to check Use Standard Outfits.  Readded her equipment as a standard outfit and haven't had any issues since.  Hope this helps someone.

Also tagged with one or more of these keywords: freezing, aft, amazing follower tweaks, derkeethus, followers, bug, crash?, vital, please help, outfit management

IPB skins by Skinbox
Page loaded in: 1.110 seconds