Jump to content

Photo

Plugins not sorted because of cyclic rules


  • Please log in to reply
6 replies to this topic

#1
Spacedog

Spacedog

    Journeyman

  • Supporter
  • Pip
  • 20 posts

Vortex keeps displaying a message that plugins not sorted because of cyclic rules, in more info it reports:

 

Cyclic interaction detected between plugins "FlowerGirls SE.esp" and "AmazingFollowerTweaks.esp". Back cycle: AmazingFollowerTweaks.esp, Relationship Dialogue Overhaul.esp, FlowerGirls SE.esp

 

It says I should change my custom rules to resolve the conflict but I don't think I have any, at least not that I can see. Is this message usual? How can I fix it?

 

EDIT: I fixed it by renaming the \AppData\Roaming\Vortex\skyrimvr\userlist.yaml file. What I don't understand is why I couldn't edit or see this interaction from within the UI? There was nothing listed in plugins for any of the files.


Edited by Spacedog, 17 April 2018 - 01:04 AM.


#2
SkunkMonkey

SkunkMonkey

    Fan

  • Premium Member
  • 458 posts

That file contains your rules. By doing that you removed ALL rules that you created.

 

If you are on the latest version, clicking on the "More" (I think that's what it's called) button in the cyclic message, it should open a dialog with a fancy mapping of the cyclic rules. Click on one of the lines to delete that rule and stop the cyclic problem.

 

Cyclic rules usually occur when you create a rule for both conflicting mod/plugins. You only need to tell one, not both, to override.

 

The other way to get a cyclic problem is by creating a circular chain of rules. A over B, B over C, then C over A. It creates an unresolvable loop.



#3
Spacedog

Spacedog

    Journeyman

  • Supporter
  • Pip
  • 20 posts

Yes I could see in the file that the only rules I had created were the ones it listed as problematic so I was happy getting rid of them, but when I clicked on "more" in the UI it displayed the cyclic problem but gave no way of adjusting or removing the rules.


Edited by Spacedog, 17 April 2018 - 01:15 PM.


#4
SkunkMonkey

SkunkMonkey

    Fan

  • Premium Member
  • 458 posts

Are you on the latest version?



#5
Spacedog

Spacedog

    Journeyman

  • Supporter
  • Pip
  • 20 posts

Yes, 14.1. In fact I just ran it and despite renaming the userlist.yaml the same issue has returned today. The file has not been recreated and I have no user defined rules at all.  When I click "more" it shows the problem but gives no method of adjusting or removing the rules.

 

EDIT: Opened and closed a couple of times and the warning has gone away, plugins sort properly etc. Very weird.


Edited by Spacedog, 17 April 2018 - 05:24 PM.


#6
zytres

zytres

    Newbie

  • Members
  • Pip
  • 16 posts

Im having exactly the same issue since last night!! i think this could be a bug. Edit: this is a flower girls 1.9.1 bug, the author said he would reupload the mod to fix it, go check it out in the nexus page.


Edited by zytres, 17 April 2018 - 08:45 PM.


#7
sopmac45

sopmac45

    Old hand

  • Premium Member
  • 699 posts

Vortex keeps displaying a message that plugins not sorted because of cyclic rules, in more info it reports:

 

Cyclic interaction detected between plugins "FlowerGirls SE.esp" and "AmazingFollowerTweaks.esp". Back cycle: AmazingFollowerTweaks.esp, Relationship Dialogue Overhaul.esp, FlowerGirls SE.esp

 

It says I should change my custom rules to resolve the conflict but I don't think I have any, at least not that I can see. Is this message usual? How can I fix it?

 

EDIT: I fixed it by renaming the \AppData\Roaming\Vortex\skyrimvr\userlist.yaml file. What I don't understand is why I couldn't edit or see this interaction from within the UI? There was nothing listed in plugins for any of the files.

 

 

I had the same situation and I solved the problem by downloading Flower Girls previous version ( 1.8 or 1.9 ... do not remember ) ... the new version has VR compatibility and that is causing this mod not to be placed at the bottom of your load order and everybody is getting crazy about that ... unless you have VR, then stick to the new version and post your feedback to the mod author and wait for him/her to fix it, otherwise, the solution is to stick ( for now ) to the previous version, which is working properly by the way. 

 

Once you download / install the previous version, your cycling error will be fixed and this mod will be placed where it is supposed to be at. Hope this help you !   :cool:






Page loaded in: 0.676 seconds