Jump to content

Photo

Already Have a 'dxgi.dll'...

enb dxgi error x5000 two .dll troubleshoot fix

  • Please log in to reply
4 replies to this topic

#1
four2nothin

four2nothin

    Enthusiast

  • Supporter
  • PipPip
  • 214 posts

I recently went ENB "shopping" and picked out one that I wanted to try out. Unfortunately it seems the preset seems to be abandoned which leaves all questions unanswered.

In the mod authors own words these are the instructions:

- Copy and rename copied ReShade64.dll to "dxgi.dll"

 

Unfortunately I already have a 'dxgi.dll'  as required by another mod. How can I easily resolve this? I've got little experience with enbs.
 


Edited by four2nothin, 18 April 2018 - 08:27 PM.


#2
bbiller

bbiller

    Enthusiast

  • Members
  • PipPip
  • 191 posts
Things to check:
1. In the archives for these two mods, what are the dates on that file? Is one newer?
2. Copy both files to two seperate temporary folders, check their properties. Did the same company make them?

If a file is newer and the same company made both, try the new one.

#3
four2nothin

four2nothin

    Enthusiast

  • Supporter
  • PipPip
  • 214 posts

Things to check:
1. In the archives for these two mods, what are the dates on that file? Is one newer?
2. Copy both files to two seperate temporary folders, check their properties. Did the same company make them?

If a file is newer and the same company made both, try the new one.

Thank you for your response and advice! I actually made a pretty big mistake while posting this. it is a actually 'd3d11.dll' file.

One is for the mod 'Load Accelerator ' and one is for  the ENB 'photorealistic commonwealth' and they are not the same authors. However, the load accelerator no longer works. I pasted the new .dll and the Enb works fine but not the other file requiring the .dll



#4
four2nothin

four2nothin

    Enthusiast

  • Supporter
  • PipPip
  • 214 posts

Nevermind, I'm just dumb. I went to the load accelerator page (after discovering the other file that required the same file) and it says how to enable alongside an ENB. Thanks again!



#5
four2nothin

four2nothin

    Enthusiast

  • Supporter
  • PipPip
  • 214 posts

Just in case anyone out there is as dumb as me the solution is:

1) rename the [d3d11.dll] of this file (Not the Enb). EXAMPLE: ( la_d3d11.dll]), then place the renamed DLL.
2) Edit [enblocal.ini], rewrite the following contents
 EnableProxyLibrary = false to true
 InitProxyFunctions = false to ture
 ProxyLibrary = [renamed DLL Name(e.g. la_d3d11.dll)]
and
 EnableFPSLimit=true to false
 * Even when FPSLimit in ENB is enabled, load time is reduced, but reduction becomes little.

 







Also tagged with one or more of these keywords: enb, dxgi, error, x5000, two, .dll, troubleshoot, fix

IPB skins by Skinbox
Page loaded in: 1.107 seconds