Jump to content

Photo

Security update for Nexus Mod Manager


  • Please log in to reply
446 replies to this topic

#1
Dark0ne

Dark0ne

    Webmaster

  • Admin
  • 20,328 posts

Today we are releasing some security updates for the Nexus Mod Manager to bring us in line with the new EU GDPR rules coming into force next month.

NMM has been "end-of-line" since 2016, which means we no longer provide any official support for the software, but we thought it was prudent to spend the time and money to release this update so our users could continue to use the software's online services while ensuring we're compliant with the new regulations. We also did not want people to think we were using the GDPR as an excuse to force people on to our new mod manager, Vortex, either. The alternative was to simply turn off the old services completely, essentially making NMM, and any other software using our old login services, offline only.

To prevent any drama with this process, we've even patched up version 0.52.3 of NMM (the last version before the profile functionality was added) so there are no complaints.

In order to be compliant, we need to turn off our old, less secure login to the web services completely. We plan to do this on Tuesday the 8th of May. This will mean anyone who does not update their NMM will no longer be able to use NMM online. This will prevent you from being able to login, check for new file versions or download mods from the site directly in to NMM. This will also affect any other software that uses the old login destination and method, for example, Mod Organizer. We do not officially support Mod Organizer, nor is it made, updated or maintained by us, so any updates needed to ensure it works with our new login service will need to be handled by the team behind Mod Organizer. If you are currently a coder with software making use of the old Nexus login system, please do get in contact via PM or Discord and I will put you through to the appropriate person to help you get on to the newer system as soon as possible.

For convenience, both updated versions of NMM can be found on a new file page setup to make this a little easier. Remember, download 0.65.0 if you are using a version of NMM that is 0.60.x or later. Download 0.52.4 if you are using version 0.52.3 of NMM.

Apologies for the inconvenience caused, but it's 8 year old code now and, at some point, this was going to happen!



#2
EvilTwinz

EvilTwinz

    Old hand

  • Premium Member
  • 523 posts
Will this only affect NMM users or regular mod users who download these files?

#3
Dark0ne

Dark0ne

    Webmaster

  • Admin
  • 20,328 posts
In response to post #59520211.


Spoiler

I don't really know what you mean by "regular mod users". It will not affect you if you "manually" download your mods from the site and do not use a mod manager that makes use of the Nexus site services.

#4
ista3

ista3

    Resident poster

  • Premium Member
  • 46,217 posts
I'm still using NMM 0.56.1 so what now? :confused:

#5
EvilTwinz

EvilTwinz

    Old hand

  • Premium Member
  • 523 posts
In response to post #59520211. #59520461 is also a reply to the same post.


Spoiler

Sorry,..I have never used NMM. I just download and manually install.
Thank You,and sorry for my poorly thought out comment to a 'gut' reaction.
I just use the manual download and PM services. Thank You.

#6
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 8,238 posts
Thanks for the heads up. Wasn't aware of any regulation changes. Good to see an NMM updated version arriving for download at The Nexus again, although I've been keeping an eye on GitHUB for NMM since Vortex alpha was launched. Was at v0.64.3 of NMM already...

Cheers.

#7
Elianora

Elianora

    Skyrim Real Estate Agent

  • Premium Member
  • 10,361 posts
Graceful and considerate, as always, Robin. :) Thanks for letting us know! :wub:

#8
IsharaMeradin

IsharaMeradin

    The Pale Redguard

  • Members
  • PipPipPipPipPip
  • 7,671 posts
Commenting here because there is no comment thread on the file page itself.

I have both the pre-profile version and the profile version. I kept them separated so that I could test the profile version when it first came out without messing up anything with the other version. The problem comes in that the pre-profile updated installer does not ask where to install the program. It automatically assumes it is to be installed wherever the registry is pointing. In my case, that is the profile version.

Would it be possible to request that a new installer for the pre-profile version which asks the user where to install be made available? The profile version does this. Thus, I do not see why the pre-profile version cannot. Thank you.

#9
Vyxenne

Vyxenne

    Naughty Girl

  • Premium Member
  • 4,064 posts

To prevent any drama with this process, we've even patched up version 0.52.3 of NMM (the last version before the profile functionality was added) so there are no complaints.

I love you guys!

It's good to know that you, too, remember the hard lessons that the 0.60 release taught us all. Seems so long ago, now... :D Keep up the good work and thank you from the bottom of my heart- if it weren't for Nexus Mods most of us would've been "over" Skyrim and Fallout x years ago, but mods, most of them hosted here, keep them fresh and new. :wub:

PS: I thought 0.56.1 was the last non-profile release? I'm still using it for the older Fallouts and Oldrim.

Edited by Vyxenne, 24 April 2018 - 05:11 PM.


#10
Vermithraxe

Vermithraxe

    Enthusiast

  • Members
  • PipPip
  • 157 posts
Seemed a little funny that Nexus Mods are pushing the Alpha version of Vortex so early. I may actually have to change and start a fresh game since the update for NMM gives me a BIG issue now updating my files since I installed the NMM update. Now I am getting the Failed message A problem occurred during install. Object reference not set to an instance of an object. The mod was not installed. This occurred after updating to 0.65.0 today. This error occurred on updating Better Power Armor - A Power Armor Overhaul and Caliente's Beautiful Bodies Enhancer -CBBE- to the latest release today. Just incase I tried reinstalling both files back to the earlier version only to receive the same error message yet again. Funny thing is when I updated another file that update worked I have had not one issue of this occurring with any of my previous installation or updates of my mod list prior to this update of NMM. I am no expert but obviously something went terribly wrong with the update and I hope to god I can fix this issue. It really makes me angry that I had a perfect stable situation finally going with my mod list and had no crashing for a 105 levels and then per Nexus Mods I update NMM to the last version which causes this issue for me.




Page loaded in: 0.778 seconds