Jump to content

Photo

Skyrim Keeps Using Wrong Graphics Adapter

graphics adapter graphics card intel nvidia

  • Please log in to reply
4 replies to this topic

#1
TrapezoidalLollipopofFury

TrapezoidalLollipopofFury

    Stranger

  • Members
  • Pip
  • 9 posts

ALREADY SOLVED!!! READ THE LAST POST FOR SOLUTION!!!

 

 

 

 

For reasons unknown to me - Skyrim keeps using wrong graphics adapter. I have two of them: Integrated: Intel® HD Graphics 4600 and High-Performance: NVIDIA GeForce GT 740M. Both of them are fully updated. My game wants to use only integrated one. 

 

What did I try to change them: 

  • Simply change it in launcher. It doesn't detect second one. 
  • Change SkyrimPrefs.ini. Under display I have found option "sD3DDevice" I have carefully rewritten Intel® HD Graphics 4600 to NVIDIA GeForce GT 740M few times. Launcher always changes it back to Intel® HD Graphics 4600. When I try to skip using launcher - game simply CTD-s on save load. 
  • Change global settings in NVIDIA Control Panel. I have changed "Preffered graphics processor" Box from "Auto-select" to "High-performance NVIDIA processor". Nothing happened. 
  • Change program settings in NVIDIA Control Panel. In: tesV.exe, skyrimlauncher.exe and skse_loader.exe - I have changed "Preffered graphics processor for this program" to "High-performance NVIDIA processor", changed "Power management mode" to "Preffer maximum performance", "Threaded optimization", "Triple buffering" and "Vertical sync" are now all off. 
  • Completly diseable integrated card to force using High-Performance card (Because I'm dumb as fu*k). It only made my screen go black (As you can probably imagine. ). Luckily some BLACK MAGIC BILL GATES MAGIC happened and system has been using screen wiithout any graphics adapter active (That's why I believe in Jesus). Solitaire has been working in like 1.5 frames-per-second thou... Quite a story...  :psyduck: 

 

As you see - I have tried everything I have heard of, so I'm not making this post without reason. 

 

Things about my game that MIGHT be somehow linked into this but probably THEY AREN'T

  • After installing the game - I have moved my files (Only mods and DLC-s) from previous Skyrim installation (On the same computer). I don't know if it was using correct adapter because I have just noticed that it's incorrect now. Judging from frames-per-second then and fact that I had some graphical mods installed then - it was using correct one. Still as far as I remember - Skyrim always has been setting graphics to low when it was launching for first time. First time I have installed the game - it was to laggy to even play on high or ultra but it has changed over time for some reason. Maybe adapter has changet itself; I don't know if that's possible, I'm not good at these things. 
  • I'm using ENBoost that runs from injector version of the game. I didn't use it before but it was simply too laggy to record anything now. It still would be better to have less stutter, so I want to change adapter to correct one. 

 

I'm sort-of frustrated now because I have been modding this game for days and it still isn't working in the way, I want. I'm not using many graphics mods. Most of them are based on gameplay (Mainly combat). I want to overhaul this game in realistic way and put whole list with videos on Nexus but I don't want my videos to be recorded on lowest settings and laggy.  :hurr:  :hurr:  :hurr:

 

 

Sorry for long post but I want to make sure that it will grab your attention and include all information needed. 


Edited by TrapezoidalLollipopofFury, 26 April 2018 - 12:19 PM.


#2
Charles17

Charles17

    Fan

  • Supporter
  • PipPipPip
  • 313 posts

You can try making your skyrimprefs.ini read-only after making your changes. That will lock out any changes your system/game tries to make. Simply right click on the ini files, go to properties, tick the read-only box, apply, ok.



#3
TrapezoidalLollipopofFury

TrapezoidalLollipopofFury

    Stranger

  • Members
  • Pip
  • 9 posts

You can try making your skyrimprefs.ini read-only after making your changes. That will lock out any changes your system/game tries to make. Simply right click on the ini files, go to properties, tick the read-only box, apply, ok.

Thanks for responding! But... Well...

I have edited SkyrimPrefs.ini in the way, I had already mentioned and checked "Read-only" attribute. Game still detects only Intel® HD Graphics 4600. The SkyrimPrefs.ini still remains unchanged (It's set to NVIDIA GeForce GT 740M). 

 

That thingie loves to fu*k 'round with me...



#4
TrapezoidalLollipopofFury

TrapezoidalLollipopofFury

    Stranger

  • Members
  • Pip
  • 9 posts

Kinda useless but I maybe should write it. 

 

I have created similar topic on GeForce Forums since the problem might lie in adapter, not directly in Skyrim. Anyways, there isn't big amount of new information but I'll link that: https://forums.gefor...formance-card-/



#5
TrapezoidalLollipopofFury

TrapezoidalLollipopofFury

    Stranger

  • Members
  • Pip
  • 9 posts

PROBLEM SOLVED THANKS TO Raysonlws ON GEFORCE FORUMS. IF YOU HAVE THE SAME ISSUE - READ THAT!!!

 

Problem lies in drivers, not actual game! To solve it - Use DDU to reinstall drivers, then install driver from manufacturer (For example from CD that you had received when buying your machine) or if you don't have it - just try older drivers. 

 

Thank You for help Charles17 and Raysonlws!







Also tagged with one or more of these keywords: graphics adapter, graphics card, intel, nvidia

IPB skins by Skinbox
Page loaded in: 1.121 seconds