Jump to content

Photo

Help With disappearing objects

textures disappearing objects pop in

  • Please log in to reply
10 replies to this topic

#1
roaric1229

roaric1229

    Newbie

  • Members
  • Pip
  • 14 posts

Hey, i'm having an issue in fallout 4 with certain textures disappearing and reappearing when near the bottom of the screen its mainly certain grass (not all grass) and the drills on work benches as the approach the bottom/bottom corner of the screen, they just vanish and appear as they get closer to the middle of the screen, almost as they are unrendering to early compared to everything else in the game, ive noticed the odd room being unrendered as well until i walk into the room and everything magically appears... 

 

I've been struggling to fix this any help would be appreciated.

 

ps. I've already tried clean install, with no mods same problem, so it isn't mod related. i'm running gtx 1080 gpu with everything on ultra, i've also tried running game in low setting, same issue. 


Edited by roaric1229, 20 May 2018 - 03:31 AM.


#2
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 10,831 posts

Sounds a bit like LOD-flicker but on a smaller scale.  Does it happen both in first and third person view?

 

If it IS LOD-flicker, then try the No More Disappearing Act mod.



#3
roaric1229

roaric1229

    Newbie

  • Members
  • Pip
  • 14 posts

Thanks for the reply i tried this mod already, no help unfortunately, the disappearing seems to only happen on certain angles, which i found very odd.

 

i took some screen shots showing what it looks like "https://imgur.com/a/sMeuB2H"

 

also it does happen in both first and third person.


Edited by roaric1229, 20 May 2018 - 05:01 PM.


#4
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 10,831 posts

Thanks for the reply i tried this mod already, no help unfortunately, the disappearing seems to only happen on certain angles, which i found very odd.

 

i took some screen shots showing what it looks like https://imgur.com/a/sMeuB2H 

 

also it does happen in both first and third person.

Well, LOD-flicker is only visible under certain angles... that's why it sprang to mind immediately, despite the fact you also have it with a frsh install.  LOD-flicker appears in the game when having scrapped things that are normally not scrappable and the game tries to render the items that are no longer there.  Modern games don't render underlying layers to save calculation time and go lighter on the GPU, so, when an upper layer has disappeared, you get holes in the game through wich you can see infinity and parts of other layers, but only when viewing things at a specific angle because of the 3D telemetry.

 

Now, if you have LOD-flicker right off the bat without having scrapped anything out of the ordinary, then some of the game's settings are off or not all textures have properly installed.  There's mods that can cause this, in particular some mods that alter ligting effects, but that's also not the case since you have it even without any mods installed...

 

Beats me...

 

Your link doesn't work, by the way.  It leads to a "Zoinks! You've taken a wrong turn" Imgur 404 error page.



#5
audiodef

audiodef

    Sofia's Bane

  • Supporter
  • PipPipPip
  • 577 posts

Try optimizing the vanilla textures. May or may not solve your issue, but it will at least rule it out, as vanilla textures are not well-optimized. You'll at least get some extra FPS out of it.

 

See the texture optimization section in the guide linked in my sig.



#6
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 10,831 posts

Try optimizing the vanilla textures. May or may not solve your issue, but it will at least rule it out, as vanilla textures are not well-optimized. You'll at least get some extra FPS out of it.

 

See the texture optimization section in the guide linked in my sig.

Please provide the answer here instead of making folks download your guide, Def.



#7
csbx

csbx

    Old hand

  • Supporter
  • PipPipPip
  • 960 posts

I get major flickering in and out of for meshes when using rooms + portals in my mod--even though I know I've done things properly. As soon as I generate precombine, that problem completely disappears. Could your problem be broken precombines because of a mod being used (e.g. scrapping mod or one that touches certain objects in the affected area) ?



#8
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 10,831 posts

I get major flickering in and out of for meshes when using rooms + portals in my mod--even though I know I've done things properly. As soon as I generate precombine, that problem completely disappears. Could your problem be broken precombines because of a mod being used (e.g. scrapping mod or one that touches certain objects in the affected area) ?

Probably not, since that's what the No More Disappearing Act mod does...



#9
audiodef

audiodef

    Sofia's Bane

  • Supporter
  • PipPipPip
  • 577 posts

 

Try optimizing the vanilla textures. May or may not solve your issue, but it will at least rule it out, as vanilla textures are not well-optimized. You'll at least get some extra FPS out of it.

 

See the texture optimization section in the guide linked in my sig.

Please provide the answer here instead of making folks download your guide, Def.

 

That's not going to happen. If I update a section of the guide, I would then have to track down every instance of that section wherever I've pasted it, and if I miss a thread where I've pasted a section, whoever is working with that will not have the latest/best info I can provide. I'm referring to a fixed location for a reason. :-)



#10
RedRocketTV

RedRocketTV

    Pushbutton modding? How quaint.

  • Premium Member
  • 2,732 posts

Sounds a bit like LOD-flicker but on a smaller scale.  Does it happen both in first and third person view?

 

If it IS LOD-flicker, then try the No More Disappearing Act mod.

 

Based on the OP description, I think you’re actually referring to occlusion preculling. LOD has nothing to do with previs as they are two totally different systems of the game engine. The only “LOD flickering” you might see is at a point where the LOD and a mesh might fight with each other to determine which texture is displayed based on your distance. You’ll briefly see a bit of Z-flicker on a surface but as you get closer the LOD stops displaying and the mipmap of the base texture kicks in. This has nothing to do with occlusion or preculling and preculling has nothing to do with LOD.

 

I get major flickering in and out of for meshes when using rooms + portals in my mod--even though I know I've done things properly. As soon as I generate precombine, that problem completely disappears. Could your problem be broken precombines because of a mod being used (e.g. scrapping mod or one that touches certain objects in the affected area) ?

 

Room bounds and portals are only applicable to interior cells. Exterior cells generally will use occlusion planes.

 

But you are likely correct in that the OP is likely experiencing something caused by broken precombines and previs or possibly a conflict from two mods that regenerate the previs data for the same cell. But since the link to the screenshot is borked and the OP hasn’t been back, we can only guess.

 

But is does sound like they may have been having problems with interior cells with the reference to "rooms." Bethesda was ultra lazy and haphazard with how they set up room bounds and portals in FO4. That would lend credence to what you said about it being a precombined/previs disabled issue. If they reinstalled the game as indicated but had that damned .ini edit that disabled precombines it wouldn't make a difference unless they removed the edit.

 

 

I get major flickering in and out of for meshes when using rooms + portals in my mod--even though I know I've done things properly. As soon as I generate precombine, that problem completely disappears. Could your problem be broken precombines because of a mod being used (e.g. scrapping mod or one that touches certain objects in the affected area) ?

Probably not, since that's what the No More Disappearing Act mod does...

 

For clarity, that mod doesn’t touch precombined meshes. It disables previs data for settlement cells to work around  the removal of precombined references with the previs data for them still being active (re: preculling) through the use of scrapping mods.

 

That being said, it’s a very sloppy workaround that does not address the underlying problem of the optimization system being disabled by a scrapping mod, a reckless .ini edit or something else. All it does is force the game to render every polygon of every mesh in a cell even if it is shoved below ground like so many things in this game...the end result is a decrease in your performance because your GPU is working that much harder. The whole point of the optimization system (such as it is) is to not render items that are not visible to the player. That mod just tosses that out the window.

 

Also it only is supposed to work in settlement cells (per the mod description), so if the OP’s issue wasn’t in a settlement cell that would explain why he/she reported it didn’t resolve the problem.


Edited by RedRocketTV, 25 May 2018 - 02:13 PM.






Also tagged with one or more of these keywords: textures, disappearing, objects, pop in

Page loaded in: 1.063 seconds