Jump to content

Photo

3xissues with FO4 help me please!

steam mods fallout 4 nmm won t launch achievements fo4 epic fuckery

  • Please log in to reply
11 replies to this topic

#1
TheBlindSnake

TheBlindSnake

    Journeyman

  • Members
  • Pip
  • 23 posts

Hi everyone!

So I'm wondering if anyone knows how I could resolve my issues so has to be able to use mods as I do in Skyrim SE with SKSE on, achievements too, NMM running smooth for it and no issues on steam. Is there something I missed or a mistake I made somewhere?

 

Currently having these issues; FO4 won't launch from steam, launcher starts but after clicking on ''play'' fade to black then back to desktop with app closed. Only fix working so far for me is having fallout4.exe file renamed/replacing fallout4launcher.exe which in turn creates the null error on NMM. So I constantly have to change file names back and forth if I close NMM after opening it. More details about that here:https://github.com/N...ager/issues/300

Can't launch FO4 from steam either or it'll ''update'' the game despite me running Fallout 4 v.1.10.82  think that undid my T.O.P. conversion last time it happened, otherwise it usually just seems to replace the executables with new ones with their vanilla names. Keep in mind that the whole FO4 not launching in steam was happening since install.

 

That in turn makes it impossible for me to run F4SE build 0.6.7 and so a whole lot of mods too since I'm not willing to play without achievements considering there should be an easy fix if F4SE was running. Mods won't run since they're not being loaded, which appears to be only working through in-game esps activated into load order.

 

I've got the Fallout 4 config tweaker installed with it having the allow mods option on and running by using the fallout4launcher.exe (formerly fallout4.exe). Used to stop stuttering running at a solid 30fps with my quad core being now used. Previous to that I had already added the lines into my .ini files to allow mods in game, as shown by Gopher's tutorial.

 

I've got all dlc's, was running the game vanilla about a year ago on steam with no issues as far as i can recall except of course terrible performance, now fixed with the config tweaker settings, some retextures and other optimizations.

 

Specs with new ssd for os and new HDD for steam and other programs like games due to old HDD dying on me, warranting reinstall and this clusterf***:

       Operating System: Windows 10 Home 64-bit (10.0, Build 16299) (16299.rs3_release_svc_escrow.180502-1908)

                Processor: Intel® Core™ i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.6GHz
                   Memory: 8192MB RAM
      Available OS Memory: 8110MB RAM

          DirectX Version: DirectX 12
           Card name: AMD Radeon HD 6800 Series

      Display Memory: 5862 MB
    Dedicated Memory: 2022 MB
       Shared Memory: 3840 MB
        Current Mode: 1680 x 1050 (32 bit) (60Hz)

         Driver Name    s: 11_0,10_1,10_0,9_3,9_2,9_1
        Driver Model: WDDM 1.3
 



#2
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 10,834 posts

Once you have the game installed properly you need to install F4SE and use the latter's exe to start the game.  Also, you're making an issue of something that isn't an issue.  Copy the game's exe to anywhere, rename it and put it back.  Tadàààà: two exe's, one original and one renamed.

 

For the rest, you'll need to look around or wait for someone more savvy to hop-in.



#3
TheBlindSnake

TheBlindSnake

    Journeyman

  • Members
  • Pip
  • 23 posts

Once you have the game installed properly you need to install F4SE and use the latter's exe to start the game.  Also, you're making an issue of something that isn't an issue.  Copy the game's exe to anywhere, rename it and put it back.  Tadàààà: two exe's, one original and one renamed.

 

For the rest, you'll need to look around or wait for someone more savvy to hop-in.

Sorry I omitted/wasn't clear about this: the game was clean installed from steam, so most likely properly and F4SE was installed properly and game run from it's .exe which also gives the CTD with the fallout.exe name unchanged but if it is changed then F4SE won't locate it and just won't run. With that being said, I still tried having 2 fallout4.exe files one with regular name the other renamed and then tried running f4se and it still didn't work. However the error message might've been different from the usual, progress maybe?
Launching E:\Software\steamapps\common\Fallout 4\\Fallout4.exe failed (740). Please try running f4se_loader as an administrator.

Tried running as admin, just did the usual CTD after fade to black. My entire fallout 4 folder is set to full control security setting, its been giving all access in windows defender as far as i can tell and also in my AV(avira) by giving the whole steam and games folders exceptions from real time protection.


 

Even if i did a reinstall of F4SE I don't see why the fallout4.exe isn't functioning as is that c***t is messing with everything...

 

*UPDATE*

Your suggestion has however resolved the issue where I have to rename my fallout4.exe back and forth to allow NMM to run and game to launch without any further apparent conflicts other then those mentioned above. Thanks for that! Feels like clutter but *meh* whatever works right? Wish there was a command I could add to NMM settings so it would use the functional fallout4launcher.exe instead of fallout4.exe to run but I don't have a clue what that would look like...


Edited by Solidus Snake, 21 May 2018 - 02:40 PM.


#4
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 10,834 posts

Didn't you say somewhere else you are using Bilago's Fallout 4 Tweaker?  Set that to use the f4se_loader.exe, add a shortcut to Bilago's app to your taskbar and start the game from there instead of through NMM.

 

 

I don't understand why you keep mentioning the Fallout 4 launchers, because they're out of the picture when you're using F4SE since you need to use the latter's launcher.



#5
TheBlindSnake

TheBlindSnake

    Journeyman

  • Members
  • Pip
  • 23 posts

Didn't you say somewhere else you are using Bilago's Fallout 4 Tweaker?  Set that to use the f4se_loader.exe, add a shortcut to Bilago's app to your taskbar and start the game from there instead of through NMM.

 

 

I don't understand why you keep mentioning the Fallout 4 launchers, because they're out of the picture when you're using F4SE since you need to use the latter's launcher.

I keep mentioning them because F4se does too. I don't use NMM to run f4se, i directly run the f4se_loader.exe from the fallout 4 folder as described in the f4se readme. As I said after launching f4se it doesn't launch and says ''Launching E:\Software\steamapps\common\Fallout 4\\Fallout4.exe failed (740). Please try running f4se_loader as an administrator.'' or previously it would simply CTD. In other words it appears the f4se loader needs to locate a valid and functional fallout4.exe.

Gonna try running it from tweaker. BTW already have a shortcut of it on my desktop.

 

*Update* Turns out It was already set to open f4se_loader.exe as the launcher and the result is the same sa running the loader directly. Maybe there's another setting I need enabled or disabled on the tweaker that I overlooked or misunderstood?


Edited by Solidus Snake, 21 May 2018 - 05:50 PM.


#6
bbiller

bbiller

    Enthusiast

  • Members
  • PipPip
  • 189 posts
Okay, I'll try to help you out with how I'm set up.
1. There is an acheivement patch that will allow mods to run as well (Google will help there).
2. I have F4SE and NMM and the way I run my game is I have an entry in NMM for F4SE. Do make sure you have done the following when installing F4SE:
A. If you haven't already done so, get the latest F4SE installer.
B. delete the old F4SE launcher, and other F4SE files found in themain Fallout 4 folder, leaving the F4SE folder in data alone.
C. Run the installer for F4SE. This will make the entry in NMM and give you access to it's launcher.
D. Do make sure any mods you have that use F4SE are up to date, if they are not, head to their Nexus page, delete them from your Fallout 4 in NMM and then re-download the updated mod (This avoids version issues). Once you have activated the mod, do adjust it in the load order, or move all the mods around once all are in (exporting to a text file may be your fastest option to get that done).
E. With all that done, you should be able to run F4SE through NMM without issue and do make sure you have the Fallout4Custom.ini file has the three mod line in it (check other parts of this site or a quick Google search will point out that, though NMM should send you there (check help section)).

Hopefully all of that squashes a few bugs for you.

#7
TheBlindSnake

TheBlindSnake

    Journeyman

  • Members
  • Pip
  • 23 posts

Okay, I'll try to help you out with how I'm set up.
1. There is an acheivement patch that will allow mods to run as well (Google will help there).
2. I have F4SE and NMM and the way I run my game is I have an entry in NMM for F4SE. Do make sure you have done the following when installing F4SE:
A. If you haven't already done so, get the latest F4SE installer.
B. delete the old F4SE launcher, and other F4SE files found in themain Fallout 4 folder, leaving the F4SE folder in data alone.
C. Run the installer for F4SE. This will make the entry in NMM and give you access to it's launcher.
D. Do make sure any mods you have that use F4SE are up to date, if they are not, head to their Nexus page, delete them from your Fallout 4 in NMM and then re-download the updated mod (This avoids version issues). Once you have activated the mod, do adjust it in the load order, or move all the mods around once all are in (exporting to a text file may be your fastest option to get that done).
E. With all that done, you should be able to run F4SE through NMM without issue and do make sure you have the Fallout4Custom.ini file has the three mod line in it (check other parts of this site or a quick Google search will point out that, though NMM should send you there (check help section)).

Hopefully all of that squashes a few bugs for you.

Which patch are you referring to? I have used the two mods available here on the nexus, the f4se reliant one and  the independent one, neither worked. Then again my f4se wasn't working. Are you referring to something else? Does it matter if F4SE is installed before that?



#8
JimmyRJump

JimmyRJump

    MoralMinority

  • Premium Member
  • 10,834 posts

@bbiller:

 

A.  He doesn't need the latest version of F4SE, he needs the version that fits the game version.

D.  Never delete mods from NMM unless you are sure those versions are still available on the Nexus, in case you want/need to go back to that older version of the mod.  NMM deletes the mod from your PC without a possibility to recuperate it.

E.  What lines are you talking about?  I know that the custom.ini takes precedence over the Fallout4.ini, but it's the latter that needs the invalidateolderefiles and such lines added, but that's something that can be done from Bilago's Tweaker.



#9
TheBlindSnake

TheBlindSnake

    Journeyman

  • Members
  • Pip
  • 23 posts

So I skipped the achievements for now, reinstalled F4SE and it still gives me the same errors fade to black and CTD or ''Launching E:\Software\steamapps\common\Fallout 4\\Fallout4.exe failed (740). Please try running f4se_loader as an administrator.''. Checked the F4SE loader log in ''My games'' and htis is what it says:

f4se loader 00060060 01D3F1397D662D01 6.2 (9200)
config path = E:\Software\steamapps\common\Fallout 4\Data\F4SE\f4se.ini
procPath = E:\Software\steamapps\common\Fallout 4\\Fallout4.exe
launching: Fallout4.exe (E:\Software\steamapps\common\Fallout 4\\Fallout4.exe)
dwSignature = FEEF04BD
dwStrucVersion = 00010000
dwFileVersionMS = 0001000A
dwFileVersionLS = 00520000
dwProductVersionMS = 0001000A
dwProductVersionLS = 00520000
dwFileFlagsMask = 00000017
dwFileFlags = 00000000
dwFileOS = 00000004
dwFileType = 00000001
dwFileSubtype = 00000000
dwFileDateMS = 00000000
dwFileDateLS = 00000000
version = 0001000A00520000
product name = Fallout 4
steam exe
dll = E:\Software\steamapps\common\Fallout 4\\f4se_1_10_82.dll
Launching E:\Software\steamapps\common\Fallout 4\\Fallout4.exe failed (740). Please try running f4se_loader as an administrator.
 

Basically saying the same thing I've been saying all along; my issue is this F*@([email protected] fallout4.exe that doesn't launch. Code 740 appears to refer to a lack of permissions but i'm at a loss as to what more permissions I must give it. Isn't there a way for F4SE to launch using fallout4launcher.exe rather then fallout4.exe? Or what settings must I change on my pc for fallout 4 to launch without some bs ranaming trickery?



#10
TheBlindSnake

TheBlindSnake

    Journeyman

  • Members
  • Pip
  • 23 posts

lol how do I remove duplicate posts? Cause this originally was an accidental duplicate of the above post I made...


Edited by Solidus Snake, 21 May 2018 - 08:04 PM.






Also tagged with one or more of these keywords: steam, mods, fallout 4, nmm, won, t launch, achievements, fo4, epic fuckery

Page loaded in: 1.087 seconds