Jump to content

Photo

TESO - Can't get my first weapon in the Coldharbour starter zone

eso teso coldharbour tutorial bug no weapon

1 reply to this topic

#1
Dovahsaur

Dovahsaur

    Journeyman

  • Supporter
  • Pip
  • 24 posts
Hello everyone,
 
Yesterday I wanted to create a new ESO character and since I don't have any expansion, I started in the Coldharbour tutorial. Right after escaping my cell, the game was supposed to give me my first weapon (a 2H sword for example, just like it did for my previous DK characters), but it doesn't give me anything.
 
My inventory is empty, I looked in the entire room but there's nothing on the floor and I can't loot anything from the daedra corpse (though I can loot from other containers normally).
 
Other players seem to have recieved their weapon as usual, this problems seems to be affecting only me. It occured just after buying a TESO+ subscription, I never got this problem prior to that. I tried creating several characters from other classes, same problem : the game refuses to give me any weapon, but continues to play the quest as if I hactually had it.
 
I tried re-installing the game from scratch, it didn't change anything...
 
Any help would be appreciated, thank you and have a nice day :)


#2
CuL8Rgator

CuL8Rgator

    Regular

  • Premium Member
  • 96 posts

The exact thing just happened to me yesterday. Found this thread by searching the topic. I actually fisted my way through the tutorial and the first couple of other smaller quests before earning my first shitty weapon. I have to say, even though it takes forever, I was surprised at just how effective my little lady boxed her way around and it made me consider for a bit letting it go, but I don't think there's an unarmed leveling system, so no thanks. Anyway, hope you are sorted now after only a year and a half hahaha.

Cheers!





Reply to this topic



  



Also tagged with one or more of these keywords: eso, teso, coldharbour, tutorial bug, no weapon

IPB skins by Skinbox
Page loaded in: 1.199 seconds