Jump to content

Photo

Creation Kit problem - follower wont attack

creation kit follower companion

  • Please log in to reply
2 replies to this topic

#1
MrGoatington

MrGoatington

    Journeyman

  • Members
  • Pip
  • 34 posts

I've created my first follower, I've followed instructions as I was supposed to, everything works, his dialogue, his idle marker, everything, but he doesn't attack, if I attack a random NPC, he draws his weapon and shield, and just blocks, he wont strike at all and he just gets cornered and dies. His aggression is set to aggressive and confidence is set to brave, and assistance is set to help allies

 

Why isn't he attacking anything? why is he only blocking?

 

I've spent a long time on this so id really prefer it if my effort didn't go to waste

 

Thanks in advance

 

Fixed:

 

Attack data wasn't set properly, I set override from behaviour graph to NordRace and he was able to attack. it was set to FoxRace, for some reason..


Edited by MrGoatington, 04 July 2018 - 07:24 PM.


#2
justinglen75

justinglen75

    Enthusiast

  • Members
  • PipPip
  • 166 posts

That's good to know, actually! Glad you got it fixed! 



#3
lukehazardly

lukehazardly

    Newbie

  • Members
  • Pip
  • 18 posts

Thank you so much! I had the same probelm with my skeleton follower. I was quite dumb for not noticing this lol. Just for clarification for anyone else with this problem -- if you want any follower besides a vanilla playable race, their attack data override has to be their exact race.

 

Now all that needs to be done are the voice lines. It feels amazing to get something that you've been tearing your hair out and smacking your head over finally done. Once again, thanks for making this form.







Also tagged with one or more of these keywords: creation kit, follower, companion

Page loaded in: 1.146 seconds