Jump to content

Photo

Vortex "Missing Masters" Issue


  • Please log in to reply
32 replies to this topic

#1
LokiX21

LokiX21

    Newbie

  • Members
  • Pip
  • 17 posts

So I am in the process of switching over from NMM to Vortex after experiencing a CTD issue that I couldn't get straightened out while using NMM to mod the legendary version of the regular (non-Special Edition) Skyrim.

 

Currently I'm in the middle of trying to use Vortex (version 0.16.5) to install all of the mods that I was using for the saved game that I hope to pick back up, but twice now I've had Vortex report a "Missing Masters" error.

 

The first error keeps coming up while trying to install the Hot Fix esp v_802 file that the Nock to Tip author (foster xbl) created for their Nock to Tip main file. The same error occurs if I try to use a different hot fix file for the Nock to Tip main file such as OperatorCactus's Nock to Tip Fixes.

 

The second error keeps occurring while trying to install the RSChildren USLEEP Patch file that the RSChildren author (Ranaline)) created for their RS Children main file. The same error occurs if I try to use a different USLEEP patch file for the RS Children main file such as Rentak's RS Children Overhaul USLEEP Patch.

 

While neither of those files caused problems for me while installing them through NMM (or at least they didn't seem to with the extent of my knowledge), in both instances now that I'm using Vortex they each are currently producing an end result where Vortex ends up reporting that there are "Missing Masters" for the Nock2Tip.esm as well as the RSChildren.esm and the USLEEP.esp respectively.

 

I don't have the technical knowledge at this point to be able to dig into the interworkings of Vortex nor the respective mod files and figure out why this is happening, but from what I have been able to observe within the Vortex > TESV Mods > Install > Nock To Tip, RS Children, and USLEEP folders is that the installation of the aforementioned patch/hot fix files causes the ".vortex_lnk" portion of the "Master" files to be removed, which within the context of how Vortex seems to work causes those files to not be "Deployed" and in turn become "Missing".

 

So with all of that... has anyone else had the same thing or something similar from happening, and if so... were you able to figure out a way to rectify it?

 

Also... does anyone with a better understanding of Vortex, mods, and mod patch/hot fix dynamics have any thoughts/suggestions/advice on how to fix/stop/prevent/address the "Missing Masters" thing from happening?

 

Asking because it seems likely to me that if I'll have problems trying to pick back up where my last saved game left off if I don't have the same Nock to Tip and RS Children USLEEP patch/hot fix installed.

 

Regardless... much thanks in advance for any help provided. 



#2
rmm200

rmm200

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,441 posts

A missing Master is a missing Master. Click the More button and it tells you which Master.

Nothing fancy or magic about this. Takes no understanding of hot fixes or anything else.

Click on the Plugins tab and see if the ESP reported as missing is actually disabled. If it is - enable it. Make sure no other ones are disabled either.


Edited by rmm200, 26 September 2018 - 07:54 PM.


#3
LokiX21

LokiX21

    Newbie

  • Members
  • Pip
  • 17 posts

A missing Master is a missing Master. Click the More button and it tells you which Master.

Nothing fancy or magic about this. Takes no understanding of hot fixes or anything else.

Click on the Plugins tab and see if the ESP reported as missing is actually disabled. If it is - enable it. Make sure no other ones are disabled either.

 

Thanks for the suggestion rmm200.

 

And yeah... we are on the same page as far as clicking on the "More" button that comes up along with the issue warning that Vortex generates whenever it detects a missing master in order to identify which master(s) actually are missing. Same goes for clicking on the Plugins tab, and making sure there aren't any files that are disabled.

 

Beyond that... whether you want to call it "fancy", "magic" or something else entirely... the wall that I'm running into is that the master file(s) being reported as missing aren't showing up on the plugins tab, and... as I did my best to articulate in my first post...most likely aren't doing so because something is happening between them, Vortex, and the patch/hot fix files resulting in the master files losing the ".vortex_lnk" portion of their file name and in turn not becoming "deploy"ed/recognized by Vortex even though the are actually there within the Vortex > TESV Mods > Installs mod folder(s).

 

Again... I don't know enough about Vortex, mods, nor mod patches to say for certain that the loss of the ".vortex_lnk" for the master files is exactly the problem, but that is my best guess at this point, but regardless...I'm curious if anyone else has had/is having the same problem with Vortex and patches/hot fixes for mod master files, and of course if anyone out there has any ideas or straight up knows how to rectify this issue whether that be by getting Vortex to recognize the master files that are actually there and deploy them by adding on the ".vortex_lnk" to them or by doing something else entirely.

 

Thanks again in advance!



#4
Wolfskin75

Wolfskin75

    Fan

  • Supporter
  • PipPipPip
  • 305 posts

I am having the same issue. It Saying missing master while it is installed.  Here is the second picture.    I too have  Vortex (version 0.16.5) . I have also posted a thread about it in Fallout 4 mod trouble shooting. Shall I report it through vortex as well>?



#5
Rattledagger

Rattledagger

    Faithful poster

  • Premium Member
  • 1,075 posts

@Wolfskin75, can you also show a picture of the plugin-tab showing ArmorKeywords.esm is really active?



#6
Tannin42

Tannin42

    Resident poster

  • Admin
  • 2,590 posts

The fact you have vortex_lnk files means you're using the experimental move deployment so that could be part of the problem.

 

But the important part is: The error message says that a master is missing. This means it's expecting the master file (e.g. ArmorKeywords.esm) in the game data directory (e.g. c:\program files\steam\steamapps\common\Fallout4\data). That is the first thing you need to check - after you ran "Deploy" just to be safe.

If that master is actually not there after deployment you need to check if the mod that you assume contains it actually contains it - for all we know there could have been an error during installation or it could have been deleted afterwards.



#7
Wolfskin75

Wolfskin75

    Fan

  • Supporter
  • PipPipPip
  • 305 posts

@Wolfskin75, can you also show a picture of the plugin-tab showing ArmorKeywords.esm is really active?

I am at work now but I will go and look for it. I have noticed that .esm will go missing and all the mods attach to it will then go inactive.  50% of the time It will be there and then still get the message. I will admit that the .esm will completely disappear while the mod is still installed. I have to then Reinstall the mod for the .esm to reappear and reactivate, along with all the mods that it took down I have to do this daily.  

 

Should I post this as a separate issue?


Edited by Wolfskin75, 27 September 2018 - 05:39 PM.


#8
sopmac45

sopmac45

    Faithful poster

  • Premium Member
  • 1,202 posts

I have had situations like the above before. Masters are missing error message ... and my masters are there, already enabled in Vortex. 

 

Part of my process when installing mods is to installs first, masters and then after that, all mods that depends on those masters or patches that also depend on that master. Still I have seen some times that error message.

 

What I have done is to remove the mod that is triggering the error and the master and reinstall again. This process fixed that error most of the times. However, in a couple of times, I have not been able not matter what. Log off Vortex, boot up my PC and get back in to Vortex. Fixed. Why ? I do not know.

 

Nevertheless, there was one occasion that I could not fix the problem at all so I decided to remove that mod / patch that was depending on a master already installed.

 

And yet, perhaps this is not a Vortex issue. Maybe some mods that depends on masters files, have not been updated by the mod author; perhaps those mods/patches are looking for a version of a master file that is not ready available. 

 

I am leaning toward that possibility rather than thinking that it is a Vortex issue.  :geek:



#9
Wolfskin75

Wolfskin75

    Fan

  • Supporter
  • PipPipPip
  • 305 posts

I was reinstalling and rebooting my entire pc. If I had stopped for like a couple hours between games I would have to repeat the process. I have had so many issues I have decided to reinstall Fallout 4 and redeploy my mods with Vortex. I understand that it is still in Alpha but I am just reporting the issues as they arrive in order to make sure everyone is aware of things happening that could be a potential bug. Vortex and the mods are all free of charge which I understand but being honest about reporting tech issues or possible tech issues is something that I feel I should do if the product is going to improve. 



#10
rmm200

rmm200

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,441 posts

I was reinstalling and rebooting my entire pc. If I had stopped for like a couple hours between games I would have to repeat the process. I have had so many issues I have decided to reinstall Fallout 4 and redeploy my mods with Vortex. I understand that it is still in Alpha but I am just reporting the issues as they arrive in order to make sure everyone is aware of things happening that could be a potential bug. Vortex and the mods are all free of charge which I understand but being honest about reporting tech issues or possible tech issues is something that I feel I should do if the product is going to improve. 

 

Just from your descriptions, some of your issues sound like issues with your PC, not Vortex. Have you tried removing Vortex from the picture as much as possible?

Install all your mods with Vortex, then while everything looks good, stop Vortex and don't start it again.

Launch the game from the game directory as if you had no mod manager installed.

Does the ESM eventually go missing again, or do you have any other installation problems show up over time?

Remember - you don't need Vortex running to run the game.  It would help to separate problems appearing from Vortex up and when it is not.


Edited by rmm200, 01 October 2018 - 05:55 PM.





IPB skins by Skinbox
Page loaded in: 1.228 seconds