Jump to content

Photo

Whitescreen - Reasons


  • Please log in to reply
70 replies to this topic

#21
HadToRegister

HadToRegister

    Awake at stupid o'clock

  • Premium Member
  • 17,535 posts

 

 

 

OK, thanks for that info.

OK, so you have games on your C, D drive and two different steam folders

In order for hardlinks to work in Bethesda Games, the "Mod DeploymentFolder" needs to be on the same drive as the game, same with Symlinks for the Witcher 3

I think because you have the games on two different drives, and Vortex is handling Hardlinks for SOME Bethesda games on Drive D:, then there's ONE Bethesda game on Drive C:
might be the reason Vortex is crashing

 

 

Well each game has its own staging folder specified to be on the same drive as the game is installed.  Witcher3 is using hardlinks as are all the other games.

Where are the ini files for vortex that I can check nothing has altered these settings for the games that obviously I can't check in vortex becasue of the ui problem?

I have played and modded all the games in their current locations since I started trying vortex at 0.16.8. 0.17.0 did not have this problem but did have the endless sorting issue so I reverted to 0.16.15 and then when the hotfix came out upped to 0.17.1 when the white ui problem started.

 

 

Ah, well then I don't know then, I missed the part where you said you switched to 0.17.1, I'm still on 0.16.15, I've decided to keep my settings to only update to a Stable Version.

If the white screen happens since you updated to 0.17.1 it's important to leave feedback so the Developer knows, and maybe roll-back to 0.16.15 until 0.17.x is a stable release 



#22
dizietemblesssma

dizietemblesssma

    Old hand

  • Premium Member
  • 927 posts

 

Ah, well then I don't know then, I missed the part where you said you switched to 0.17.1, I'm still on 0.16.15, I've decided to keep my settings to only update to a Stable Version.

If the white screen happens since you updated to 0.17.1 it's important to leave feedback so the Developer knows, and maybe roll-back to 0.16.15 until 0.17.x is a stable release 

 

 

Fair enough, you respond very quickly:) Thankyou

 

If you mean feedback via the app then the app won't let me at current, will using 0.16.15 to leave feedback confuse things?



#23
Tannin42

Tannin42

    Faithful poster

  • Staff
  • PipPipPipPip
  • 2,488 posts

 

Edit:  After lots and lots of restarts and fast switching games to witcher3 I have the following, switching to SKSE or FO3 seems to be ok (famous last words!) but as soonas I switch to FO4 or FONV the whiting of the ui happens, being quick to switch back to w3 when the ui briefly appears makes the whiteness go away.

FO4 is installed on the SSD c drive in the normal steam folder, FONV is the gog version and is installed on the d drive in its own folder.

SKSE and FO3 are both installed to a second steamlibrary folder on the d drive.

 

 

This is great information.

 

It shouldn't matter that those games are on a different drive, at least I can't come up with a reason why that should matter.

 

The fact that it only crashes when managing certain games rules out a lot of the common reasons.

One thing you could check: Please go to settings to enable advanced mode, then go to the extensions page and disable the following extensions:

- Gamebryo BA2 support

- Gamebryo BSA Support

- Gamebryo Plugin Management

- Gamebryo Savegame Management

- Mod Dependency Manager

 

Then let it restart and see if the white screen is now "fixed".

If so, please reenable the plugins one-by-one and see at which point the crashes start again.

 

If I'm reading your report right, you're saying this only happens since 0.17.1, not in earlier versions? Then the most likely cause is the savegame management extension.

Out of curiosity: How many savegames do you have for the games that crash?

 

Please also make sure that you report the issue via the "More" button in the error notification.



#24
dizietemblesssma

dizietemblesssma

    Old hand

  • Premium Member
  • 927 posts

 

The fact that it only crashes when managing certain games rules out a lot of the common reasons.

One thing you could check: Please go to settings to enable advanced mode, then go to the extensions page and disable the following extensions:

- Gamebryo BA2 support

- Gamebryo BSA Support

- Gamebryo Plugin Management

- Gamebryo Savegame Management

- Mod Dependency Manager

 

Then let it restart and see if the white screen is now "fixed".

If so, please reenable the plugins one-by-one and see at which point the crashes start again.

 

If I'm reading your report right, you're saying this only happens since 0.17.1, not in earlier versions? Then the most likely cause is the savegame management extension.

Out of curiosity: How many savegames do you have for the games that crash?

 

Please also make sure that you report the issue via the "More" button in the error notification.

 

 

Ok, disabling those extensions has removed the whiting, after restarting gamebryo plugin indexlock is aronge and says 'failed'.

Just enabled ba2 plugin and still ok.

Just enabled bsa support and still ok.

Just enabled plugin management and still ok.

Just enabled savegame management and all appeared ok, until I selected the save games panel for FO4, (edit: now it goes white even on a different panel). I managed to select witcher3 and then FO3, everything ok except when I selected the savegame panel in FO3 I get a continuous 'loading' message on a blank panel.

 

The two games that suffer from the white ui have more than one profile, whereas FO3 and SKSE just have the one 'default' profile.  Also each profile for FO4 and FONV has the option selected for its own savegames, whereas FO3 and SKSE do not have this selected in their single profile each.

 

I would test by changing FO3 to select this option but I'm little worried what might go wrong at this time:)

Managed to switch to FO3 to submit report, but when i opted to attach recent state changes (was going to attach all special files) vortex froze! :smile:

Disabled savegame management and enabled mod dependency extension, all good so far,

Reenabled savegame management et voila! the white ui is back.

At this time the white ui does not seem to revert to the normal ui, I have to restart to get a chance to switch games to FO3 or SKSE or witcher3.

 

Yes this only happens with 17.1

I managed to get a feedback sentoff by restarting and not choosing to attach state changes file.

 

I altered the FO3 profile to have its own savegames and imported (moved) them from global. This went ok, I then cloned the profile and copied the savegames, still ok except for continuous loading of the savegames panel.

 

I tried selecting a different profile for each of FO4 and FONV and at the moment FONV doesn't go white bit I also get the blank savegames panel just saying 'loading'.  FO4 however, goes white no matter what.

 

I have an early shift tomorrow so i will check back after:)

 

Edit: today FONV whited out after booting win and starting vortex



#25
Jebbalon

Jebbalon

    Yeah, that Jebbalon!

  • Premium Member
  • 4,975 posts

I've been having similar issues as dizietemblesssma 

Started in 0.16.15 with the long delays after starting up and after deployment

I sent in a report and Nagev messaged me to try 0.17.1

I switched to testing from stable to let Vortex update and have since had the white screen crash reset issue.

 

The long delays were a pain but it was usable. Now it's not usable. You'll get it going soon enough I'm sure.

 

To answer the question of how many saves are in the folders.....

The 2 profiles I've been using are both for Skyrim SE. One is larger the other is small...

 

Profile with large number of saves has 4034 files (includes .ess and .skse) total of about 10.7GB

Smaller number of saves folder has 94 files and is about 156MB size.

 

Both have white screen issue - although the smaller one did display eventually - then it crashed again.

I tried disabling the Save manager extension and have not seen white screen yet but now saves are not managed. Does that mean profiles will not have individual save folders?



#26
AgentTallin

AgentTallin

    Newbie

  • Premium Member
  • 18 posts

I 'm also having the same problem when I switched to FO4 from SKSE.

No problem when I switched back to SKSE.

 

Using vortex 0.17.1



#27
DFiNo

DFiNo

    Enthusiast

  • Premium Member
  • 102 posts

I was also having the white screen crash problem. I noticed I had 1530+ files in my save game folder, so I removed about 1350 of them...problem solved. No more crashes, plus my game seems to load a bit faster. If you don't want to delete a bunch of your game saves, just move them to another folder somewhere. (using Vortex 0.17.1)


Edited by DFiNo, 31 January 2019 - 08:27 AM.


#28
dizietemblesssma

dizietemblesssma

    Old hand

  • Premium Member
  • 927 posts

 I noticed I had 1530+ files in my save game folder, so I removed about 1350 of them...problem solved. No more crashes, plus my game seems to load a bit faster.

 

I never thought to check the gamesaves themselves, I just moved all but two fallout4 saves out of its profile folder, and now no white ui, however even with only two savegame files in the profile saves folder the savegame panel just has an eternal spinning 'loading' icon.  Switched to another FO4 profile (900 odd savegame files) and bingo! white ui.

 

I checked this with FONV, the profile with 48 savegame files is not a problem the profile with 606 files does give a problem.  However on both cases where the white ui does not happen the savegame panel juist shows 'loading' AND the plugins panel still has the small spinning icon indicating that it is still sorting.

 

Edit:  noticed this - if I restart vortex then the eternal plugin sorting doesn't happen and the savegames show up, if I then change games and then switch back to the original game the plugins are fine (no sorting) but the savegame panel is hung on 'loading'.



#29
dizietemblesssma

dizietemblesssma

    Old hand

  • Premium Member
  • 927 posts

Just did a test, took a while, slowly added savegame files to the FONV profile that worked, and as soon as I added the 205th file into the profile savegame folder, vortex would whiteout loading FONV, switching to a game that doesn't whiteout, removing one file, and switching back to FONV I get no white ui,

 

To reiterate, the highest number of savegame files that works seems to be 204 with a total filesize of 1.15 GB (1,238,562,427 bytes) / 1.15 GB (1,238,970,368 bytes) ondisk.

Of course it maybe the latter that counts not the file numbers so I shall test this directly with FO4 and edit here.

 

So... with FO4 the magic number of savegames seems to be 139 or a total filesizie of 4.02 GB (4,318,425,465 bytes) / 4.02 GB (4,318,724,096 bytes) on disk. Above this the ui whiteouts.

As an experiment I took out the 10 largest savegame files and put in the 11 smallest savegame files from the one I had put aside, the total file size was now 3.81 GB (4,099,469,994 bytes) but still vortex whiteouts with what is now 140 savegame files for FO4

 

All file size totals were copy and pasted from the windows properties dialogue for each folder.



#30
Hasmith99

Hasmith99

    Enthusiast

  • Supporter
  • PipPip
  • 190 posts

Every time I switch games I get the white screen glitch (alternating between white screen and vortex). I reinstalled which fixed it, until I tried switching to new vegas again. Anyone else have this problem?

Also this was after I ran out of hard drive space while downloading skyrim mods and switched to new vegas to delete some unused texture packs, not sure if that matters or not.






IPB skins by Skinbox
Page loaded in: 0.920 seconds