Jump to content

Photo

Custom Race Plugin Troubleshooting

race sse creation kit custom race plugin modular

  • Please log in to reply
1 reply to this topic

#1
SkyeRangerDelta

SkyeRangerDelta

    Journeyman

  • Premium Member
  • 35 posts

Greetings all,

 

A while back, I built my own custom race - one that mimics the ways of the Bosmer. It has its own descriptor and abilities, and perks, and all that jazz. Well I decided that I wanted to add some war paints to it. But instead of straight adding them to the already existing race, I wanted it to be a plugin or addon to the main file. I've selected WyldTats to do this because I like some of the ones in there. I opened the CK and loaded Skyrim, RaceCompatibility (required by the custom race and all that), the main custom race file and DIDNT set an active file because I wanted this one different. So I go into the race, add the proper tinting paints and all that, textures n' stuff and saved it (I did this for both male and female and for regular race and vampire race).

 

When I load up the game, they dont show up. But I noticed that I now have two of the same race. One with the war paints and one without.

 

I re-fired up the CK and found that the "plugin" is literally duplicating the main race's race (haha) and adding it as a new one with the war paints and everything.

 

I'm really confused about how to make this work, or if it can work rather. Essentially, I want this plugin to edit an already existing race and it's duplicating it instead. If anyone can fix this, I'd be in your debt because I lost sleep on this one last night it was bothering me so much. Thank you in advance.



#2
SkyeRangerDelta

SkyeRangerDelta

    Journeyman

  • Premium Member
  • 35 posts

With the help of a fellow mod developer, I'v found and fixed the problem. The "plugin" wasn't reading the other like a master because the other wasn't a master. Using the black magic of SSEEdit, I've changed the main race file into an ESM and made it a requirement of the plugin mod. This has fixed the issue and the warpaints now properly show up in game.

 

Hope others might find that useful.

 

 

@Mods: please lock/close, whatever.


Edited by SkyeRangerDelta, 11 December 2018 - 09:29 PM.






Also tagged with one or more of these keywords: race, sse, creation kit, custom race, plugin, modular

Page loaded in: 1.022 seconds