Jump to content

Photo

Vortex And Oblivion Issues

vortex oblivion body replacer

  • Please log in to reply
27 replies to this topic

#1
Kifyi

Kifyi

    Fan

  • Members
  • PipPipPip
  • 340 posts

So I decided to try modding Oblivion with Vortex.  I installed Oblivion, ran it, closed out, loaded up Vortex and have started installing some mods. Most of them work fine. OCO v2 works fine. Unofficial patches work fine. Quest mods seem to work fine. However, I cannot figure out what I'm doing wrong to get body replacers working.

 

I've tried using HGEC and Robert's and none of it changes anything in game. I've set Vortex's Archive Invalidation on, I've since also installed archvie invalidation from the nexus site to try that way. I thought perhaps Vortex was installing the mods incorrectly and tried manually installing them. Nothing. It doesn't change anything, it's all vanilla.  What am I doing wrong? Thank you in advance!



#2
Augusta Calidia

Augusta Calidia

    Mayor of Talos Plaza

  • Premium Member
  • 1,148 posts

So I decided to try modding Oblivion with Vortex.  I installed Oblivion, ran it, closed out, loaded up Vortex and have started installing some mods. Most of them work fine. OCO v2 works fine. Unofficial patches work fine. Quest mods seem to work fine. However, I cannot figure out what I'm doing wrong to get body replacers working.

 

I've tried using HGEC and Robert's and none of it changes anything in game. I've set Vortex's Archive Invalidation on, I've since also installed archvie invalidation from the nexus site to try that way. I thought perhaps Vortex was installing the mods incorrectly and tried manually installing them. Nothing. It doesn't change anything, it's all vanilla.  What am I doing wrong? Thank you in advance!

 

In regard to archive invalidation, do you have two AI utilities turned on?  If so, turn one of them off.  Having one AI turned on is sufficient.  This probably won't solve the problem with HGEC and Roberts, but it will probably prevent other problems.

 

As for your problem mods, are they packaged as OMOD's or as 7Zip files?



#3
Kifyi

Kifyi

    Fan

  • Members
  • PipPipPip
  • 340 posts

HGEC is packaged as a fomod and Robert's is just a zip, neither work. I only have one AI going atm and it's the Vortex version.



#4
DrakeTheDragon

DrakeTheDragon

    Resident poster

  • Staff
  • PipPipPipPipPip
  • 7,511 posts

HGEC is packaged in a way most managers won't understand inherently. There is a "fomod" folder with structural explanation, but I don't know if Vortex can install FOMOD-ready archives just like that. If you now happen to find folders like "MGEC", "Common", "Underwear" and "Nude" inside your Data folder, then Vortex couldn't understand it either and it wasn't installed correctly.

 

Robert's Male though, although you left out the version number or distribution specifics there, should be rather simple to understand, unless, of course, Vortex got confused by there being a "Data" folder inside the archive and you now have a "Data" inside your "Data".

 

As for Archive Invalidation, nowadays they all work the same. There must be some new empty dummy BSA inside your Data folder now (the name of which can vary), and there's a line "sArchiveList" inside your "Oblivion.ini", which has it at around the first or second place. If either of the two isn't the case, Archive Invalidation was not applied. Does Vortex have additional requirements for applying AI, too? Like re-deploying again or similar?



#5
Augusta Calidia

Augusta Calidia

    Mayor of Talos Plaza

  • Premium Member
  • 1,148 posts

HGEC is packaged as a fomod and Robert's is just a zip, neither work. I only have one AI going atm and it's the Vortex version.

 

DrakeTheDragon has provided excellent information in response to your inquiries.  I would add only one detail - Vortex cannot install OMOD's.  You'll need to repackage any OMOD file before the mod will work in Vortex.

 

In regard to HGEC, there may be a non-OMOD version available.  Have you looked?

 

Following up on DrakeTheDragon's point about a possibly redundant "Data" folder in the Robert's mod, do you see a folder labelled "Data" in your game data folder?  If so, what's in it?


Edited by Augusta Calidia, 15 December 2018 - 06:50 PM.


#6
Kifyi

Kifyi

    Fan

  • Members
  • PipPipPip
  • 340 posts

I checked the file structure, everything seems installed correctly, no stray folders in the data folder. And manually installing them I am prompted to replace identical files, so as far as I can tell, Vortex is installing things correctly, it's just not taking effect in game whatsoever. 

 

I also checked the Oblivion.ini and added that line but to no avail. I double checked and Vortex's version of AI is still active, I also restarted Vortex after making the ini change just to make sure it saw it.

 

Edit: The version of Robert's I tried was "Robert's Female Body v13" found on Nexus. I don't have it and hgec installed at the same time, I just tried them separately to see if there was any difference.

 

Edit 2: I'd also like to add that I have uninstalled all other mods until I get this sorted out to ensure there isn't any conflicts going on.


Edited by Kifyi, 15 December 2018 - 07:13 PM.


#7
DrakeTheDragon

DrakeTheDragon

    Resident poster

  • Staff
  • PipPipPipPipPip
  • 7,511 posts

Oh, Robert's Female. I thought when you said HGEC and Robert's you meant both, a female and a male body replacer, as that's also what people usually use. But it doesn't change much, as the folder structure of Robert's Female and Robert's Male is the same.

 

So, you said you "added" that line? Meaning it wasn't there before? Not at all? Or just not containing the dummy BSA I mentioned, yet? Because this line is in everyone's "Oblivion.ini" the moment the game was properly installed. It's usually used to make the game load its own BSAs. Of course this can also be solved through the auto-load mechanism loading all BSAs starting with the same name as an ESP. But I still think, when the "sArchiveList" entry in your INI is completely missing, your game simply won't work.

 

And if it really was missing, chances are very good Vortex AI didn't work either.

 

Or let's go about all this a little differently. Was the line missing? Or was it just the new BSA? If the latter, what name does the new BSA inside your Data folder have when it comes from Vortex? Maybe this will get us closer to the reason for why it doesn't work.



#8
Kifyi

Kifyi

    Fan

  • Members
  • PipPipPip
  • 340 posts

The line is there, followed by "=Oblivion - Meshes.bsa, ArchiveInvalidationInvalidated!.bsa, Oblivion - Textures - Compressed.bsa, Oblivion - Sounds.bsa, Oblivion - Voices1.bsa, Oblivion - Voices2.bsa, Oblivion - Misc.bsa"

But immediately under it is "SResourceArchiveList=Vortex - BSA Redirection.bsa, Oblivion - Meshes.bsa,Oblivion - Textures - Compressed.bsa,Oblivion - Sounds.bsa,Oblivion - Voices1.bsa,Oblivion - Voices2.bsa,Oblivion - Misc.bsa"

 

When you said "has it at around the first or second place" I assumed you meant near the top of the file, didn't see it there, so added it, but it is at the bottom.  The name of the file Vortex added for its invalidation is "Vortex - BSA Redirection.bsa" It and the HGEC body mod are the only ones I have installed at present.

 

(Side note, I plan to use a male and female body replacer to go with OCO v2 I just haven't gotten that far lol)

 

I'd also like to say thank you for taking the time to help me figure this out. I didn't expect this to be this complicated an issue. :(



#9
Augusta Calidia

Augusta Calidia

    Mayor of Talos Plaza

  • Premium Member
  • 1,148 posts

The line is there, followed by "=Oblivion - Meshes.bsa, ArchiveInvalidationInvalidated!.bsa, Oblivion - Textures - Compressed.bsa, Oblivion - Sounds.bsa, Oblivion - Voices1.bsa, Oblivion - Voices2.bsa, Oblivion - Misc.bsa"

But immediately under it is "SResourceArchiveList=Vortex - BSA Redirection.bsa, Oblivion - Meshes.bsa,Oblivion - Textures - Compressed.bsa,Oblivion - Sounds.bsa,Oblivion - Voices1.bsa,Oblivion - Voices2.bsa,Oblivion - Misc.bsa"

 

When you said "has it at around the first or second place" I assumed you meant near the top of the file, didn't see it there, so added it, but it is at the bottom.  The name of the file Vortex added for its invalidation is "Vortex - BSA Redirection.bsa" It and the HGEC body mod are the only ones I have installed at present.

 

(Side note, I plan to use a male and female body replacer to go with OCO v2 I just haven't gotten that far lol)

 

I'd also like to say thank you for taking the time to help me figure this out. I didn't expect this to be this complicated an issue. :sad:

 

The first line of the Oblivion.ini entries for archive invalidation is not correct.  The two lines should read as follows:

 

sArchiveList=Vortex - BSA Redirection.bsa, Oblivion - Meshes.bsa, Oblivion - Textures - Compressed.bsa, Oblivion - Sounds.bsa, Oblivion - Voices1.bsa, Oblivion - Voices2.bsa, Oblivion - Misc.bsa

SResourceArchiveList=Vortex - BSA Redirection.bsa, Oblivion - Meshes.bsa,Oblivion - Textures - Compressed.bsa,Oblivion - Sounds.bsa,Oblivion - Voices1.bsa,Oblivion - Voices2.bsa,Oblivion - Misc.bsa

 

Both lines should be the last two lines in [Archive].

 

Before editing your .ini, however, make a backup copy, just in case my advice is incorrect.



#10
Kifyi

Kifyi

    Fan

  • Members
  • PipPipPip
  • 340 posts

I'm going to add that I can't launch Oblivion from Vortex. I don't really think it matters, but I thought I would note it in here. I think it's because my steam client is on a separate drive from all of my games, but don't really want to deal with the hassle of reinstalling Steam unless it would actually solve an issue. I have been launching Oblivion directly from steam instead, and also checking the data files to make sure anything I've installed with an ESP is active.







Also tagged with one or more of these keywords: vortex, oblivion, body replacer

Page loaded in: 0.882 seconds