Jump to content

Photo

Help placing projectiles via script

projectile script placeatme

  • Please log in to reply
2 replies to this topic

#1
SGTbayk47

SGTbayk47

    Old hand

  • Supporter
  • PipPipPip
  • 573 posts

Hi all,

 

I'm currently having trouble with projectiles placed via script.

 

I have the script set up to place a securitron missile projectile at a specified xmarkerheading. However when placed the missile doesn't move as if it has been fired, which is the effect I want. It just remains stationary emitting the trailing smoke etc.

 

In the script the projectiles are placed inside a gamemode block, as I want several to appear in sequence with a timer, which is working. I have just tested and if I move the spawning of the projectiles to an onactivate block they work as intended, and move as if they have been fired.

 

Any help getting the projectile to work from an onactivate block would be appreciated.

 

Thanks in advance

 

BayK



#2
uhmattbravo

uhmattbravo

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,864 posts
You need something to fire them. I've done it for a few things, myself. Basically, I used an Activator with a projectile nodes in the .nif, set up a weapon form that fires an embedded weapon from that projectile node, and just used '(RefID).fireweapon (weapon formID)' in the script.

#3
SGTbayk47

SGTbayk47

    Old hand

  • Supporter
  • PipPipPip
  • 573 posts

Awesome! I just replaced the placeatme with the fireweapon function and it works perfectly from the X markers I had set up already. Thanks for the quick response :)







Also tagged with one or more of these keywords: projectile, script, placeatme

IPB skins by Skinbox
Page loaded in: 1.073 seconds