Jump to content

Photo

I Fixed My Constant Memory Crashes, but IDK how.

memory crash skyrim se skyrim

  • Please log in to reply
3 replies to this topic

#1
SgtSandbags

SgtSandbags

    Journeyman

  • Supporter
  • Pip
  • 41 posts

(I know, the title sounds stupid, but hear me out)

Alright, so I finally got finished with my modlist, and everything loaded fine, but it seems there were just random crashes that would just happen to me randomly (For instance, it's happened indoors, outdoors, wait menu, just waiting, etc.) 

 

So I kept crashing, and every crash it would be like "Your Skyrim SE.exe has crashed. Minidump uploaded--" etc. etc. 

 

So I analyzed it and every dump said this:

 

In CrashDump-2019-05-26-02-47-53.dmp the assembly instruction at SkyrimSE+10704eb in E:\Steam\steamapps\common\Skyrim Special Edition\SkyrimSE.exe from Bethesda Softworks has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000000 on thread 0

 

And after some research, I basically concluded it was memory related (Because, to be fair, I have a s*** ton of mods, so I thought it was one of them)

 

But every tweak that was supposed to be considered a "fix" didn't work, I woke up today, and changed a few things.

 

I went from crashing within 5 minutes, to not crashing at all (maybe it will crash when I start playing more, but overall, the crashing seems to have ceased at all.

 

So, the two changes I made was:

 

1): Skyrim.ini tweaks; I changed the following settings from their vanilla values.

 

uExterior Cell Buffer=108

uInterior Cell Buffer=108

iPreloadSizeLimit=1048576000

 

and my second one is:

 

2)Changing some settings in  Enblocal.ini

Someone said to do some tweaks (I already had speedhacks enabled), and I made a change by insterting this entire section for "[MEMORY]"

[MEMORY]
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=64
VideoMemorySizeMb=10240
EnableCompression=false
AutodetectVideoMemorySize=false
 
To be completely honest, I don't want to touch anything at the moment, because it's running amazingly. But could anyone tell me if 1) or 2) would actually be useful in preventing a crash, or, in other words, can you tell me which one likely helped relieve my memory crash problem? Thank you


#2
albpalace

albpalace

    Stranger

  • Members
  • Pip
  • 1 posts

I have Skyrim SE heavily modded with 4K textures, and I was tired of CTDs and frame rate drops. I have tried everyhing without success. I found your post and introduced those lines in my files (though the VRAM of my card was 8 Gb instead of 10 Gb in the VideoMemorySizeMb). I also changed the valuie of iVSyncPresentInterval to 0 in SkyrinPrefs.ini and used my graphic card (NVIDIA RTX 2070 Super) to perform the VSync. After some hours playing, the CTDs, crashes and frame rate drops are gone!.  Thank you very much!



#3
BeingShotAt

BeingShotAt

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,016 posts

Not to necromancy this thread, but do you add

 

uInterior Cell Buffer
iPreloadSizeLimit 

If they are not already in your skyrim.ini? Because they are not in my skyrim.ini



#4
GhostN1nja

GhostN1nja

    Journeyman

  • Members
  • Pip
  • 29 posts

Not to necromancy this thread, but do you add

 

uInterior Cell Buffer
iPreloadSizeLimit 

If they are not already in your skyrim.ini? Because they are not in my skyrim.ini

Yes







Also tagged with one or more of these keywords: memory, crash, skyrim se, skyrim

IPB skins by Skinbox
Page loaded in: 1.164 seconds