Jump to content

Photo

Radio Music Over Dialogue


  • Please log in to reply
8 replies to this topic

#1
Glenrhee

Glenrhee

    Fan

  • Premium Member
  • 411 posts

Might be a beginner question, but I can't find anything about it on any tutorial. I've added custom replacement music to a pre-built radio station. In-game it plays just fine, songs cycle just fine, it all works, but for whatever reason the songs don't get quiet over dialogue or other "cut away" scenes. It's always full volume. I've looked through the .esp and can't find anything, though I very vaguely remember an FO3 tutorial talking about this exact issue, but I can't find it. Other radio songs and vanilla get quiet in dialogue as they should. They're .mp3 files to match the radio's original files. I haven't tested the original files to see if they do the same thing yet. Wanna rule out if this is just an easy beginner's mistake or a flag I have to enable. Anyone know?


Edited by Glenrhee, 13 July 2019 - 09:58 AM.


#2
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 8,113 posts

Please see the 'Music and Sounds' section of the wiki "Getting started creating mods using GECK" article.  In particular, see 'TIP Format to call a song'.

 

-Dubious-



#3
Glenrhee

Glenrhee

    Fan

  • Premium Member
  • 411 posts

Hi, thanks for the link. I tried it, made sure the songs were in the right format and bitrate, but they still don't go quiet over dialogue. I also tested the original files, and it's the same result. I'm still relatively inexperienced at GECK modding, most of what I do is FNVEdit and for this audio editing software. I've not been able to find anything different from this mod compared to other radio mods with quieter music over dialogue or fade-outs.



#4
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 8,113 posts

I found a thread regarding this issue for FO3.  There was a mod which resolved by:

redirects Fallout 3 to play the .wav files of the songs instead of the MP3s, so the music will still play quietly in the background during dialogue instead of not at all.

The original mod was "Radio Stutter Fix" by Razorwire, but it has been removed.

 

The mod "Radio Active Channel Extender (RACE)" by tortured Tomato has auto mute during dialogues, which is silence rather than volume reduction.  But the technique may be worth examining for your purposes.

 

-Dubious-



#5
Glenrhee

Glenrhee

    Fan

  • Premium Member
  • 411 posts

Tried doing that as well, setting the radio to play .wav files instead. It plays the first announcement on loop, never switching to the other songs. There's no script to this particular radio so I'm not sure if that's the problem.



#6
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 8,113 posts

The first song "looping" seems like a "playlist" problem.  I would look into the linked tutorials in the "Music" section linked previously for that solution.  Sorry I can't be more help but this is something I don't have any direct experience with.

 

-Dubious-



#7
Glenrhee

Glenrhee

    Fan

  • Premium Member
  • 411 posts

So it turns out I was encoding them wrong all along. If anyone else is wondering, here's how you get the muted music during dialogues:

 

1. The music has to be in mono .wav format.

2. It has to be in a CBR (constant bit rate) of 256 or less. Most audio editing programs let you choose to export it this way.

3. It'll sound louder out-of-game than in-game, so don't lower the volume too much on it.

 

Voila, music gets quiet when in dialogue.



#8
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 8,113 posts

Glad you solved it.  Thanks for reporting your solution.  I've added 'TIP Music and Dialog' to "Music and Sounds" section of the wiki article so it will help the next person.

 

-Dubious-



#9
Glenrhee

Glenrhee

    Fan

  • Premium Member
  • 411 posts

Awesome! Thank you.






Page loaded in: 1.059 seconds