Jump to content

Photo

mesh - model is 10x bigger than it should be

nifskope blender 3d model size scale scaling

  • Please log in to reply
12 replies to this topic

#11
Ech0Chamber

Ech0Chamber

    Newbie

  • Members
  • Pip
  • 11 posts

BTW, I haven't tried it out, but Blender has a scale multiplier when importing or exporting. You might just be exporting the mesh 10x higher, which suspiciously enough is the same as the default value for that multiplier.

BY THE NINE DIVINES!

My first failed attempt was scaling down the object vertices, however object scaling worked perfectly.

In Blender, use object scaling to get the desired size results. No scale modifications required in NifSkope

 

I'll be editing the top of this post for quick access to the answer of this problem for impatient people like myself

 

Results after changing the object scale to "0.1" in Blender

Kku35QQ.png



#12
Moraelin

Moraelin

    Negotiator Gladiarius

  • Premium Member
  • 5,303 posts
Sounds like Atom smiled upon you :wink:

#13
RoNin1971

RoNin1971

    Old hand

  • Members
  • PipPipPip
  • 500 posts

I know, I'm late, but there's a 'better' solution for editing a lot of meshes, without manually setting the scale (& rotation) each time:

 

 

When importing an .obj file, into blender on the right side of the file selection menu there's a bunch of settings. Set 'clamp size' to 1.0 for the right scale (it'll show up as 'scale 0.1') and set the Z-up for the axis, to have the right rotation too. (it will show up with Z -90 degrees)

When exporting make sure its set to Z-up as well.

 

As blender will remember these settings, you'll only have to set it right ones, and enjoy the results over and over again ;)







Also tagged with one or more of these keywords: nifskope, blender, 3d, model, size, scale, scaling

IPB skins by Skinbox
Page loaded in: 1.070 seconds