Jump to content

Photo

Horses keep sliding or flying.


  • Please log in to reply
9 replies to this topic

#1
zooloo75

zooloo75

    Newbie

  • Members
  • Pip
  • 13 posts


^ That video sums up what I'm experiencing.

I use the Nexus Mod Manager to install mods. There a lots of mods installed, so if there's a quick way to paste all the enabled mods I have with NMM, please tell me so I can offer more details.

IDK if this is caused by mods, or if it's a bug in Skyrim.
I tried making new characters, and it still happens.

#2
FastBlackCat

FastBlackCat

    Warrior Cat

  • Premium Member
  • 31,642 posts
It's a Skyrim thing--I've had this happen to Frost, and just recently. Fortunately, I have Convenient Horses installed, which enables a god mode setting for the horse, or Frost would have been toast. I've also had flying mammoths, and giants, and dragon skeletons. A good friend of mine had his PC killed by a falling mammoth. :laugh: His PC and Lydia were hiking down a trail after killing a dragon, and Lydia said, "I have a bad feeling about this . . . " and then SQUASH! A mammoth plummetted down and smashed his PC.

I don't know if there's a fix for this or not. I save often and reload if I have to, although one time, oddly enough, after doing that, it happened again! (It was a dead mammoth and a dragon skeleton together that came down.) Didn't expect it to happen again.

Edited by FastBlackCat, 30 September 2012 - 05:24 PM.


#3
Georgiegril

Georgiegril

    I'm always like this

  • Premium Member
  • 4,469 posts
It is a mod issue. Bben's Troubleshooting guide can walk you through the procedure to identify your specific issue.

#4
Cymri

Cymri

    Regular

  • Members
  • PipPip
  • 66 posts
So, I have this, and it is 100% *not* a Beth problem, as it goes away if I launch w/the actual TESV.exe, but it immediately occurs on the same save load if I launch from SKSE. OFC, I want me my SKSE mods! Game eventually crashes those particular saves that had them when they are loaded.

Note that I deselected and pulled ALL mods, running only w/official DLCs for this experiment. A clean save w/only Skyrim, Update, Dawnguard, Hearthfires, and Dragonborn had no slidey slidey until SKSE was in the picture. I'm guessing it is a script somewhere getting parsed.

BTW, the behavior behaves like bad Havok physics, IMO.

I have also seen sliding NPCs in combat , but suspect that s my bad for incorrectly selecting 1h weap in FNIS when it was not installed (since none of the modders actually said which files shoulda be checked off for their mods in FNIS).

#5
bben46

bben46

    I had a title once, but I forgot what it was.

  • Premium Member
  • 24,973 posts

If you play without SKSE then some mods will never start. It's like they are not even there. Then when you do use SKSE they do run. My guess is some mod that requires SKSE is giving you this problem. Although I have heard of the falling mammoth syndrome in vanilla games also. It happens when a mammoth - or other creature spawns too high ( z axis offset). I thought Beth fixed that with one of the official patches. But it's possible a mod negated that patch. Probably a mod made with the older version that doesn't work quite right with the newer version.



#6
Cymri

Cymri

    Regular

  • Members
  • PipPip
  • 66 posts

If you play without SKSE then some mods will never start. It's like they are not even there. Then when you do use SKSE they do run. My guess is some mod that requires SKSE is giving you this problem. Although I have heard of the falling mammoth syndrome in vanilla games also. It happens when a mammoth - or other creature spawns too high ( z axis offset). I thought Beth fixed that with one of the official patches. But it's possible a mod negated that patch. Probably a mod made with the older version that doesn't work quite right with the newer version.

Yeah, I disabled and pulled ALL of my mods to test a clean save:  no slide w/SKSE off, but slide w/it on. 

 

As no mod was in place, only a bad script call or maybe a behavior file (but those would still need a script pointing to them if they only did this under SKSE, I think) would likely do this, at least rom what I understand of the engine.

 

I managed to reinstall a few mods w/scripts,including Better Horses (I see no recent posts in that mod for sliding horses) and the slide now seems to happen only if I have reloaded while mounted, but not if I dismount, save, load, remount and ride.  At least, so far.

 

Unfortunately, I now have my own horse listing as "STEAL" (%username% horse), when I clearly own it.  Already-owned (from before this bug) horses w/n let me mount, and those bought after the bug hit still say "Steal", and leave if I dismount.

 

I have a few mods w/new FNIS-affected horse animations, so I assume they may have whammied the sliding, but this new Steal thing is annoying.  Fix one problem, get 3 more.



#7
mikkaisen

mikkaisen

    Newbie

  • Premium Member
  • 10 posts

So there is no easy solution for this?



#8
captice

captice

    Enthusiast

  • Supporter
  • PipPip
  • 242 posts

Seems like the only fix for this is to put the poor animal out of is misery and travel skyrim on foot...



#9
HadToRegister

HadToRegister

    Beer Ambassador

  • Premium Member
  • 9,349 posts

Necroed a thread from Six Years ago.

 

 

 

 

 

 

 

 

From "MyGoodEye"
 

 

This is often caused by a vanilla "object" called a COMPLEX SCENE MARKER. There are a couple of these around SKyrim and are designed, I suspect, to tell the game to do a number of "performance enhancing" routines... including but not limited to decreasing the amount of corpses, arrows and decals "allowed" in that particular area...

... it has the unfortunate effect of also sending some animals flying... including when you're riding one.

It can be exacerbated by having "too many things" happening at the same time in the same cell - but that "too many" is determined entirely (from what I can tell) upon your system, inis, resources, etc...

In other words... get used to it :wink:


--------------------------

Could disabling these Complex Scene Markers fix the issue?

 
--------------------------------

Disabling, no (don't ask me why, but they seem to be "always on" even when disabled).

Removing, yes - in instances in which they are the cause. But removing them may have the unknown effect of potentially messing up the areas in which they were placed - and they are linked to a spider web of other objectReferences...

Thing is, these markers are completely undocumented and have "mysterious purpose" and "unknown radius". I assumed from observation that their radius was relative to the user's UGRIDS. I've gleaned some of their purpose from my use of them in earlier versions of WARZONES (they are all now removed entirely from WARZONES 2015.2 because they exacerbated the flying animals and follower problems for many users) but I can not say with any level of certainty that the removal of the remaining vanilla ones will not be detrimental in ways unknown.

It is likely that your "culprit" is "too much stuff". When Mammoths start flying, you've reached a certain threshold in your game's resources, I've found. Not a dangerous threshold necessarily... but one in which the game seems to have to "stop paying attention" to some things on screen in order to keep pace with the user's demands. Unscientific observations.

 

 

 

 

 

This is why I use a bashed patch for the TWEAK options.
Too many actors in one place can cause things to start flying etc.

You have to raise the number of Actors in the Bash Patch Tweak options

 

I can't see the OP's video, but it would be helpful if he posts his load order in [ spoiler] tahs



#10
sa547

sa547

    Ordre de la Rose

  • Members
  • PipPipPipPipPip
  • 4,293 posts

 

 

This is why I use a bashed patch for the TWEAK options.
Too many actors in one place can cause things to start flying etc.

 

Intriguing. I gotta try this since I'm getting sick and tired of watching horses fly and fortunately I have a copy of Wrye Bash.






Page loaded in: 0.741 seconds