Jump to content

Photo

Mesh Visible in Nifskope, Invisible in CK and Game.

player home nikscope mesh dds

  • Please log in to reply
4 replies to this topic

#1
QueenAcademe

QueenAcademe

    Enthusiast

  • Supporter
  • PipPip
  • 145 posts

Hello there! I am a (very) novice modder and have encountered an issue splicing several meshes together. I am hoping to use the blue patterned mattress/blanket from Snazzy Furniture with the common left bed frame from EEK's Whiterun Interiors.

 

My process has been to paste the BSTriShape, BSLightingShaderProperty, and the BSShaderTextureSet from the common bed left frame into the noble bed and then delete the originals. Doing so renders it perfectly in Nifscope, but the bed frame fails to render in the creation kit. Does anyone know why this might be? 

59414403d51b945f327d064178fa6fc0ea14095f

32345540cb32615ffc9b386652553144da7f1879

32664297e6371ae11669a9549552095b3e491eb9
 

I've attached the .dds, but the textures were too large (even zipped) to include. 

 

 

Attached Files



#2
SkiaMK

SkiaMK

    Regular

  • Supporter
  • PipPip
  • 80 posts

Here you go... You had an extraneous BSLightingShaderProperty (which I'm not sure was actually hurting anything but I removed anyway) and you did not place the BSTriShape for your bed-frame within the BSFadeNode.

 

The attached copy should work... I didn't put in CK but I did do a quick and dirty test by renaming it and having overwrite the mesh for the child beds in Dragonsreach so I could see it game and sure enough, other than being purple because I don't have the textures it worked.

 

Cheers,

Skia

Attached Files



#3
QueenAcademe

QueenAcademe

    Enthusiast

  • Supporter
  • PipPip
  • 145 posts

Here you go... You had an extraneous BSLightingShaderProperty (which I'm not sure was actually hurting anything but I removed anyway) and you did not place the BSTriShape for your bed-frame within the BSFadeNode.

 

The attached copy should work... I didn't put in CK but I did do a quick and dirty test by renaming it and having overwrite the mesh for the child beds in Dragonsreach so I could see it game and sure enough, other than being purple because I don't have the textures it worked.

 

Cheers,

Skia

 

This worked perfectly; thank you SO much. 



#4
QueenAcademe

QueenAcademe

    Enthusiast

  • Supporter
  • PipPip
  • 145 posts

Here you go... You had an extraneous BSLightingShaderProperty (which I'm not sure was actually hurting anything but I removed anyway) and you did not place the BSTriShape for your bed-frame within the BSFadeNode.

 

The attached copy should work... I didn't put in CK but I did do a quick and dirty test by renaming it and having overwrite the mesh for the child beds in Dragonsreach so I could see it game and sure enough, other than being purple because I don't have the textures it worked.

 

Cheers,

Skia

 

For future reference, how do I place the BSTriShape within the BSFadeNode? 



#5
SkiaMK

SkiaMK

    Regular

  • Supporter
  • PipPip
  • 80 posts

On the fadenode update the number of children then hit the refresh (green arrows in a circle) under it... Then double click the new child link and type the number of the node you want to add as a child. (see screen shot)

Attached Files







Also tagged with one or more of these keywords: player home, nikscope, mesh, dds

Page loaded in: 1.074 seconds