Jump to content

Photo

Fallout New Vegas poco bueno, nmc, textures over time,ojo beuno texture packs not loading using mm2. Need help please.

mod order problems ini problems fallout new vegas texture mods not working

  • Please log in to reply
9 replies to this topic

#1
YWHW2019

YWHW2019

    Stranger

  • Members
  • Pip
  • 7 posts

I use mod manager 2 to install all texture mods i'm having a problem with something about the INI files and a read only flag and the lightening bolt symbols on the textures are red line some have a plus with a red line. I do not know how to fix please help. P.S new to modding so yes lol i'm a modding newbie.


Edited by YWHW2019, 17 January 2020 - 11:58 PM.


#2
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 7,972 posts

Have you seen the wiki "How to ask for help" article?  Because I am going to ask you one of the earliest and most fundamental questions presented there.  Answering the other questions there when you reply will reduce the number of back-and-forth exchanges we go through to resolve your problems, getting you up and playing faster.  (Save that information to speed things up with your next problem.  Because there will be one.)

 

Where (drive and path) did you install FNV?  Details matter.  What INI files have the "read-only" flag?  Most likely guess is the pair located in the "C:\Users\<yourAccountName>\Documents\My Games\Fallout New Vega" folder.  (There are many articles on the web about how to change file properties such as that flag.)  But some mods have their own INI files as well.  If you have the game installed under the default of the "C:\Program Files" folder tree, then you are going to always be fighting with Windows which will not let you turn off that protection for files anywhere under that file tree for long.

 

* Did you install Steam to it's default location?  If so, please see the wiki "Installing Games on Windows Vista+" article for why the original default Steam behavior of installing games to the "C:\Program Files" or "C:\Program Files(x86)" folder tree was bad (they learned better, and don't do that any more); and why "disabling UAC and running as Administrator" is NOT sufficient, with instructions how to move it.  This is the single most important thing you can do to fix and protect yourself against problems in the future.  As much of a PITA as that is, it's never going to be any easier than now.  System updates often cause issues with games installed to these folder trees.  With the game moved out of the default location you will not need to be running it as an "Administrator Account", which is safer.  Please see the 'Restoring to "Vanilla"' section of the wiki "FNV General Mod Use Advice" article as well.

  Disabling "User Account Control" (UAC) only stops Windows from prompting you to grant "administrative" credentials to an application that the system says must have a "UAC elevation".  Disabling UAC does not automatically then enable the permission for such applications.  Instead, (for all intents and purposes) it automatically denies them.  (Please read this MS article on how it works in Win10.  The basics have been there since the inception of UAC with Vista.)

  If you did move Steam out of the default location, then likely any access privilege problem is one of "File and Folder permissions" on the parent "root" folder under which you installed the games.  If this is not set correctly to allow at least "System", "Administrators", and "Users" to have "Full Control" then you can't overwrite other files or make changes.  You then (while logged in as an "Administrator Account") need to enable the "Properties | Security | Advanced | Change Permissions" setting of the parent folder to enable the box: "Replace all child object permissions with inheritable permissions from this object", so those changes get applied to the existing files and sub-folders.

I recommend anyone read the entire "FNV General Mod Use Advice" article to understand the differences between this game and others you may have experience with; especially if this is your first attempt to play a modded FNV or it's been more than a year since you last did so.  It is designed for someone who has never played a modded PC game before, so it tries to avoid making any assumptions.

 

If you believe the problem lies within MO2, then you need to check out their support.

 

Re: Using more than one texture pack.

Please see the wiki "Display resolution versus Image Size" article.

To illustrate such considerations: I use both "Ojo Bueno" and "NMC" texture packs with a 4GB VRAM video card on an older [email protected] system still running Win7 (upgraded from WinXP; simply to show how old it is).

I chose to install "Ojo Bueno - Performance" (textures up to 2048 x 2048) first, because most of it's images indicate it's dealing with more fore- to mid- ground textures.  IMO, these tend to use more models with more details and vertices.  They are more demanding of video resources.

I installed "NMC - Large" (Typically: 2048 x 2048 Textures & 2048 x 2048 Bumpmaps/Normal maps) second, because it seems to be more "View While Distant/Level of Detail (VWD/LOD)" oriented, which are lower in details and vertices but where the two overlap I wanted the consistency in favor of the NMC imagery color scheme.

You could install them in the reverse order, depending upon which you preferred to win any "overlap" conflicts.  I'm quite pleased with the result, both visually and performance wise; but will confess to not being highly demanding in the visual regard compared to others.  YMMV.

If you add (or remove) any VWD/LOD textures (such as NMC, Vurt's WFO, or Ojo Bueno), please see the 'Checklist Item #15 & 16' entries in the wiki "Fallout NV Mod Conflict Troubleshooting" guide regarding the need to run both TES4LL and FNVLODGen; or xLODGen - Terrain LOD beta for FNV, FO3, FO4, FO4VR, TES5, SSE, TES5VR, ENDERAL.  Also recommend you read the 'LOD/VWD Texture Packs' section of the wiki "FNV General Mod Use Advice" article first.

 

-Dubious-



#3
YWHW2019

YWHW2019

    Stranger

  • Members
  • Pip
  • 7 posts

My game is installed on an external d drive.



#4
YWHW2019

YWHW2019

    Stranger

  • Members
  • Pip
  • 7 posts

And im an administrator and i run this on windows 10. 



#5
YWHW2019

YWHW2019

    Stranger

  • Members
  • Pip
  • 7 posts

So i did what you said i disabled uac a already had an admin account and i also checked the box in permissions to  "Replace all child object permissions with inheritable permissions from this object". and i moved it out of steam apps to the desktop and changed the game file location in mm2 to only recognize the game folder on the desktop I still have the prompt talking about the read only popping up and every time i click on proprieties on the folder and uncheck the box read only it automaticly sets it back again to read only. Again im confused about computer modding im from consoles. So again im confused.


Edited by YWHW2019, 18 January 2020 - 11:45 AM.


#6
YWHW2019

YWHW2019

    Stranger

  • Members
  • Pip
  • 7 posts

Its an InI file that is somewhere i can change clear a read only flag. 



#7
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 7,972 posts

The "desktop" is a "special case" folder located under your "Users" account.  It is another "not a good place for games" location used by the system.  (I've updated the "Installing" article to reflect that.)  Best is to create a separate folder (such as "D:\Games"), give it the necessary permissions you want and Windows won't mess around with, and move your games there (as described in the referenced articles) so they will automatically inherit the permissions you established on the parent folder.

 

The only INI locations you should need to clear the "read only" flag from are in the game root folder (where the "FalloutNV.exe" file is located), and the "NVSE" subfolder and it's subfolders.  Otherwise, make a careful note as to which file is reporting the flag error so we can track it down.

 

-Dubious-



#8
YWHW2019

YWHW2019

    Stranger

  • Members
  • Pip
  • 7 posts

A popup from mm2 says the fallout.ini file is set to read only but when i go into properties its not set to read only. So at this point i'm getting pissed yo. I changed the location from the desktop to a new separate folder in the d drive btw. 



#9
YWHW2019

YWHW2019

    Stranger

  • Members
  • Pip
  • 7 posts
 
13:36:56.170 [W] C:/Users/Owner/AppData/Local/ModOrganizer/fallout NV/profiles/Default/fallout.ini is read-only.  Attempting to clear read-only flag.


#10
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 7,972 posts

That is a file belonging to MO2 itself.  The "AppData" folder is a "protected system folder", so you are fighting with Windows.  I can't believe this issue hasn't come up before but I don't use MO2 myself, so you need to check with the MO2 support team as to how they suggest you deal with it. 

 

But if they don't have a suggestion, then (and only then) you might try the procedure laid out here on the "/Default" subfolder ONLY that lies under "C:/Users/Owner/AppData/Local/ModOrganizer/fallout NV/profiles/Default".  If that doesn't seem to "stick", then slowly work your way back up that path, as in "Default" first, then "profiles", then "fallout NV", etc., testing after each change.  You don't want to attempt to remove such protections any higher in the path than necessary.

 

-Dubious-







Also tagged with one or more of these keywords: mod order problems, ini problems, fallout new vegas, texture mods not working

Page loaded in: 1.100 seconds