Jump to content

Photo

Witcher 3 GOTY Modded no DLC's

dlc mods goty witcher witcher 3 modded missing help

1 reply to this topic

#1
yollohallo

yollohallo

    Stranger

  • Premium Member
  • 5 posts

Hey, so I've been modding TW3 Goty a bit lately and have run into some issues with the Dlc's working properly.

 

I've read a few threads about either empty folders being in the DLC Directory of TW3 that could cause this issue which isn't the case.

Another solution was checking the dlc folders added by mods if they are correctly placed. Like TW3 > DLC > "DLCMOD" instead of something like TW3 > DLC > DLC > "DLCMOD".

So these solutions didn't do a lot for me.

 

I've got DLC Options in the game's settings menu like the alternative look for yennefer and the options that got added by the mods I installed.

I also got the options to start only B&W or only HoS, but if I try and select one of those nothing happens. I can't start the DLC variants of the Games.

Going into the Game there is also content from DLC's missing. Some DLC Quests are there but for example I've got only the vanilla 10 General Skills.

 

Script Merger has merged all files automatically and all the mods are working.

Just the DLC's are missing.

Here are some Screenshots of how it looks for me.

https://imgur.com/a/r0H65o1

 

Thanks for any kind of help in Advance,

Yollo.



#2
titouille313

titouille313

    Stranger

  • Members
  • Pip
  • 3 posts

Hi,

 

I've run into a similar problem. I played the game and the dlc a few years back without problem. Wanted to play again with mods now that i got a new pc and screen, and it was just fine until now.

 

I just finished the main game this afternoon, and the only active quest i haven't finished is "gwent : collect them all". My character is also lvl 41 so it isn't a lvl cap problem.

 

I've tried re-installing the game because one of the unificatiojn patch made the dlc pop up disapear on the main menu, and after reinstalling they got back up. But still, impossible to launch a dlc.

 

Then i uninstalled every mod i had hoping one of them would be the thing that caused problem, but still no way to launch heart of stone at the 7 cat Inn.

 

 

I finally found your post talking about the empty folders into the DLC folders and that solved my game. Some mods like brutal blood and real weathers created empty folders there. I've deleted them all, just keeping "bob" ep1" and DLC 1 to 16"

 

So thank you for solving my problem, and sorry for not solving yours ...

 

 

EDIT 1 : i tried launching my game after deleting the empty folders, and i couold launch the dlc quests. Problem, whjen i re-installed all my mods, the game bug and is stuck in loading, even with a save i took before taking the DLC quests. So i guess one of the mods make everything bug, and it's gonna teke me forever to know which one. I need to activate them by small group until i found the concerned mods. But my computer crash and i need to manually reboot everytime i fail loading a save, hope i don't ruin my pc doing that.

 

EDIT 2 : After completly removerd blutal blood and trueweather who seem to be the source of problem for many people, i've desactived many mod, trying launching only a bunch a few times, the game won't start now, if i've 1 mod or more activated, when launching the game with mods wasn't a problem before. The processus goes on in the windows task manager but the game won't start.

Also, with every mod desactivated, the game starts normally and DLC are up and running.

 

EDIT 3 : Reintallated vortex after a n update, pick the strictly usefull mod (alsmost 20) and it works for me. I spotted 2 mods who could made the game not working for me : Trademan 1.31 and modrareitemmerchant but then again, i'm not really sure. Now that it works for me i won't try it too hard for comfort mods.


Edited by titouille313, 20 February 2020 - 12:08 AM.




Reply to this topic



  



Also tagged with one or more of these keywords: dlc, mods, goty, witcher, witcher 3, modded, missing, help

Page loaded in: 1.104 seconds