Jump to content

Photo

Magnolia's Burlesque Outfit Pink Stockings Issue

effect shaders cbbe clothing

  • Please log in to reply
17 replies to this topic

#11
AbsolutGrndZer0

AbsolutGrndZer0

    Fan

  • Members
  • PipPipPip
  • 254 posts

Err, that's weird. I have RX series card and experienced the same purple tint. After I turned off Env Mapping, everything looked as it should.

Edit: I was curious about this, since I'm an AMD user myself. Sorry that didn't work for you. Best of luck in figuring out the root of this problem.

 

Edit2: I tried one more thing, which leads me to believe it is actually a missing texture. I copied Env Map texture from the mod COCO Lace Body, called pvc_e.dds, and pasted it in the folder of magnolia's burlesque outfit. I opened the BGEM file, in Effects where the main texture for the stocking is, I put pvc_e.dds as Envmap Mask Texture. Environment Mapping in General settings I left on. The stockings looked normal in the game.

No, it's not a missing texture, as only those with AMD cards have the issue. The only reason that might work is that you are swapping that pvc_e.dds for the Magnolia one.  That doesn't mean the Magnolia texture is missing.  You can also see the effect on this mod https://www.nexusmod...tab=description it all works great, except for the laser sights are purple.  Again, the texture is not missing in any way shape or form, just something about the way it is rendered doesn't work on an AMD.



#12
robotized

robotized

    Fan

  • Premium Member
  • 328 posts

Like I said, I'm on AMD too, RX580 to be precise. An here is the other weird part, I'm not swapping anything. When I installed the mod and opened the BGEM file, there was nothing assigned for Envmap Texture or Envmap Mask Texture. There was only the Base Texture for the stockings(Shadowliger/MagnoliaDress/MagnoliaDressStockings_d.dds), which I did not touch. I also tried the M9 from the link. The laser sight wasn't purple for me, sorry. If it is for you, then you are right, something's fishy and may not be a missing texture. Which means that this doesn't affect all AMD cards.



#13
AbsolutGrndZer0

AbsolutGrndZer0

    Fan

  • Members
  • PipPipPip
  • 254 posts

Like I said, I'm on AMD too, RX580 to be precise. An here is the other weird part, I'm not swapping anything. When I installed the mod and opened the BGEM file, there was nothing assigned for Envmap Texture or Envmap Mask Texture. There was only the Base Texture for the stockings(Shadowliger/MagnoliaDress/MagnoliaDressStockings_d.dds), which I did not touch. I also tried the M9 from the link. The laser sight wasn't purple for me, sorry. If it is for you, then you are right, something's fishy and may not be a missing texture. Which means that this doesn't affect all AMD cards.

Well, it could also be something fixed on much newer cards, as yea RX580 is a lot newer than mine (an R9 380 series).  Fact is, NovaFinch is a mod author who has figured out what exactly causes it and makes "AMD Patches" for his mods now.

Quote NovaFinch: Sight fix for AMD users that experience a purple lens texture.
If you are an Nvidia user or do not experience a purple texture then you do not need this.


So yes, not all AMD users have this error, but many do.  So, we're hoping that he will answer our pleas to help us fix it.

 

EDIT: Also I Double checked and I was wrong about that Beretta having the issue, but I do know I have a gun mod that does... would have to see what other gun mods I have that do.

EDIT 2: And yea just tried what you said, adding that pvc_e.dds file and nope. Didn't fix it.

 


Edited by AbsolutGrndZer0, 23 March 2020 - 11:30 PM.


#14
robotized

robotized

    Fan

  • Premium Member
  • 328 posts

You up for more experiments? Try this:

Edit:Link removed, no longer necessary.

The archive contains Dress-WithoutSkirt.nif + material file. I set stockings inside the nif to use different material - with BGSM extension. The tri morphs of the stockings still have EffectShader property attached to them.



#15
AbsolutGrndZer0

AbsolutGrndZer0

    Fan

  • Members
  • PipPipPip
  • 254 posts

That

 

You up for more experiments? Try this:

https://drive.google...MF0WRG0sErU4XX_

The archive contains Dress-WithoutSkirt.nif + material file. I set stockings inside the nif to use different material - with BGSM extension. The tri morphs of the stockings still have EffectShader property attached to them.

That worked great, now can you explain a bit more what you did, so Shadowliger can replicate it and we can help other modders 'fix' this issue in other mods where it rears its' ugly head?



#16
robotized

robotized

    Fan

  • Premium Member
  • 328 posts

With Material Editor I created new file. When you view material files in the program, there are 3 pages/tabs with settings - General, Material and Effect. Under General, I changed two things:

1. Reduced "Alpha" to 0.90

2. Enabled "Two Sided"

Since BGSM is going to be used, I switched to Material tab. Only thing I did here was put

Shadowliger/MagnoliaDress/MagnoliaDressStockings_d.dds

in the filed for Diffuse Texture.

Then I saved the file as MagnoliaStockings.BGSM.

Next, with NifScope I edited the material, used for the meshes of Stockings and Stockings_2(*). Since it's the same name, I only changed the extension to BGSM. Same operation could be done in Outfit Studio.

 

(*)Yes, there are two meshes/tri morphs. Maybe that is done on purpose. Regardless, I switched the material for both.

 

I am not sure this is a universal fix. And I still think the proper way is to use BGEM file for meshes with BSEffectShaderProperty. But, at first glance it works in the game, and there are no purple tints.

Btw, I still have one other backup solution, which is more complicated. It involves adding BSLightingShaderProperty and AlphaProperty with NifScope, using BGSM file with option for Decal. This will require creating Normal and Specular maps. Also the texture looks a bit different in the game. I've tried that, so I know it works.



#17
robotized

robotized

    Fan

  • Premium Member
  • 328 posts

NovaFinch isn't going to be able to help in this case. One look at the sticky posts of one of his mods, and also viewing both the original and fixed scopes side by side, I can tell you his fix is actually removing the mesh of the lens that's making trouble. For Magnolia's outfit this means deleting the mesh for the stockings, and we all know that's not an option. I tried his Desert Eagle mod and experienced the purple tint once again. And I fixed it not with his patch, but with what I suggested in my very first post here. I opened the material for the lens(Circle_Glass.BGEM) and removed Environment Mapping. Which once again makes me think that this is an issue with missing texture. If Environment Mapping is On, the problem is that the texture is missing, there is an empty field for Envmap Texture. If you turn it Off, the Envmap Texture is no longer required, thus no more problem with a missing texture. A visual representation of what I talk about, because sometimes words don't cut it:

Screenshot of MagnoliaStocking.BGEM

2 out of 2 I fixed this way. This just can't be a coincidence. AbsolutGrndZer0 I am going to ask once again, please take a look at the screenshot and tell me, did you open the BGEM inside Material Editor, disable/remove Environment Mapping and then Save the BGEM file?



#18
AbsolutGrndZer0

AbsolutGrndZer0

    Fan

  • Members
  • PipPipPip
  • 254 posts

NovaFinch isn't going to be able to help in this case. One look at the sticky posts of one of his mods, and also viewing both the original and fixed scopes side by side, I can tell you his fix is actually removing the mesh of the lens that's making trouble. For Magnolia's outfit this means deleting the mesh for the stockings, and we all know that's not an option. I tried his Desert Eagle mod and experienced the purple tint once again. And I fixed it not with his patch, but with what I suggested in my very first post here. I opened the material for the lens(Circle_Glass.BGEM) and removed Environment Mapping. Which once again makes me think that this is an issue with missing texture. If Environment Mapping is On, the problem is that the texture is missing, there is an empty field for Envmap Texture. If you turn it Off, the Envmap Texture is no longer required, thus no more problem with a missing texture. A visual representation of what I talk about, because sometimes words don't cut it:

Screenshot of MagnoliaStocking.BGEM

2 out of 2 I fixed this way. This just can't be a coincidence. AbsolutGrndZer0 I am going to ask once again, please take a look at the screenshot and tell me, did you open the BGEM inside Material Editor, disable/remove Environment Mapping and then Save the BGEM file?

Yes, I did and it didn't help but your other thing DID work.







Also tagged with one or more of these keywords: effect shaders, cbbe, clothing

Page loaded in: 1.040 seconds