Jump to content

Photo

Mod to stop point-blank combat?

distance npc combat ai

  • Please log in to reply
1 reply to this topic

#1
Qaerixxszhara

Qaerixxszhara

    Journeyman

  • Supporter
  • Pip
  • 48 posts

Is there a mod that effectively stops NPC's running into yours and each other's faces with ranged weapons? I am sick of NPC's that actively run into melee range of their target with a rifle and then just stand there spraying, it looks incredibly dumb and it breaks my immersion in half.

 

I have tried Combat Enhancer and Modified Combat Values which claim to fix this, but it still happens regularly.



#2
Mktavish

Mktavish

    Pleb

  • Premium Member
  • 2,658 posts

What game setting(s) did you try adjusting ?  And did you notice any change at all , re-testing same area ?

Not sure , but I don't think there is anything in the game settings for specifically minimum ranged weapon use.

There is this "fCombatMinEngageDistance"  But of course that would effect mele too I think.

And it seems more like this setting would only be used when transitioning into combat AI from regular AI.

Something to keep Actors from starting out with possibly clipping through the player after extending a weapon.

But obviously during combat can end up with the barrel of a gun on the other side of the player depending how cramped the environment is.

 

There is two spots you can adjust the value , on the Weapon : Range / Min ...        

And the Combat Style : Weapons ; Ranged Weapon Ranged Mult  (Min / left box)   

But these are suggestive in nature , and do not limit all times the Actor would fire the weapon.

The combat AI is pretty complex , and how often they fire overrides the distance. But they will gravitate to the range of the weapon eventually , which there are quite a few gun weapons set with 128 for the min , about the height of most NPC's.

 

So if you wanted to alleviate this as much as possible game wide , as simple as possible.

Just adjust that setting on all the CombatStyles that are applicable , which looks like 12-15 is all you may want to adjust.  Setting "Ranged Weapon Ranged Mult (min) " about 3 - 5 ... what ever feels good after some testing.

But specific weapons you may have to check the "Fixed" flag to bypass the range multiplier.

Like flamethrowers or shotguns.  But do it after noticing problems , because remember the ranges are not absolute to where they will fire.

But before you delve into all of them ... pick a spot you want to test at.  Find out what Actor/NPCs are there.

Then look at the Combat Style they have.  And adjust that one.  Then in game try charging them and see at what point they usually start back peddling to get away from you.

 

My count of 12-15 combat styles was from loading all the DLC's  Just looking at combat styles used by gun wielding actors , so no creatures except Super Mutants.  

Nothing that says Mele , and nothing that says Sniper.

Since Sniper ones have less than 1 for min , there is something specific there , that I don't think you should mess with.  Plus any sniper combat AI is probably almost never going to be in your face.

Also in the object list , 2 columns over from the Editor ID  "Users"   if it is 0 , then you don't need to adjust it.

Also any ones that appear to be for a named like "CSNVLegateLanius"  I wouldn't adjust those either.

 

1 thing to note ... once you get an edit to a combat style saved into an .esp ... you can then adjust it using FNV-Edit , and will be easy to find from there since only the adjusted ones will show in your file.

 

Also in case just having npc's take up to much of the screen is part of what breaks immersion for you.

Try adjusting the FOV setting ... which you can do with the console.







Also tagged with one or more of these keywords: distance, npc, combat, ai

Page loaded in: 1.030 seconds