Jump to content

Photo

Mod Standards - why don't we use a version standard?


3 replies to this topic

#1
vegavak

vegavak

    Journeyman

  • Members
  • Pip
  • 28 posts

Why do we always have to figure out what version of mods works with the version of game?

 

Shouldn't mods released for 1.3 be versioned at 1.3.XXX?

 

Mods for 1.4 released at 1.4.XXX?

 

Doesn't that make sense?

 

1.4.1Beta for 1.4 beta? or whatever?



#2
Snyper1010

Snyper1010

    Newbie

  • Premium Member
  • 14 posts

No, because then when a mod receives an update how can they adjust the version number if it is tied to which version of game it is compatible with? Also, what happens if the mod works with multiple versions of the game? 



#3
029614

029614

    Stranger

  • Members
  • Pip
  • 6 posts

Actually I agree. It would be more in line with most versioning conventions to version mods as game patches. If you were offering a major overhaul or total conversion, then it would be more appropriate to version that uniquely.

 

I would suggest everyone to agree on a convention prefacing their mod version with the game version: b4.1-1.0("game version"-"mod version") or something along these lines.


Edited by 029614, 23 May 2020 - 05:57 AM.


#4
DeckardKain

DeckardKain

    Regular

  • Supporter
  • PipPip
  • 79 posts

I wish nexus included a tag for version numbers so that we could filter versions in search. 
thats all we need imho





Reply to this topic



  


Page loaded in: 0.938 seconds