Jump to content

Photo

FNIS for Skyrim SE Warning showing up and updating time?

fnis skyrimse skyrim vortex

  • Please log in to reply
7 replies to this topic

#1
failedartkid

failedartkid

    Stranger

  • Members
  • Pip
  • 4 posts

Hi, so I'm really new at modding and I need some help understanding some stuff

 

First, every time FNIS runs, I get the following warning:
 

1 Warning(s).
Generated files redirected to C:\Users\markc\AppData\Roaming\Vortex\skyrimse\mods\FNIS Data (Default)

Based on my reading of this, it just means that the files are being redirected to another folder, and I don't have much of a problem with that, but apparently the program has an issue with it. Is there any way I can fix this so the program stops warning me about it?

I'm hoping that through resolving this first issue, I'll solve my second one, which is that when Vortex tries deploying updates from FNIS it never succeeds. Is this a separate issue? Or if I can fix part one will part two likely clear up?
 
Sorry again for my lack of knowledge about this stuff, if any additional info is needed I can happily provide it! Thanks!


#2
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 12,386 posts

I'm not even really sure why the FNIS window is open if you're running it through Vortex, but the redirect can be ignored. 

 

As for the second, I'm not really sure. You'd need to include your Vortex log file or something to give us more info. 



#3
rmm200

rmm200

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,817 posts

There are two items that may affect this. Under Settings, there is one for Run FNIS at Deploy. Good if you never want to run it manually.

Then the FNIS window has a couple of options you should always check. Skeleton arm fix is one, and check HKX files for compatibility. The one of interest is Redirect data file for Vortex. I never set that one - and it redirects anyway.

Thing to note about FNIS - each Profile for that game has it's own FNIS data file. Default is the one for Profile Default. Each one will have a name matching the profile. Make sure only the correct one is enabled for the Profile you are on.



#4
nt5raham

nt5raham

    Enthusiast

  • Premium Member
  • 115 posts

I'm not even really sure why the FNIS window is open if you're running it through Vortex, but the redirect can be ignored. 

When I run FNIS through Vortex, the FNIS window opens any time there is an error message.  I figured that was normal.  Pickysaurus, are you saying it should not open at all if run through Vortex?



#5
rmm200

rmm200

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,817 posts

If FNIS does not open a window, you have no chance to set required FNIS options.

If you use a replacement skeleton, the skeleton arm patch is always required.

If you are running SE, you should also set Check for hkx compatibility.



#6
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 12,386 posts

You can change the FNIS options inside Vortex rmm200. It's a button on the "mods" toolbar.

 

I haven't used FNIS in a while, but I believe it's not supposed to open the main app window unless there's an error Vortex can't resolve. 



#7
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 12,386 posts

I just checked with Tannin, FNIS is not supposed to open when running on deployment unless there is an error. 



#8
rmm200

rmm200

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,817 posts

Having an enhanced skeleton and not checking the Skeleton Arm Fix counts as an error.

I think that alone will cause the window to open.

 

On a new profile, I set it to run on Deploy; that seems to create the profile specific FNIS Data.

After that, I turn it off to run FNIS manually.

I actually never saw much use for the FNIS file redirection check. It redirects in either case.


Edited by rmm200, 02 June 2020 - 03:36 PM.






Also tagged with one or more of these keywords: fnis, skyrimse, skyrim, vortex

Page loaded in: 1.039 seconds