Jump to content

Photo

Been using the "No Class Restrictions on Weapons" mod and noticed some bugged animations for Female Human Rogues. Has anyone else noticed this

animations mods weapons human female rogue

No replies to this topic

#1
Brandozero

Brandozero

    Newbie

  • Members
  • Pip
  • 10 posts

So I just started my second playthrough of Inquisition since playing it on release and was excited to try out the various mods that have been made over the years. The "No Class Restrictions on Weapons" mod as well as mods that unlock all abilities for every class to use seemed super appealing to make a sort of multiclassed inquisitor.

 

The way the mod works however implored me to play a rogue as its the only class that can equip and use all weapons and skills without trouble as bows are completely unusable by non-rogues. I tested the mod on my original human male inquisitor and was astonished by how well and seamless the mod worked.

 

When I made my new character, a human female rogue, I noticed that the "trail" of sword and shield weapons looked strange compared to how Cassandra's looked.

 

Here are some examples of this:

 

Sword and Shield: https://imgur.com/a/sT0JNgn

 

Greatsword: https://imgur.com/a/BC1Myi2

 

Notice how the weapons trail is completely crooked and off track with the sword. The greatsword animation as well is especially horrendous in motion, the blade's trail wildly flailing in a very buggy way.

 

Naturally I assumed this was some inevitable bug due to the nature of the mod and me trying to make the game do something it wasn't designed to do, but to troubleshoot I made a female rogue of a different race to test it out. Turns out the animation worked fine on EVERY SINGLE OTHER COMBINATION -except- human female rogue.

 

Here is an elven rogue as an example: https://imgur.com/a/aKcl0nm

 

But every single other combination of races and gender worked fine for a rogue. ONLY female human rogues seemed to have this issue, which made me think this may not be a problem with my mods at all.

 

Upon looking further into it I also noticed that AOE dual-bladed weapons also had a bugged animation exclusively for female human rogues. Even when I used the mod to have Cassandra equip the dual-blades as a warrior her animation worked fine!

 

Dual Blade Example: https://imgur.com/a/grM7R8c

 

I removed the mods and still noticed that my human female rogue's animations were still glitched with AOE dual-blades. I know this seems like such a small and strange thing to have even noticed, but the fact that literally only one race\class combo has this problem has me scratching my head if this is something that can be fixed or is related to something. Is this something consistent across everyone's game or just mine?

 

I haven't been able to find anything on any forum or site noticing or discussing this bug. I wonder if it is possible to create a mod to fix this if it is just a bug of the base game? If anyone happens to have a human female rogue with a pair of dual-blades, is this animation error replicating for you as well or is it just me?

 

Sorry if this is a strangely specific post, but I'm just curious if anyone else has noticed this before! I feel like a chump that the one race/class combo I wanted to try is the only one that's bugged, haha. Of course I could always just make a warrior or play a different race, but I feel like I have to try if there's some kind of solution before I dive into another 90+ hour playthrough.





Reply to this topic



  



Also tagged with one or more of these keywords: animations, mods, weapons, human, female, rogue

Page loaded in: 1.073 seconds