Jump to content

Photo

Opening/editing/converting Skyrim Special Edition .DDS files on Linux

bug linux dds edit dxgi error unsupported dxgi format texture

  • Please log in to reply
2 replies to this topic

#1
Vai1lyn

Vai1lyn

    Journeyman

  • Members
  • Pip
  • 30 posts

Hello

 

I know of several other forum threads discussing this issue, but none have come up with a working solution for me.

 

What do I want to do?

 

I want to do private retextures for some textures added by mods (since I want the texture to match my armor). Don't worry for permission breaches, since I am not intending on publishing them anywhere, it is just for my personal color OCD.

 

How do I do it?

 

I am running Linux, and use the latest version of Gimp with the (current version, but outdated) DDS plugin.

 

The error

 

Opening some textures, I get the following error: Unknown DXGI Error (98) (or 99 in some cases).

 

What did I try to circumvent it?

 

The following methods were suggested in other threads, or things I tried on my own, but nothing worked.

 

* converting it to another format

I tried to convert it to .png's using ImageMagick, but the conversion failed, saying that the file type is not supported.

 

* opening in an image viewer, making a screenshot and editing the screenshot

And it failed opening, either saying image not supported or Unknown error.

 

* online solutions

I tried several online file converters, but all failed due to unknown conversion errors.

 

Was anyone using Linux able to bypass this error? If yes, I'd be glad to hear from you!

 

Cheers



#2
Vai1lyn

Vai1lyn

    Journeyman

  • Members
  • Pip
  • 30 posts

Quick addition: the problem is easily solvable by downloading the Oldrim textures (as they are previous versions of DDS), however not all mods are available for Oldrim, too.



#3
anjenthedog

anjenthedog

    Faithful poster

  • Premium Member
  • 1,413 posts

Download PaintdotNet and run it through wine?







Also tagged with one or more of these keywords: bug, linux, dds, edit, dxgi, error, unsupported dxgi, format, texture

Page loaded in: 1.087 seconds