Jump to content

Photo

Nifskope issue

nifskope model fallout new vegas new vegas blender

  • Please log in to reply
3 replies to this topic

#1
boofrog8

boofrog8

    Stranger

  • Members
  • Pip
  • 6 posts

Hey so i have managed to use blender to modify a outfit to work with this race mod https://www.loversla...ed-sissy-sluts/ but everytime i try open any nif or obj i export from blender in nifskope i get a Error [32] Array Extra Data List much too large. 96010567 bytes requested failed to load block number 32 (NiSourceTexture) previous block was NiScourceTexture any help would be great thanks.



#2
madmongo

madmongo

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,114 posts

Feminized sissy sluts? :laugh:

 

Make sure you are using Blender 2.49b with the appropriate nif tools.

The complete package with all of the versions that work together properly is here:

https://www.nexusmod...on/mods/12248/?

 

DO NOT export as obj and try to import it into NifSkope. That will never work.

 

If you want your outfit to actually work, DO NOT use newer versions of Blender.

 

Make sure everything is selected. Blender will only export the selected parts.

 

Make sure your mesh is properly rigged to the skeleton (armature). Blender Noob to Pro is a free online reference and has tutorials on rigging and bone weighting. Just make sure that you search for the 2.49 version of the tutorial. Any mesh parts that aren't rigged will go really crazy in-game and might crash your game or the GECK.

 

If you are using the upper body slot like most outfits do, make sure you export the human body along with the outfit, since for the upper body slot the outfit and body in your mesh will completely replace the race's default body mesh.

 

Make sure all textures are UV mapped.

 

Export your mesh as a nif. In the export options, make sure that you have Fallout 3 selected. To make sure you have the right options selected, click on Restore Defaults for Selected Game (bottom left), then at the top center, click on Creature and Skin, then under Shader Options, make sure that Use BSFadeNodeRoot is unselected.

 

Blender doesn't export shader flags correctly, so after you export your nif, you need to fix this in NifSkope. For the human body parts the type needs to be set to SHADER_SKIN and make sure SF_SHADOW_MAP and SF_FACEGEN are both checked. For armor/clothing parts, the type needs to be set to SHADER_DEFAULT and  make sure  SF_SHADOW_MAP and SF_REMAPABLE_TEXTURES are both checked. Blender will usually export the rest of the shader flags correctly.

 

Add the outfit in the GECK, and maybe add a world model for when you drop the outfit, and you should be good to go.



#3
boofrog8

boofrog8

    Stranger

  • Members
  • Pip
  • 6 posts

Feminized sissy sluts? :laugh:

 

Make sure you are using Blender 2.49b with the appropriate nif tools.

The complete package with all of the versions that work together properly is here:

https://www.nexusmod...on/mods/12248/?

 

DO NOT export as obj and try to import it into NifSkope. That will never work.

 

If you want your outfit to actually work, DO NOT use newer versions of Blender.

 

Make sure everything is selected. Blender will only export the selected parts.

 

Make sure your mesh is properly rigged to the skeleton (armature). Blender Noob to Pro is a free online reference and has tutorials on rigging and bone weighting. Just make sure that you search for the 2.49 version of the tutorial. Any mesh parts that aren't rigged will go really crazy in-game and might crash your game or the GECK.

 

If you are using the upper body slot like most outfits do, make sure you export the human body along with the outfit, since for the upper body slot the outfit and body in your mesh will completely replace the race's default body mesh.

 

Make sure all textures are UV mapped.

 

Export your mesh as a nif. In the export options, make sure that you have Fallout 3 selected. To make sure you have the right options selected, click on Restore Defaults for Selected Game (bottom left), then at the top center, click on Creature and Skin, then under Shader Options, make sure that Use BSFadeNodeRoot is unselected.

 

Blender doesn't export shader flags correctly, so after you export your nif, you need to fix this in NifSkope. For the human body parts the type needs to be set to SHADER_SKIN and make sure SF_SHADOW_MAP and SF_FACEGEN are both checked. For armor/clothing parts, the type needs to be set to SHADER_DEFAULT and  make sure  SF_SHADOW_MAP and SF_REMAPABLE_TEXTURES are both checked. Blender will usually export the rest of the shader flags correctly.

 

Add the outfit in the GECK, and maybe add a world model for when you drop the outfit, and you should be good to go.

 

um yeah when i try open my .blend in that version of blender it will not open so i would have to remake my blend file. and also from i can gather from the new version the issue i am having is something to do with textures but when i check the uv my model will not use my uv textures in blender so unless that is only for export i don't know.



#4
boofrog8

boofrog8

    Stranger

  • Members
  • Pip
  • 6 posts

also i have managed to work out what the issue is so now i know the issue is vertices weights so by that i mean some vertices have no weights and i have no clue how to fix that.


Edited by boofrog8, 18 July 2020 - 12:36 PM.






Also tagged with one or more of these keywords: nifskope, model, fallout new vegas, new vegas, blender

Page loaded in: 1.041 seconds