Jump to content

Photo

Why is my script waiting in an IF condition not met?

script

  • Please log in to reply
4 replies to this topic

#1
antstubell

antstubell

    Old hand

  • Supporter
  • PipPipPip
  • 926 posts

Have a lock gate script that works fine except, it appears, that the script is executing a Utility.Wait in conditions that are not met. That's the best way I can explain it. Video link attached and script.

In the video you can see that when player activates the lever - not the first time but every time after - that it needs 2 pulls. I am guessing the script is executing a Utility.Wait that I don't want it to.

Spoiler

 

https://onedrive.liv...D8E!191&o=OneUp


Edited by antstubell, 23 July 2020 - 12:24 PM.


#2
Rasikko

Rasikko

    The Arbiter of Time

  • Members
  • PipPipPipPip
  • 1,243 posts

It does look like it's getting hung up on the waits. How long is the wait supposed to be?


Edited by Rasikko, 23 July 2020 - 08:51 PM.


#3
antstubell

antstubell

    Old hand

  • Supporter
  • PipPipPip
  • 926 posts

You know what, it typical CK fashion, it now works fine. Just by me going to bed and waking up. The wonders of CK.



#4
Rasikko

Rasikko

    The Arbiter of Time

  • Members
  • PipPipPipPip
  • 1,243 posts

That's nice work you got going there by the way.



#5
antstubell

antstubell

    Old hand

  • Supporter
  • PipPipPip
  • 926 posts

Well it's thanks to you guys that I got back into modding. Here's a compilation of what I've done, just some, there is more.

https://www.youtube....rfsiDQQ&t=1308s

 

I may post this generally as a thank you.







Also tagged with one or more of these keywords: script

Page loaded in: 1.040 seconds