Jump to content

Photo

Please Help: Idle Animations not Working

mods animation fnis pretty idle animations

  • Please log in to reply
4 replies to this topic

#1
LexiRexi

LexiRexi

    Enthusiast

  • Supporter
  • PipPip
  • 130 posts

Hey all. I've recently come back to the wonderful world of Skyrim and took the plunge from SLE to SSE and have been loving it so far. Unfortunately, about 100 mods in, I'm finally hitting some issues.

 

I'm using a number of animation mods, so let me list them all here:

 

FNIS (+ sexy move, PCEA2, creature pack and spells) - all working correctly

Pretty Combat Animations - working correctly

 

I also have CBBE + Bodyslide Studio and XPMSE skeleton.

 

and most recently decided I wanted to try and add Pretty Female Idles...

(important to note, when this one didn't work I attempted another idle animation mod... which suffers the exact same problem as PFI)

 

So I'm using Mod Organizer 2 along with LOOT. I read mod descriptions and try to keep all my mods in as good an order as possible but maybe I messed up somewhere along the lines, idk...

 

Pretty Female Idles and apparently no other idle mod will work for me. I found ONE way of making it work and that was to open up RaceMenu, change my gender and then back, reload my preset (to fix the uggo from gender swapping) and the animation plays just fine for all tested idle mods. However, this BREAKS the other animation mods. Everything reverts to vanilla.

 

I find this really perplexing when I had no issues adding any other animation mod... Nothing seems to be overwriting the mods and the mods themselves are not overwriting others, either. So no conflicts. Does anybody have any idea what the issue could be here? It's probably something painfully obvious but I haven't modded in so long I may as well be considered fresh and new to it...

 

Thanks everyone.



#2
LexiRexi

LexiRexi

    Enthusiast

  • Supporter
  • PipPip
  • 130 posts

Still seeking help on this one, if anyone is able to figure it out... doesn't seem so, at this rate. x.x



#3
xPotatoLordx15

xPotatoLordx15

    Enthusiast

  • Premium Member
  • 110 posts

I'm having the exact same problem rn. Try to move up XMPSE skeleton plugin in your load order. I heard making it to the top helps resolve this.



#4
sorcerernocturn

sorcerernocturn

    Stranger

  • Members
  • Pip
  • 1 posts

Hey, 

 

I don't know if this will work but it did for me.

Situation or problem all characters stuck in I think it's called T-Pose, no walking movement or anything like that just static.

 

So in Vortex I went to my last saved game and clicked down arrow and one of the options was reload game profile.  Now everything moves normally or how I had it.

 

I installed Bodyslide and hose everything and had to reinstall all mods anyway so not much tooo loose.

 

Hope it works.



#5
Thedudeistt

Thedudeistt

    Enthusiast

  • Premium Member
  • 119 posts

There is a possibility that the idles aren't able to play due to the way that animation mod files are numbered. The bigger the number, the more they overwrite. It might be worth checking the numbering on the idle animation files to see if that's your issue. Your testing supports this for the sole reason that they seem to work only when nothing else works, which means the game is reverting to vanilla for everything except the idles. The reason you don't see this is that animation file overwrites usually don't appear on mod managers unless they're the same exact files for the same exact animations. But idles work a little differently as they temporarily overwrite other idle animations while they're playing. 

 

Hmm. The way to know for sure would be to test it would be to disable all the animation mods and to see which exactly is preventing idles from working, after which you can figure out your own solution, possibly, again, changing the numbering of the file folders. Since you don't have all that many animation mods then this shouldn't take too long. My bet is pretty combat idles and maybe sexy move? Anything that affects how your character stands.

 

Something I found out somewhere later down the line is that if there's two animation files for the same exact thing running at the same exact time, then your character does their best to reenact an epileptic, or simply reverts to vanilla. This however, only happened to me when I had a full animation package called awakened greatsword warrior and used a separate animation for a combat idle that was similar to it. Which caused the idle animation to keep moving the warrior's arm between the two stances. However, that animation package is quite buggy on its own so I may be wrong. I've moved on from that anyway. and PCEA seems to to contradict that as it allows you to use animation packages on top with smaller, more specialized animations on the bottom that have no problem overwriting the other, incidentally lower-numbered ones. 

 

My bet, personally? The conflict is the pretty combat idles, because they have your character in an animated pose while idle. Thus, the idles would have to overwrite this in order to play at all. Again, something that can be fixed by increasing the number on the animation files for these presumably temporary idles. I'd say just go into the folder for any idle animation folder and add a few zeroes to them and I reckon that will fix all your issues in this regard.

 

As far as I know, pcea doesn't work with idles, idles definitely need to be lower in your load order than any other animation-related file, and the numbering should be bigger. Try this out. You can easily check which animation files touch upon the idle animations by looking through the mod directories. Thankfully, the naming for the individual files is universal so you can just see if they exist in each mod. I don't know what will happen if idle animations are numbered higher than active combat animations, but I'd reckon that they're scripted to not happen during combat anyway. 

 

An example of all this would be a conversation on the posts in Nexusmods for UNDERDOG idle animations. There was a whole scramble there because other animations were overwriting underdog. What I've mentioned so far was the solution that everyone used, including the mod author when they updated it. 


Edited by Thedudeistt, 11 September 2021 - 06:24 PM.






Also tagged with one or more of these keywords: mods, animation, fnis, pretty idle animations

IPB skins by Skinbox
Page loaded in: 1.034 seconds