Jump to content

Photo

Mute all sound after fast travel


  • Please log in to reply
9 replies to this topic

#1
TyburnKetch

TyburnKetch

    Enthusiast

  • Members
  • PipPip
  • 204 posts
I have a set up whereby after fast travelling to my player home stables I have various scripts that are set up to move the player and actors (horses) to different locations depending on if the player is riding, has a horse but is not riding or does not have a horse at all. The script covers different actors (horses) and the player themselves.

I have set up imagespace modifiers to start with a black screen and I am using the event OnFastTravelEnd. This event did not even exist when I first started this mod! Haha. Shows how long it is taking me.... anyway.

The event works really well. I have the script attached to a reference alias filled by the player. All of my horses end up where I want them. The player ends up where I want him. Although it is this that could be my issue.

Basically I have a brilliant view and starting position for the player when they arrive at the home. But due to the angle required to get it perfect I have had to set up a door marker. Using an xmarker heading just did not enable me to tilt the starting view of the player. A door marker does this so this is the route I have taken. Basically on arrival to the cell the horses go one way and the player opens a dummy door that positions them where I want. All works. Except ...

For a split second, either when first entering the cell, or when the dummy door is opened (it happens so fast it is hard for me to tell) sound blips and then goes silent, before the script finishes and all is as it should be.

On the script (which I can post if it helps) I have a mute function for _audiocategorymaster at the start of the script along with the black screen modifier, all the meat of the actor placement happens, and then the audio is unmuted, the screen fades (actually it pops) from black and all is as if the player has fast travelled back to the home as normal.

But this audio blip (the imagemodifier works flawlessly btw - the screen stays black throughout) is really annoying!

Is it that I am opening a door mid script (the door is actually in another adjacent exterior cell) that causes the main audio to pop in overriding my mute function? Or is the slither of audio happening before my script fires?

Hope this all makes sense.

Any insight, much appreciated.

Edit: I should add that I have tried putting a mute function script on the door itself but that made no difference. Also the audio heard seems to be music, ambient weather and feet landing on the ground. Which might suggest that the slither of audio is before the script fires. But I am just not sure. Anyway to mute audio BEFORE the event of landing in the cell after fast travel?

Edited by TyburnKetch, 12 August 2020 - 01:20 PM.


#2
TyburnKetch

TyburnKetch

    Enthusiast

  • Members
  • PipPip
  • 204 posts
Never mind. Sorted it. Just had to reapply the mute master just before the door is opened! It was so easy in the end, as always when you know how, but my god has this taken me forever to work out! Delighted :)

#3
cumbrianlad

cumbrianlad

    Right turn, Clyde!

  • Premium Member
  • 1,314 posts

I saw this reply after I posted about music. I'm impressed. I could maybe call on you sometime for this kind of thing?



#4
TyburnKetch

TyburnKetch

    Enthusiast

  • Members
  • PipPip
  • 204 posts
Sure, except unfortunately I got all delighted too soon :( It has not made any difference. Further testing has revealed that the slither of audio is still escaping.

I am now pretty sure that it is not the door that is the problem but the fact I have to move the player from their landing position (straight after fast travel) to another marker BEFORE then opening the door. This only fires when actually on horseback. If fast travelling to the location without being on a horse the muting of the audio works fine. It is this hop that I have to do, to split the player from the horse, that is causing the issue. I have to separate the player and the horse otherwise the player will not open the door.

Bah ...

Edit* Ok. I am a total buffoon. I moved my xmarker headings slightly into the ground and hey presto, the audio blips have gone!! Facepalm

Edited by TyburnKetch, 13 August 2020 - 02:58 AM.


#5
cumbrianlad

cumbrianlad

    Right turn, Clyde!

  • Premium Member
  • 1,314 posts

Odd that moving the xmarker heading into the ground fixed it.

 

Then again, I had a pair of teleport doors linked correctly on finalized navmesh and in-game, the player was plonked right back at the coc marker when going one way. The other way worked fine. I tried adjusting the door markers and finalizing again with no joy. In desperation I unchecked the teleport box on the doors and connected them up again. It now works.

 

Good that you got it fixed.



#6
TyburnKetch

TyburnKetch

    Enthusiast

  • Members
  • PipPip
  • 204 posts
Yeah. The sound escaping was the split second it takes the player to LAND in the cell. Because my markers were at a slight angle I am guessing the game saw the player as being airborne or something. Weird how that negated the mute(s) I have running. But now the markers are slightly (more than I would usually) embedded in the ground the game does not break the mute.

#7
maxarturo

maxarturo

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,841 posts
Read carefully the 'creationkit' web page on the sound functions category and especially on the 'Mute' reference.
There is a 'Bug' that ones it fires you can never come back from, the bug is not meantion or listed but it's directly connected to the page's reference on the 'Mute'.
 
* I personally after some point removed all of my mod's custom music and music functions because through all my experiments i discovered that all music functions are very sensitive and they can easily lead to a lot of bugs (that they are not listed) on heavy mods or heavy scripted mods.
 
* I prefer 1000 times over stability, consistency and security from fanciness and shiny wrap paper.

Edited by maxarturo, 13 August 2020 - 02:44 PM.


#8
TyburnKetch

TyburnKetch

    Enthusiast

  • Members
  • PipPip
  • 204 posts
Thank you Maxarturo. I have read and understood it. In testing I managed to mute everything once or twice when not desired. It carried over to the next time I started the game, like as described. Obviously as a Modder I can rectify it on the fly but I agree it is a concern. I will have to think about a couple of security options, more than one, in case this happens to somebody.

Unless there are other bugs involving Mute that I am unaware of?

#9
maxarturo

maxarturo

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,841 posts
It's been more than a year that i did all my testings and remove all custom music + functions, so i don't quite remember all the bugs an the conditions in which they would fire.
 
I'm sure that you have run into mods that the combat music or custom music will just not stop playing, and in most cases the 'fix' is to completely remove that particular function from the mod.
 
The one bug that i do remember was very 'cunning' because it did the exact opposite from the above, it would 'STOP' playing ALL MUSIC  for ever !!, forcing you to either load a mod's pre-installation save or start a new game (without the mod in it).


#10
TyburnKetch

TyburnKetch

    Enthusiast

  • Members
  • PipPip
  • 204 posts
Interesting. Yes, I have experienced that before. Will test throughly. I have to make this particular set up work but will be over cautious with it.

Thanks again for the heads up.




Page loaded in: 0.950 seconds