Jump to content

Photo

Custom companion does not dismiss

companion dismiss

  • Please log in to reply
1 reply to this topic

#1
zayrot

zayrot

    Stranger

  • Members
  • Pip
  • 7 posts

Hi everyone! 

 

This is the first mod I'm working on, so excuse me for any rookie mistakes I might make. 


The issue: Every follower function works fine, except for the dismiss function. The conversation ends at the appropriate point, but I don't get an option to send the follower anywhere. When I talk to the NPC again, I get the normal follower options and it is still commandable.

- the FollowersScript.GetScript().DismissCompanion is compiled properly
- the dismissal-scene sets the parent quest stage to the correct one at the last phase

- the dismissal-scene is linked in the companionactorscript

 

- for testing convenience and because I read that not homing to a workshop area might be a problem, I've set the Homelocation in the companionactorscript to SanctuaryHillsLocation
- I used the sandbox idle of Preston for reference, it is set to 'SactuarySandboxMarker' in 'SanctuaryExt'

One thing I'm not sure about, is the condition of the sandbox package or if it even matters for the dismissal. After trying a few things, I've set it to [S | GetStageDone | Dismissal Scene]. That didn't make anything better or worse

I have tried to fix this for a whole day, but I've ran out of options. Not that my knowledge on these matters is very vast to begin with. Dismissing the companion via console command doesn't work either, it just gets stuck in a talk-option loop.


Other issues I have encountered, maybe someone seeing this has some answers:

- The companion pulls up their shoulders comically while standing still
- While I tried to fix the dismissal, conversations suddenly started to cancel. I bandaid fixed that by checking the 'Prevent Player Exit Dialogue' in all scenes. I don't know if this will bite me later though.


Thank you to anyone taking the time to help me out!


Edited by zayrot, 29 August 2020 - 12:12 PM.


#2
zayrot

zayrot

    Stranger

  • Members
  • Pip
  • 7 posts

For anyone wondering or in the same boat:

I made a completely new mod from scratch and now the dismissal works. Same conditions and everything, so I believe, that it must have been some issue with old data / corrupted file. I did check all scripts for redundant data and they were clean, so I really don't know what it was.

The 'send companion to settlement' window still does not pop up, but that might have to do with the progress of my savegame. I'll have to check that again at a later point.







Also tagged with one or more of these keywords: companion, dismiss

Page loaded in: 1.255 seconds