Jump to content

Photo

Characters bobbing up and down

glitch

  • Please log in to reply
10 replies to this topic

#1
nognow

nognow

    Regular

  • Supporter
  • PipPip
  • 97 posts

All NPCs start to bob up and down whenever I look at them from close range. Zooming in on them causes it from any distance.

In the video, I'm obviously using mods, but I tried vanilla (with the exception of NVSE related mods) and it's the same thing

https://streamable.com/gllpv7

https://streamable.com/1sqli7



#2
KiCHo666

KiCHo666

    A Nice Guy Fascist

  • Supporter
  • PipPipPipPip
  • 2,066 posts

Is your framerate over 60 fps?
The more your framerate is above 60 fps, the more likely you'll see this problem.



#3
nognow

nognow

    Regular

  • Supporter
  • PipPip
  • 97 posts

Is your framerate over 60 fps?
The more your framerate is above 60 fps, the more likely you'll see this problem.

yes, it is.

capped at 119 with Gsync.

I'll play around with various fps and vsync settings and update.



#4
nognow

nognow

    Regular

  • Supporter
  • PipPip
  • 97 posts

Is your framerate over 60 fps?
The more your framerate is above 60 fps, the more likely you'll see this problem.

that's indeed the culprit.

lowering the refresh rate to 60 did the trick.

but I don't want to loose out on half my fps, any known fix to this?



#5
KiCHo666

KiCHo666

    A Nice Guy Fascist

  • Supporter
  • PipPipPipPip
  • 2,066 posts

No idea how to fix it, but you can disable Leg IK in the Fallout.ini. Search for the "Leg" and you'll find it.
However, by disabling that, actors will no longer adapt their leg position to the terrain.



#6
nognow

nognow

    Regular

  • Supporter
  • PipPip
  • 97 posts

No idea how to fix it, but you can disable Leg IK in the Fallout.ini. Search for the "Leg" and you'll find it.
However, by disabling that, actors will no longer adapt their leg position to the terrain.

I just looked through all INI files, there are no entries with the word "leg"



#7
JimboUK

JimboUK

    There's someone watching me, I can tell.

  • Premium Member
  • 45,135 posts

There are a bunch of settings under FootIK but I see nowhere to disable it, anyway I've had what's described here and switching off FootIK via TFIK in console didn't help so I left it on.



#8
KiCHo666

KiCHo666

    A Nice Guy Fascist

  • Supporter
  • PipPipPipPip
  • 2,066 posts

I apologize. Yes, "Foot", not "Leg".

Also, according to NVTF's author:

Solution #1:
Make sure that your in-game framerate is capped below 120 FPS. Better use some fps counter to double check if it really is below 120.

Solution #2:
That is a trade off between player foot dynamic placement efficiency and the absence of foot bouncing glitches for NPCs. It eliminates NPCs bouncing glitches almost entirely, but also makes player dynamic foot placement work slightly worse.

Set these lines in [FootIK] section using either "FalloutPrefs.ini" or "FalloutCustom.ini" to the following values:
fOnOffGain=0.01
bFootPlacementOn=0
fPelvisUpDownBias=0
fPelvisOffsetDamping=0
fOriginalGroundHeightMS=0

Solution #3:
[RagdollAnim]
bFootIK = 0

Try capping your framerate to something lower than 120 fps.



#9
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 8,214 posts

Added as 'Issue - Bobbing NPCs' to the "Graphics Problems" section of  the wiki "Fallout NV Mod Conflict Troubleshooting" article.

 

-Dubious-



#10
nognow

nognow

    Regular

  • Supporter
  • PipPip
  • 97 posts

I apologize. Yes, "Foot", not "Leg".

Also, according to NVTF's author:

Solution #1:
Make sure that your in-game framerate is capped below 120 FPS. Better use some fps counter to double check if it really is below 120.

Solution #2:
That is a trade off between player foot dynamic placement efficiency and the absence of foot bouncing glitches for NPCs. It eliminates NPCs bouncing glitches almost entirely, but also makes player dynamic foot placement work slightly worse.

Set these lines in [FootIK] section using either "FalloutPrefs.ini" or "FalloutCustom.ini" to the following values:
fOnOffGain=0.01
bFootPlacementOn=0
fPelvisUpDownBias=0
fPelvisOffsetDamping=0
fOriginalGroundHeightMS=0

Solution #3:
[RagdollAnim]
bFootIK = 0

Try capping your framerate to something lower than 120 fps.

 

Added as 'Issue - Bobbing NPCs' to the "Graphics Problems" section of  the wiki "Fallout NV Mod Conflict Troubleshooting" article.

 

-Dubious-

 Capping the framerate doesn't help (I had already done it), disabling bFootPlacementOn did the trick; no need to touch the rest. 

 







Also tagged with one or more of these keywords: glitch

Page loaded in: 1.058 seconds