Jump to content

Photo

Fusion core insertion and power armor modification animations busted.

broken animations power armor crafting

  • Please log in to reply
1 reply to this topic

#1
Eranderil

Eranderil

    Journeyman

  • Premium Member
  • 31 posts

So I recently picked up Fo4 from a long break. I have had my game set to not be able to update and had a set, stable mod list. I added a few expansion packs for SimSettlements, but nothing, I thought, that should affect power armor. When I went to interact with a power armor crafting station though, I had a rude surprise awaiting me. My screen jumped out to the typical third person view... and then there stood my character. I can draw and sheath my weapon, but I can't move. I can't open any pip-boy menu, though I can save and load. 

 

I realized the issue was larger while troubleshooting. I thought a particular armor was possibly bugged due to me putting it in a display stand, so I went to get another. I always rip my power cores out of my armor, just as a paranoid precaution. I went to grab a different set and found that the same thing happened as when I interacted with a crafting station- there stood my guy, looking as smart as a box of rocks. I reloaded, and took a bit to figure out why I could get into one set of armor and not another. What I found was that if I manually put in a power core, I could board power armor without issue. I thought maybe this was the file I had pulled worsin's garage out of, so I re-installed it. No joy. So I updated game, and then updated F4se and all mods with possible updates. Still no joy.

 

Modlist;

Longer Power Lines (3x)

 

MTM-Power Radius Increased and NBL( for vault 88, new since return.)

 

Vault-tec workshop overhaul redux (new since return)

 

Sanctuary Homestead postwar edition v2.3

 

Commonwealth Conifers, no weather changes

 

Commonwealth Conifers- summer

 

Truestorms- wasteland edition

 

HUDFramework

 

SimSettlementsROTC complex city plans

 

Better Automatron weapons

 

Mr handy buzz blade increased reacherino

 

immersive scrapping

immersive scrapping money

 

WIPAG

 

Expanded settlement buildings

 

UF4P

 

AWACR

 

Companion infinite ammo and unbreakable power armor

 

Larger shipments

 

Better Junk fences

 

Place everywhere

 

underfoot rugs

 

visible companion affinity

 

Achaivements

 

Everyone's best friend

 

Hangmans ally interior appartments

 

Jamaica Plains Interior Home

 

No perk Requirements

 

Settler Sandbox Overhaul (10x)

 

Snapbeds

 

Chinese Stealth Suit

 

Craftable turret stands

 

SimSettlements 3-in-1

 

Vault Glass Repair (New since return)

 

Settlementmenumanager

 

No power armor strength cap

 

Backpacks of commonwealth

 

Extended Dialog interface

 

--- I did have in 3 expansions to Simsettlements, but as the most recent 3 additions I axed them to see if they were the problem. 

 

Things I have not yet tried- removing the other 3 new mods. I desparately do not want to attempt this, as I have a massive vault that is completely reliant on them. The glass one, thats fine, it can be removed. The others I don't know what sort of effect it would have. Mostly I am posting this here in the hopes that someone just happens to know what causes this issue. I don't think I have anything that affects animations, aside from maybe the stealth suit, and I dont think any of the new mods affect Power armor in any way, aside from worsins and awakr, but they are clear as they were an attempt to fix the issue.

 

 

 



#2
Eranderil

Eranderil

    Journeyman

  • Premium Member
  • 31 posts

Ok, figured out the guilty mod by going one by one through the list. The Guilty party is... Chinese stealth suit! Dunno why it breaks these two animations, but it does.







Also tagged with one or more of these keywords: broken animations, power armor, crafting

Page loaded in: 1.053 seconds