Jump to content


Demon’s Souls BLUS30443 Suddenly Stopped Working

No replies to this topic




  • Premium Member
  • 1 posts
For around a month, I was running Demonâs Souls with mods perfectly fine. The other day, I made a mistake and now it has stopped working.

I play Demonâs Souls with three mods in particular. They are HD font/text, disable lens flare and depth of field, and gray outline removal. All mods are found on Nexus Mods.

As stated, everything was perfect and I managed to clock around 90 hours in this game with no issues. The other night, I was browsing mods and tried to download a mod to disable depth of field. I didnât realize that the lens flare fix mod also fixed depth of field, and thatâs why I tried. After I downloaded the mod, my game starting loading slower and freezing on loading screens, as well as others. The audio started bugging out. For example, I would talk to an NPC and their dialogue would cut out, yet text for what they were saying would still show up on screen.

Of course after this, I tried to switch back to the lens flare with depth of field, and Iâve never managed to get the game working properly again.

In the beginning, I was using the BLES00932 version of the game, which I downloaded online. After multiple times of failing with that version, I decided to rip the files from my copy of Demonâs Souls on my PS3. That version of the game is BLUS30443, and itâs still not working properly.

Iâve tried a lot of different fixes and messed with all the settings in RPCS3. Iâve also tried to uninstall and reinstall the mods. It makes no sense how this used to work and suddenly does not. Installing the mods is simple and just requires that you move files to the USRDIR folder.

For the record, it seems that the game works fine with no mods installed. I say it seems because I havenât done extensive testing. The mods are pretty vital to the overall experience, and after playing so much with them, I canât go back.

Is it possible that to old files are being stored from RPCS3 or...something? Iâm so puzzled as to why this stopped working after downloading that DOF mod. Especially because Iâve started over with fresh files multiple times.

Reply to this topic


IPB skins by Skinbox
Page loaded in: 1.068 seconds