Jump to content

Photo

Having trouble with normal maps

textures normals

  • Please log in to reply
2 replies to this topic

#1
Ironman5000

Ironman5000

    Man in a Can (of beer)

  • Supporter
  • PipPipPipPipPip
  • 4,769 posts

OK so I thought I would get into some texturing again, making some hires ones as replacers but I am a bit of difficulty with the normal map making the mesh look shiney in-game.  I know there are several threads about this but I can't seem to get it right, according to several sources it's calculated through the 'channels' alpha layer - lighter are shiney, darker are dull.

 

I admit I haven't really tried messing around with channels hence my confusion, so I could do with some help on how to lower the alpha channel correctly because the few threads i've seen have too many people chipping with different methods and some don't seem to work.

 

Here is what the normal looks like in Gimp (yes this what I using) with the channels open, i'm assuming the grey area needs to be darker but I can't get it right :confused:

55309669.jpg

 

Just in case it's needed here is a screen of it in-game

screenshot1bau.jpg


Edited by Ironman5000, 31 March 2013 - 05:51 PM.


#2
Werne

Werne

    Criminal Scum

  • Members
  • PipPipPipPip
  • 1,966 posts

You know, you need to disable RGB channels in GIMP to view the alpha, otherwise it just displays a transparent RGB pic. And specular maps don't look right when they're made from a normal map, they look too plain.

 

Anyway, I think you can adjust the alpha in GIMP by changing brightness/contrast while the RGB channels are unchecked, I'd use a cca 75-85% gray, not too shiny but actually reacting to light. Alpha in your pic looks as 50-60%, kinda too glossy for leaves.

 

Though I think it would be easier to modify the diffuse, change it to grayscale, get it to look the way you want it then just import it into your normal and add it as alpha.

 

And I don't know how to do any of that in GIMP, I know what to do but I got no idea how to do it. You'll have to figure that out yourself, I got GIMP but I never really used it for anything other than viewing pics.



#3
Ironman5000

Ironman5000

    Man in a Can (of beer)

  • Supporter
  • PipPipPipPipPip
  • 4,769 posts

You know, you need to disable RGB channels in GIMP to view the alpha, otherwise it just displays a transparent RGB pic.

I see...that just shows how much I need to get used to channels :P
 
Thanks for advice, I managed to get it sorted by using Colours > Curves and lowering the alpha that way :thumbsup:


Edited by Ironman5000, 31 March 2013 - 07:52 PM.






Also tagged with one or more of these keywords: textures, normals

Page loaded in: 1.151 seconds