Jump to content

Photo

All NPC's backgrounds: "I am an Imperial guard."


  • Please log in to reply
8 replies to this topic

#1
Macbone

Macbone

    Fan

  • Supporter
  • PipPipPip
  • 251 posts

One of my plugins must be causing this error where all NPCs say "I am an Imperial guard" when I ask about their background. I searched for this error, but I couldn't find anything about it.

 

I've tried disabling a few mods, including Yet Another Guard Diversity, Imperial Legion Expansion, and Legion at the Siege of Firemoth. I haven't been able to determine the cause of the error so far.

 

My mod list:

Spoiler


Edited by zcul, Yesterday, 08:02 PM.
"list" put behind a spoiler


#2
cyran0

cyran0

    Regular

  • Members
  • PipPip
  • 53 posts

It's an official entry filtered for ID: Imperial Guard (generic guards). One of your hundreds of mods may have inadvertently tampered with that filter. That seems more plausible than the creation of an unfiltered new entry with the same text.

 

Not all NPCs report this background. LGNPC backgrounds are above this official entry, so you should see our content when in a less generic town. If not, then perhaps the unknown author did create a new entry and insert it very near the top of the list.



#3
Macbone

Macbone

    Fan

  • Supporter
  • PipPipPip
  • 251 posts

Yeah, this is happening in Seyda Neen. Hm.

 

I'm going category by category at this point. The housing mods look okay. I'm going to check the factions next.

 

Thanks for taking a look at this. I have far too many mods, and it's tough to know where this might be coming from. I suspect it's a mod I haven't used before, though, since I haven't seen this happen in past playthroughs.


Edited by Macbone, 27 January 2021 - 09:36 PM.


#4
Oblivionaddicted

Oblivionaddicted

    Resident poster

  • Members
  • PipPipPipPipPip
  • 3,030 posts

Save in front of a NPC who uses the glitchy background topic. Disable a bunch of mods, check if the problem remains etc.



#5
Macbone

Macbone

    Fan

  • Supporter
  • PipPipPip
  • 251 posts

It's an issue with Province Cyrodiil: https://www.nexusmod...44922?tab=posts

 

I disabled nearly everything looking for the source of that bug. At least I know the cause of the problem now. =)



#6
Oblivionaddicted

Oblivionaddicted

    Resident poster

  • Members
  • PipPipPipPipPip
  • 3,030 posts

You can easily fix this glitch by the way.



#7
Hiroshika13

Hiroshika13

    Stranger

  • Members
  • Pip
  • 1 posts

You can easily fix this glitch by the way.


Would you kindly enlighten us about how to easily fix the glitch? Aside from simply disabling the Province Cyrodiil mod, of course.

#8
Oblivionaddicted

Oblivionaddicted

    Resident poster

  • Members
  • PipPipPipPipPip
  • 3,030 posts

Since the mod seems to modify a vanilla topic you could load the mod with Morrowind enchanted editor select the faulty topic and remove to cancel the changes.



#9
leonardo2

leonardo2

    Reborn Old Timer

  • Members
  • PipPipPipPip
  • 1,325 posts

Since the mod seems to modify a vanilla topic you could load the mod with Morrowind enchanted editor select the faulty topic and remove to cancel the changes.

Yep, that's the easiest way to fix an issue, but it's easy to mess up things when one doesn't know how to do it properly.






IPB skins by Skinbox
Page loaded in: 1.031 seconds