Jump to content

Photo

BSA Not registering all textures

obmm bsa textures render

  • Please log in to reply
4 replies to this topic

#1
Ironman5000

Ironman5000

    Man in a Can (of beer)

  • Supporter
  • PipPipPipPipPip
  • 4,769 posts

I am working on Immersive Weapons for oblivion which needs a lot of meshes and textures, which I compiled into a BSA file using OBMM.  For some reason not all the textures are rendering though (meshes are fine), at first I thought it was because I was using medium compression but I tried again without and it still happens.

 

The BSA is 0.98gb in size, had to make a few cuts because I know the limit is 1gb and at first is was over.  I made sure all the assets are present and in the proper paths, and double checked this in BSA Commander so I can't understand what the problem is :confused:

 

Can anybody help me out at all?  



#2
Nephenee13

Nephenee13

    Life. Love. Yuri.

  • Supporter
  • PipPipPipPipPip
  • 3,513 posts

Are the texture paths unique or are they replacing vanilla textures? Also, are you sure you have it named properly so Oblivion knows to load it?

Don't wed yourself to using a BSA. If it works fine as loose files but not as a BSA, just go with loose files. Oblivion doesn't handle BSAs as well as it should, so no need to borrow trouble.



#3
Ironman5000

Ironman5000

    Man in a Can (of beer)

  • Supporter
  • PipPipPipPipPip
  • 4,769 posts

They are all unique paths and the bsa is named the same as the plugin.  

 

I really would prefer to use bsa over loose files, it just makes everything a lot tidier and it's easier for the game to read when it comes to performance.  It would really help with a mod this big.



#4
Arthmoor

Arthmoor

    Destroyer of Bugs

  • Premium Member
  • 19,987 posts

Are you sure all of the texture paths in the meshes are in the proper format?

 

Like so: textures\somefolder\someotherfolder\somefile.dds

 

Rather than: textures/somefolder/someotherfolder/somefile.dds

 

If the slash marks are wrong, they won't display from inside of a BSA. PyFFI will correct this.

 

You'll also need to be sure all of the textures have mipmaps, because the ones that don't also won't display. That's a bit harder to work out. Possibly DDSOpt will fix this, but I don't know as I've never used that.



#5
Ironman5000

Ironman5000

    Man in a Can (of beer)

  • Supporter
  • PipPipPipPipPip
  • 4,769 posts

Hmm...it turns out some of the nif paths are wrong, i'm hoping this is the case with them all and I should be good to go.  Some had an extra \, some were even trying to find the textures all the way from root drive!  And these are mods that are pretty popular so dunno how this wasn't sorted already.

 

Thanks for reminding me to check the actual nifs arthmoor :thumbsup:

 

EDIT: My BSA and all weapons are perfect now :biggrin:


Edited by Ironman5000, 07 April 2013 - 10:05 PM.






Also tagged with one or more of these keywords: obmm, bsa, textures, render

Page loaded in: 1.075 seconds