Jump to content

Photo

Mismatched Flesh Error after Edit

mismatched skin skin flesh elves elf error mismatched creation kit natural skin tones elf skin

  • Please log in to reply
18 replies to this topic

#11
SkinkFargle

SkinkFargle

    Journeyman

  • Members
  • Pip
  • 39 posts

I'm not sure how you are going about making the color change.  I just did a test and changed the values on the colorforms assigned to the Redguard race and from what I could tell the color took across face and body.  Granted I had no other mods active at the time.

 

There was no editing of the race, actors or anything else.  Just changing the value of the colorforms used by the race.

 

It must be that the Dunmer are different from Redguards, because when I checked every individual Dunmer to see that their tint data was what I desired, some had custom data. The hireling of The Drunken Huntsman, for example, had her own unique tint data. I changed it, and she still comes out with a different coloured body.

 

Perhaps you could try altering the Dark Elves or High Elves and see if you get the same error as me? If you don't, it's almost certain I have some mod installed which is causing the error, although I cleaned out the texture directory and I still get the same error.

 

Just so you all know, this is where I've edited the data:

 

Attached File  tintdata.jpg   99.96KB   8 downloads

 

It is the right place, isn't it?



#12
IsharaMeradin

IsharaMeradin

    The Pale Redguard

  • Members
  • PipPipPipPipPip
  • 10,494 posts

As far as I know that is the correct place.

I had only checked in the race menu before for the color change.  Had assumed that since the player character took on the hue that the NPCs would too.  I was wrong.  Sorry.

 

Just tried again with the Dark Elfs and while the player character will take the hues none of the NPCs will at all.  I suspect the only way to do it is to create new custom color forms, assign them to the race records, remove the old colors and go thru each actor and assign the colors as needed.

 

Indeed when I went and cleared out the old color forms on the race record and put them right back on with the modified color value and did the Ctrl+F4 thing on Jenessa after reassigning the color entry, she appeared with matching tones on face and body.

 

So despite changing the value of the color form in the CK, the race record must be keeping the old color.  This must be the reason why you get a correct face and incorrect body.  Why some change and others don't no idea...

 

Oh oh...  try this first.. I just saw it.

Open the Character pull down menu and select the option Update NPC Body Tint Colors

backup your plugin first incase it goes horribly wrong.



#13
SkinkFargle

SkinkFargle

    Journeyman

  • Members
  • Pip
  • 39 posts

Thanks, IsharaMeradin, you've been a great help.

 

But could you run through updating NPC tint data in a little more detail?

 

Do you mean start up the Command Console and type in "update NPC body tint colors"?



#14
IsharaMeradin

IsharaMeradin

    The Pale Redguard

  • Members
  • PipPipPipPipPip
  • 10,494 posts

No.  not in the console.  In the Creation Kit.  At the top there are the drop down menus (File, Edit, View, World, NavMesh, Character, Gameplay, Help).  I saw the option "Update NPC Body Tint Colors" under the Character drop down menu.  Not sure what it does but it sounds like it would do what you are wanting.



#15
SkinkFargle

SkinkFargle

    Journeyman

  • Members
  • Pip
  • 39 posts

Well, I just tried that. It said it had updated the NPC body tint data suspiciously quickly. When I went into the game, Nords were displaying blue faces!

 

Bizarre.

 

I'm afraid I may just wait for a superior modder than myself to create the natural-flesh-tone-elf-mod I want, because apparently I keep finding ways to screw it up!

 

That or I'll just start from scratch.

 

Sigh.

 

Edit: Oh, and now apparently even without that mod installed, Nords now have blue faces.

 

This is so frustrating.

 

Attached File  nords blue.jpg   84.73KB   4 downloads


Edited by SkinkFargle, 09 May 2013 - 02:21 PM.


#16
IsharaMeradin

IsharaMeradin

    The Pale Redguard

  • Members
  • PipPipPipPipPip
  • 10,494 posts

I bet it is a double edge sword.  If you update the body tint color, then the faces think they are wrong and have something akin to the "grey face bug".  So you'd need to do the facegendata thing on every NPC even tho you only wanted to change the one race...



#17
SkinkFargle

SkinkFargle

    Journeyman

  • Members
  • Pip
  • 39 posts

IsharaMeradin, on 09 May 2013 - 15:46, said:
I bet it is a double edge sword. If you update the body tint color, then the faces think they are wrong and have something akin to the "grey face bug". So you'd need to do the facegendata thing on every NPC even tho you only wanted to change the one race...


Oddly enough, even without my Flesh Elf mod installed, certain Nords are still displaying blue face.

I'm going to try to save their facegen data. Hopefully that will help. It seems to be effecting only Lively Inns and Taverns NPCs, though.

I hope I can fix this...

Edit: Okay, so I export the facegen data for all LIAT NPCs with CTRL+F4, I update NPC body tints and yet they're still blue in the face.

I no longer have my flesh elf mod installed, so it shouldn't be a problem. All elves are now displaying as normal again.

I have no idea why Nords shouldn't be displaying correctly.

I'm truly at the end of tether. :wallbash:

Edited by SkinkFargle, 09 May 2013 - 03:14 PM.


#18
SkinkFargle

SkinkFargle

    Journeyman

  • Members
  • Pip
  • 39 posts

Okay, so I recently attempted to alter an existing mod to see if it's a problem with the particular way I'd  been doing it or with my save states or some other mystery.

 

So I altered Ethereal Elven Overhaul as desired, and I found it didn't alter the Elves at all. Not even their faces. Is there any explanation for that?



#19
SkinkFargle

SkinkFargle

    Journeyman

  • Members
  • Pip
  • 39 posts

If anybody is still interested, this is the effect I want for all High and Dark Elf NPCs, but can only achieve for player characters:

 

Attached File  Natural Flesh Tones for High Elves and Dark Elves.jpg   153.92KB   5 downloads

 

And here is my process:

 

1. Open Race menu.

2. Alter tint data as desired under Tinting tab.

3. Go to Head Parts directory.

4. Create copies of human eyes, assign to desired race. Remove certain eye options.

5. Make sure that all NPCs are displaying desired flesh colour in CK preview window in Actor editing window.

6. CTRL+4 all High Elf and Dark Elf NPCs.

7. Load beneath Ethereal Elven Overhaul.

 

Result: Working faces but mismatched colour on the bodies.

 

If anybody could take this in hand and find a way to make it work, I'd be very appreciative.







Also tagged with one or more of these keywords: mismatched skin, skin, flesh, elves, elf, error, mismatched, creation kit, natural skin tones, elf skin

IPB skins by Skinbox
Page loaded in: 1.231 seconds