Jump to content

Photo

sound and the geck


  • Please log in to reply
12 replies to this topic

#1
Rendalli

Rendalli

    Old hand

  • Members
  • PipPipPip
  • 585 posts
hi there i have search all over in these forums and all over the net without any luck in finding out how to import custom sounds into the geck. ive been working on a mod and need to be able to add custom sounds to it. please help.

#2
Skree000

Skree000

    Procrastinator

  • Members
  • PipPipPipPip
  • 2,149 posts
ok first in the objects list, go to the 'Sounds' list in the long long list of stuff. its near the bottom somewhere.
once you find that, youll see a huge list of sounds. These arent actually the sound 'files' (ie. wavs) they are useable GECK references that point towards wav files on your computer.

so what you have to do to get custom sounds working is this:

1. get your wav file(s) and place them somewhere in the fallout3/data/sounds/fx/ folder structure. (ideally make your own folder in there named after you or your mod)
2. in GECK, right click and edit one of the existing sounds. ideally find one of the same type as what you want. ie, to make a new gunshot sound, use an existing gunshot sound
3. make your modifications to that sound, point it towards your own personal .wav sound file. Click OK, and it will ask, 'create a new form?' say YES, then make note of the ID
now when you are in your art&sound tab (if its a weapon or something) just click on the sound buttons and find your new sound!

dont forget to save!

#3
Rendalli

Rendalli

    Old hand

  • Members
  • PipPipPip
  • 585 posts
i love you skree you are a lifesaver.

oh btw i love yer bf2142 mod =P

#4
Skree000

Skree000

    Procrastinator

  • Members
  • PipPipPipPip
  • 2,149 posts
awww shucks *blushes*

#5
PelzartigTod

PelzartigTod

    Stranger

  • Members
  • Pip
  • 8 posts
Ok, I'm having the same problem, and even when I do what you say, I still can't hear the gun fire sound in-game. I have a MG42 mod that I was editting the stats of with GECK so the gun was more like the real deal. I got to the art and sounds section, and it already had custom sound effects to start with, but they didn't satisfy me. I looked up what I needed to do to add my own, and I learned that I needed a .wav file, so I downloaded the audio from a Youtube video with high quality sound of the MG3 firing from Battlefield: Bad Company 2. I editted the audio in Windows Movie Maker to where there was only one round firing like it needs to be for using in GECK. After that, I converted the file from .wma to .wav. I put my own file in the sound/fx/wpn folder and deleted the original audio file that came with the mod. Finally, I opened GECK, clicked miscellaneous, then sound. I created my own form called WPNMaschinengewehr42Fire and selected my audio file for the sound to be used. For some reason, when I click play to preview the sound, it doesn't play anything. I didn't change any of the other things below while creating the form, and I don't know if that's the problem. Then, I created the form, found the gun, chose to edit the gun, went to the art and sound section, changed both of the two gun fire sound effect options to my custom sound, then I OK'd it and saved the .esp.

Now here's where I get mad. I made sure the .esp was selected and ready to use in Fallout 3. Then when I find the gun in-game, I whip it out of my pants, and BAM! NO SOUND! All of the sound besides the gun fire is completely fine and still working (Ex.: Reloading, pickup, drop, equip, unequip). If you somehow help me fix this, you'll probably be my best online friend of all time!

Oh, and by the way, I tried the same thing with other guns, and none of them worked correctly either. I don't know what the deal is, but I think GECK hates me pretty hardcore.

#6
dimandrid

dimandrid

    Stranger

  • Members
  • Pip
  • 2 posts

Ok, I'm having the same problem, and even when I do what you say, I still can't hear the gun fire sound in-game. I have a MG42 mod that I was editting the stats of with GECK so the gun was more like the real deal. I got to the art and sounds section, and it already had custom sound effects to start with, but they didn't satisfy me. I looked up what I needed to do to add my own, and I learned that I needed a .wav file, so I downloaded the audio from a Youtube video with high quality sound of the MG3 firing from Battlefield: Bad Company 2. I editted the audio in Windows Movie Maker to where there was only one round firing like it needs to be for using in GECK. After that, I converted the file from .wma to .wav. I put my own file in the sound/fx/wpn folder and deleted the original audio file that came with the mod. Finally, I opened GECK, clicked miscellaneous, then sound. I created my own form called WPNMaschinengewehr42Fire and selected my audio file for the sound to be used. For some reason, when I click play to preview the sound, it doesn't play anything. I didn't change any of the other things below while creating the form, and I don't know if that's the problem. Then, I created the form, found the gun, chose to edit the gun, went to the art and sound section, changed both of the two gun fire sound effect options to my custom sound, then I OK'd it and saved the .esp.

Now here's where I get mad. I made sure the .esp was selected and ready to use in Fallout 3. Then when I find the gun in-game, I whip it out of my pants, and BAM! NO SOUND! All of the sound besides the gun fire is completely fine and still working (Ex.: Reloading, pickup, drop, equip, unequip). If you somehow help me fix this, you'll probably be my best online friend of all time!

Oh, and by the way, I tried the same thing with other guns, and none of them worked correctly either. I don't know what the deal is, but I think GECK hates me pretty hardcore.


You must have the same sample rate as other files, it must be 44100 Hz, Mono and 16 of bit depth

#7
elettronicopazzo

elettronicopazzo

    Stranger

  • Members
  • Pip
  • 2 posts
Tell me, what if i want to make a brand new sound instead of editing an existing one? i want to make my weapon sound unique

#8
TerribleAim

TerribleAim

    Stranger

  • Members
  • Pip
  • 3 posts

Tell me, what if i want to make a brand new sound instead of editing an existing one? i want to make my weapon sound unique

I recommend using a program like Audacity to record any sound you want, and you can easily place it into the game. 



#9
TerribleAim

TerribleAim

    Stranger

  • Members
  • Pip
  • 3 posts

Ok, I'm having the same problem, and even when I do what you say, I still can't hear the gun fire sound in-game. I have a MG42 mod that I was editting the stats of with GECK so the gun was more like the real deal. I got to the art and sounds section, and it already had custom sound effects to start with, but they didn't satisfy me. I looked up what I needed to do to add my own, and I learned that I needed a .wav file, so I downloaded the audio from a Youtube video with high quality sound of the MG3 firing from Battlefield: Bad Company 2. I editted the audio in Windows Movie Maker to where there was only one round firing like it needs to be for using in GECK. After that, I converted the file from .wma to .wav. I put my own file in the sound/fx/wpn folder and deleted the original audio file that came with the mod. Finally, I opened GECK, clicked miscellaneous, then sound. I created my own form called WPNMaschinengewehr42Fire and selected my audio file for the sound to be used. For some reason, when I click play to preview the sound, it doesn't play anything. I didn't change any of the other things below while creating the form, and I don't know if that's the problem. Then, I created the form, found the gun, chose to edit the gun, went to the art and sound section, changed both of the two gun fire sound effect options to my custom sound, then I OK'd it and saved the .esp.

Now here's where I get mad. I made sure the .esp was selected and ready to use in Fallout 3. Then when I find the gun in-game, I whip it out of my pants, and BAM! NO SOUND! All of the sound besides the gun fire is completely fine and still working (Ex.: Reloading, pickup, drop, equip, unequip). If you somehow help me fix this, you'll probably be my best online friend of all time!

Oh, and by the way, I tried the same thing with other guns, and none of them worked correctly either. I don't know what the deal is, but I think GECK hates me pretty hardcore.


You must have the same sample rate as other files, it must be 44100 Hz, Mono and 16 of bit depth

I made sure my file was set to these specs, but it still won't work. Is it because it is a .wav?



#10
MonsterMonkey

MonsterMonkey

    Fan

  • Members
  • PipPipPip
  • 446 posts

I have the same problem here, it's a complete non-sense i'have tries every Wav forms (Window PCM, ADPCM, ACM Waveform) none is working.

 

Ihave extracted sounds from the BSA and converted my files to the exact same sampling rate, not working either...

 

Renamed the same as vanilla files............... not working !!!!!!!!!!!!!!!!!!!!!!!!

 

WTF






IPB skins by Skinbox
Page loaded in: 1.025 seconds